]> git.pld-linux.org Git - packages/ming.git/blob - ming.spec
- check-files cleanup
[packages/ming.git] / ming.spec
1 %include        /usr/lib/rpm/macros.perl
2 Summary:        Ming - an SWF output library
3 Summary(pl):    Ming - biblioteka do produkcji plików SWF
4 Name:           ming
5 Version:        0.2a
6 Release:        11
7 License:        LGPL
8 Group:          Libraries
9 Source0:        http://www.opaque.net/ming/%{name}-%{version}.tgz
10 # Source0-md5:  72b25da0af28d9cb025c2aaf3fd0185c
11 Patch0:         %{name}-dynamic-exts.patch
12 Patch1:         %{name}-soname.patch
13 Patch2:         %{name}-python.patch
14 Patch3:         %{name}-c++.patch
15 Patch4:         %{name}-types.patch
16 URL:            http://www.opaque.net/ming/
17 BuildRequires:  python-devel
18 BuildRequires:  rpm-perlprov >= 4.0.2-24
19 BuildRequires:  zlib-devel
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 Ming is a C library for generating SWF ("Flash") format movies, plus a
24 set of wrappers for using the library from c++ and popular scripting
25 languages like PHP, Python, and Ruby.
26
27 %description -l pl
28 Ming jest bibliotek± w C do generowania animacji w formacie SWF
29 ("Flash") wraz z zestawem wrapperów do u¿ywania jej z C++ i
30 popularnymi jêzykami skryptowymi, takimi jak PHP, Python i Ruby.
31
32 %package devel
33 Summary:        Ming development files
34 Summary(pl):    Pliki dla programistów Ming
35 Group:          Development/Libraries
36 Requires:       %{name} = %{version}-%{release}
37
38 %description devel
39 Header files for ming library (C and C++).
40
41 %description devel -l pl
42 Pliki nag³ówkowe dla biblioteki ming (do C i C++).
43
44 %package -n perl-ming
45 Summary:        Ming perl module
46 Summary(pl):    Modu³ perla Ming
47 Group:          Development/Languages/Perl
48 Requires:       %{name} = %{version}-%{release}
49 Obsoletes:      ming-perl
50
51 %description -n perl-ming
52 Ming perl module - perl wrapper for Ming library.
53
54 %description -n perl-ming -l pl
55 Modu³ perla Ming - perlowy wrapper do biblioteki Ming.
56
57 %package -n python-ming
58 Summary:        Ming Python module
59 Summary(pl):    Modu³ biblioteki Ming dla jêzyka Python
60 Group:          Development/Languages/Perl
61 Requires:       %{name} = %{version}-%{release}
62 %pyrequires_eq  python-libs
63
64 %description -n python-ming
65 Ming Python module.
66
67 %description -n python-ming -l pl
68 Modu³ biblioteki Ming dla jêzyka Python.
69
70 %package utils
71 Summary:        Ming utilities
72 Summary(pl):    Narzêdzia Ming
73 Group:          Applications/File
74
75 %description utils
76 Ming utilities:
77 - listswf - swf format disassembler
78 - listfdb - show contents of fdb font file
79 - makefdb - rip fdb font definition files out of a generator template
80   file
81 - swftophp - attempt to make a php/ming script out of an swf file
82
83 %description utils -l pl
84 Narzêdzia Ming:
85 - listswf - disasembler plików swf
86 - listfdb - pokazuje zawarto¶æ plików fontów fdb
87 - makefdb - wyci±ga pliki definicji fontów fdb z pliku generatora
88 - swftophp - próbuje zrobiæ skrypt php/ming z pliku swf
89
90 %prep
91 %setup -q
92 %patch0 -p1
93 %patch1 -p1
94 %patch2 -p1
95 %patch3 -p1
96 %patch4 -p1
97
98 %build
99 %{__make} \
100         CC="%{__cc}" \
101         LIBDIR=%{_libdir} \
102         CFLAGS="%{rpmcflags} -fPIC"
103
104 #%%{__make} -C java_ext
105
106 cd perl_ext
107 %{__perl} Makefile.PL \
108         INSTALLDIRS=vendor
109 %{__make} \
110         OPTIMIZE="%{rpmcflags}"
111 cd ..
112
113 %{__make} -C py_ext \
114         CC="%{__cc}" \
115         CFLAGS="%{rpmcflags}" \
116         PYINCDIR=%{py_incdir}
117
118 #%%{__make} -C rb_ext
119
120 cd util
121 %{__make} listswf listaction swftophp makefdb \
122         CC="%{__cc} %{rpmcflags}"
123
124 %{__cc} %{rpmcflags} -o listfdb listfdb.c
125
126 %install
127 rm -rf $RPM_BUILD_ROOT
128 install -d $RPM_BUILD_ROOT{%{_bindir},%{py_sitedir}}
129
130 %{__make} install \
131         LIBDIR=$RPM_BUILD_ROOT%{_libdir} \
132         PREFIX=$RPM_BUILD_ROOT%{_prefix}
133
134 %{__make} -C perl_ext install \
135         DESTDIR=$RPM_BUILD_ROOT
136
137 %{__make} -C py_ext install \
138         DESTDIR=$RPM_BUILD_ROOT \
139         PYLIBDIR=$RPM_BUILD_ROOT%{py_libdir}
140 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
141 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
142
143 install util/{listswf,listaction,listfdb,makefdb,swftophp} $RPM_BUILD_ROOT%{_bindir}
144 rm -f $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
145 rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/SWF/.packlist
146 rm -f $RPM_BUILD_ROOT%{py_sitedir}/ming.py
147
148 %clean
149 rm -rf $RPM_BUILD_ROOT
150
151 %post   -p /sbin/ldconfig
152 %postun -p /sbin/ldconfig
153
154 %files
155 %defattr(644,root,root,755)
156 %doc CHANGES CREDITS README TODO
157 %attr(755,root,root) %{_libdir}/libming.so.*.*
158
159 %files devel
160 %defattr(644,root,root,755)
161 %attr(755,root,root) %{_libdir}/libming.so
162 %{_includedir}/ming.h
163 %{_includedir}/mingpp.h
164
165 %files -n perl-ming
166 %defattr(644,root,root,755)
167 %doc perl_ext/{README,TODO}
168 %{perl_vendorarch}/SWF.pm
169 %{perl_vendorarch}/SWF
170 %dir %{perl_vendorarch}/auto/SWF
171 %{perl_vendorarch}/auto/SWF/SWF.bs
172 %attr(755,root,root) %{perl_vendorarch}/auto/SWF/SWF.so
173 %{_mandir}/man3/SWF*
174
175 %files -n python-ming
176 %defattr(644,root,root,755)
177 %doc py_ext/{README,TODO}
178 %attr(755,root,root) %{py_sitedir}/*.so
179 %{py_sitedir}/*.py[co]
180
181 %files utils
182 %defattr(644,root,root,755)
183 %doc util/{README,TODO}
184 %attr(755,root,root) %{_bindir}/*
This page took 0.08042 seconds and 3 git commands to generate.