]> git.pld-linux.org Git - packages/microcode-data-intel.git/commitdiff
- rel 2; use ucode format which is directly accessed by kernel module (no need for... auto/th/microcode-data-intel-20111110-2
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Sun, 27 May 2012 07:24:36 +0000 (07:24 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    intel-microcode2ucode.c -> 1.1
    microcode-data-intel.spec -> 1.11

intel-microcode2ucode.c [new file with mode: 0644]
microcode-data-intel.spec

diff --git a/intel-microcode2ucode.c b/intel-microcode2ucode.c
new file mode 100644 (file)
index 0000000..caad032
--- /dev/null
@@ -0,0 +1,163 @@
+/*
+ * Convert Intel microcode.dat into individual ucode files
+ * named: intel-ucode/$family-$model-$stepping
+ *
+ * The subdir intel-ucode/ is created in the current working
+ * directory. We get multiple ucodes in the same file, so they
+ * are appended to an existing file. Make sure the directory
+ * is empty before every run of the converter.
+ *
+ * Kay Sievers <kay.sievers@vrfy.org>
+ */
+
+
+#ifndef _GNU_SOURCE
+# define _GNU_SOURCE 1
+#endif
+
+#include <stdio.h>
+#include <unistd.h>
+#include <stdlib.h>
+#include <string.h>
+#include <time.h>
+#include <limits.h>
+#include <stdbool.h>
+#include <inttypes.h>
+#include <fcntl.h>
+#include <errno.h>
+#include <sys/stat.h>
+
+struct microcode_header_intel {
+       unsigned int hdrver;
+       unsigned int rev;
+       unsigned int date;
+       unsigned int sig;
+       unsigned int cksum;
+       unsigned int ldrver;
+       unsigned int pf;
+       unsigned int datasize;
+       unsigned int totalsize;
+       unsigned int reserved[3];
+};
+
+union mcbuf {
+       struct microcode_header_intel hdr;
+       unsigned int i[0];
+       char c[0];
+};
+
+int main(int argc, char *argv[])
+{
+       char *filename = "/lib/firmware/microcode.dat";
+       FILE *f;
+       char line[LINE_MAX];
+       char buf[4000000];
+       union mcbuf *mc;
+       size_t bufsize, count, start;
+       int rc = EXIT_SUCCESS;
+
+       if (argv[1] != NULL)
+               filename = argv[1];
+
+       count = 0;
+       mc = (union mcbuf *) buf;
+       f = fopen(filename, "re");
+       if (f == NULL) {
+               printf("open %s: %m\n", filename);
+               rc = EXIT_FAILURE;
+               goto out;
+       }
+
+       while (fgets(line, sizeof(line), f) != NULL) {
+               if (sscanf(line, "%x, %x, %x, %x",
+                   &mc->i[count],
+                   &mc->i[count + 1],
+                   &mc->i[count + 2],
+                   &mc->i[count + 3]) != 4)
+                       continue;
+               count += 4;
+       }
+       fclose(f);
+
+       bufsize = count * sizeof(int);
+       printf("%s: %lu(%luk) bytes, %zu integers\n",
+              filename,
+              bufsize,
+              bufsize / 1024,
+              count);
+
+       if (bufsize < sizeof(struct microcode_header_intel))
+               goto out;
+
+       mkdir("intel-ucode", 0750);
+
+       start = 0;
+       for (;;) {
+               size_t size;
+               unsigned int family, model, stepping;
+               unsigned int year, month, day;
+
+               mc = (union mcbuf *) &buf[start];
+
+               if (mc->hdr.totalsize)
+                       size = mc->hdr.totalsize;
+               else
+                       size = 2000 + sizeof(struct microcode_header_intel);
+
+               if (mc->hdr.ldrver != 1 || mc->hdr.hdrver != 1) {
+                       printf("unknown version/format:\n");
+                       rc = EXIT_FAILURE;
+                       break;
+               }
+
+               /*
+                *  0- 3 stepping
+                *  4- 7 model
+                *  8-11 family
+                * 12-13 type
+                * 16-19 extended model
+                * 20-27 extended family
+                */
+               family = (mc->hdr.sig >> 8) & 0xf;
+               if (family == 0xf)
+                       family += (mc->hdr.sig >> 20) & 0xff;
+               model = (mc->hdr.sig >> 4) & 0x0f;
+               if (family == 0x06)
+                       model += ((mc->hdr.sig >> 16) & 0x0f) << 4;
+               stepping = mc->hdr.sig & 0x0f;
+
+               year = mc->hdr.date & 0xffff;
+               month = mc->hdr.date >> 24;
+               day = (mc->hdr.date >> 16) & 0xff;
+
+               asprintf(&filename, "intel-ucode/%02x-%02x-%02x", family, model, stepping);
+               printf("\n");
+               printf("%s\n", filename);
+               printf("signature: 0x%02x\n", mc->hdr.sig);
+               printf("flags:     0x%02x\n", mc->hdr.pf);
+               printf("revision:  0x%02x\n", mc->hdr.rev);
+               printf("date:      %04x-%02x-%02x\n", year, month, day);
+               printf("size:      %zu\n", size);
+
+               f = fopen(filename, "ae");
+               if (f == NULL) {
+                       printf("open %s: %m\n", filename);
+                       rc = EXIT_FAILURE;
+                       goto out;
+               }
+               if (fwrite(mc, size, 1, f) != 1) {
+                       printf("write %s: %m\n", filename);
+                       rc = EXIT_FAILURE;
+                       goto out;
+               }
+               fclose(f);
+               free(filename);
+
+               start += size;
+               if (start >= bufsize)
+                       break;
+       }
+       printf("\n");
+out:
+       return rc;
+}
index 42a31735288a342d080722d5cd29f989d42d7e28..d52bf734c3d732a1e061e72318e540492696ffc5 100644 (file)
@@ -1,19 +1,18 @@
 Summary:       Microcode definitions for Intel processors
 Name:          microcode-data-intel
 Version:       20111110
-Release:       1
+Release:       2
 License:       INTEL SOFTWARE LICENSE AGREEMENT
 Group:         Base
 # http://downloadcenter.intel.com/, enter "processor microcode data file" to the search
 Source0:       http://downloadmirror.intel.com/20728/eng/microcode-%{version}.tgz
 # Source0-md5: ba288eb9490986513e59c5a035c93a65
+# Tool for splitting Intel's microcode file. From Fedora
+Source1:       intel-microcode2ucode.c
 Provides:      microcode-data
 ExclusiveArch: i686 pentium2 pentium3 pentium4 %{x8664}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-# nothing to put there
-%define                _enable_debug_packages  0
-
 %description
 The microcode data file for Linux contains the latest microcode
 definitions for all Intel processors.
@@ -27,14 +26,20 @@ if ! grep -q 0x00000000 microcode.dat; then
        exit 1
 fi
 
+%{__cc} %{rpmcflags} %{rpmcppflags} %{rpmldflags} -Wall -o intel-microcode2ucode %{SOURCE1}
+./intel-microcode2ucode microcode.dat > /dev/null || exit 1
+
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT/lib/firmware
-cp -a microcode.dat $RPM_BUILD_ROOT/lib/firmware/microcode.dat
+install -d $RPM_BUILD_ROOT{%{_sbindir},/lib/firmware}
+
+install intel-microcode2ucode $RPM_BUILD_ROOT%{_sbindir}
+mv intel-ucode $RPM_BUILD_ROOT/lib/firmware
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%attr(640,root,root) /lib/firmware/microcode.dat
+%attr(755,root,root) %{_sbindir}/intel-microcode2ucode
+/lib/firmware/intel-ucode
This page took 0.173325 seconds and 4 git commands to generate.