]> git.pld-linux.org Git - packages/mediastreamer.git/commitdiff
- updated to 5.3.38 auto/th/mediastreamer-5.3.38-1
authorJakub Bogusz <qboosh@pld-linux.org>
Tue, 2 Apr 2024 20:31:39 +0000 (22:31 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Tue, 2 Apr 2024 20:31:39 +0000 (22:31 +0200)
ffmpeg_5_0_fixes.patch
mediastreamer.spec

index 1d492e8e7cd7ca286b8ecb06d30c4e342c6db508..553054849e04f43cb0bfacb9ab6e65fa9ce65e0b 100644 (file)
@@ -92,8 +92,8 @@ Bug-Debian: https://bugs.debian.org/1004819
  AVCodecContext *avcodec_alloc_context3(AVCodec *codec) {
        return avcodec_alloc_context();
  }
---- mediastreamer2-5.3.29/src/videofilters/videodec.c.orig     2024-02-21 12:02:03.000000000 +0100
-+++ mediastreamer2-5.3.29/src/videofilters/videodec.c  2024-03-09 16:15:27.685733089 +0100
+--- mediastreamer2-5.3.38/src/videofilters/videodec.c.orig     2024-03-25 15:57:39.000000000 +0100
++++ mediastreamer2-5.3.38/src/videofilters/videodec.c  2024-04-02 21:59:15.943207387 +0200
 @@ -47,8 +47,8 @@
  extern void ms_ffmpeg_check_init(void);
  
@@ -201,15 +201,6 @@ Bug-Debian: https://bugs.debian.org/1004819
        return yuv_msg;
  }
  /* Bitmasks to select bits of a byte from low side */
-@@ -600,7 +606,7 @@ static unsigned char smasks[7] = {0x7f,
- static void dec_process_frame(MSFilter *f, mblk_t *inm) {
-       DecState *s = (DecState *)f->data;
--      int got_picture;
-+      int got_picture = 0;
-       /* get a picture from the input queue */
-       if (f->desc->id == MS_H263_DEC_ID) inm = skip_rfc2429_header(inm);
 @@ -649,12 +655,27 @@ static void dec_process_frame(MSFilter *
                                pkt.data = frame->b_rptr;
                                pkt.size = remain;
index abb13d56bf1d73b5d0843fcca18a83b073997427..6d0c4c5a09413d2521519681a9c3ff056012bd7e 100644 (file)
 Summary:       Audio/Video real-time streaming
 Summary(pl.UTF-8):     PrzesyƂanie strumieni audio/video w czasie rzeczywistym 
 Name:          mediastreamer
-Version:       5.3.29
+Version:       5.3.38
 Release:       1
 License:       AGPL v3+
 Group:         Libraries
 #Source0Download: https://gitlab.linphone.org/BC/public/mediastreamer2/tags
 Source0:       https://gitlab.linphone.org/BC/public/mediastreamer2/-/archive/%{version}/mediastreamer2-%{version}.tar.bz2
-# Source0-md5: 582b4e2563297e7737b7b899b66c1edb
+# Source0-md5: 0ad6f0779f03aa40603f8a9b34d82ef6
 Patch0:                build.patch
 Patch1:                %{name}-cmake-link.patch
 Patch2:                libupnp-1.14.patch
This page took 0.764664 seconds and 4 git commands to generate.