]> git.pld-linux.org Git - packages/mdds.git/commitdiff
- up to 0.6.0 auto/th/mdds-0.6.0-1
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Thu, 9 Aug 2012 12:25:02 +0000 (14:25 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Thu, 9 Aug 2012 12:25:02 +0000 (14:25 +0200)
0001-Fixes-build-breakage-on-Debian.patch [new file with mode: 0644]
0001-fix-linking-error-with-boost-1.50.patch [new file with mode: 0644]
0001-help-compiler-select-the-right-overload-of-vector-in.patch [new file with mode: 0644]
mdds.spec

diff --git a/0001-Fixes-build-breakage-on-Debian.patch b/0001-Fixes-build-breakage-on-Debian.patch
new file mode 100644 (file)
index 0000000..fd2d582
--- /dev/null
@@ -0,0 +1,24 @@
+From 770ff91820f8ed95f7ecc40b72b78ae57ee5d277 Mon Sep 17 00:00:00 2001
+From: Kohei Yoshida <kohei.yoshida@gmail.com>
+Date: Thu, 19 Jul 2012 15:05:47 -0400
+Subject: [PATCH] Fixes build breakage on Debian.
+
+---
+ include/mdds/multi_type_vector_types.hpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/include/mdds/multi_type_vector_types.hpp b/include/mdds/multi_type_vector_types.hpp
+index f27ac88..ac2b0ef 100644
+--- a/include/mdds/multi_type_vector_types.hpp
++++ b/include/mdds/multi_type_vector_types.hpp
+@@ -355,6 +355,7 @@ struct managed_element_block : public copyable_element_block<managed_element_blo
+     typedef managed_element_block<_TypeId,_Data> self_type;
+     using base_type::get;
++    using base_type::set_value;
+     using base_type::m_array;
+     managed_element_block() : base_type() {}
+-- 
+1.7.11.2
+
diff --git a/0001-fix-linking-error-with-boost-1.50.patch b/0001-fix-linking-error-with-boost-1.50.patch
new file mode 100644 (file)
index 0000000..68c4cfb
--- /dev/null
@@ -0,0 +1,27 @@
+From 09937e5d6b4b82efbff40da2aa50fb02f2250bb2 Mon Sep 17 00:00:00 2001
+From: David Tardon <dtardon@redhat.com>
+Date: Sat, 28 Jul 2012 14:32:47 +0200
+Subject: [PATCH] fix linking error with boost 1.50
+
+---
+ include/mdds/mixed_type_matrix_storage.hpp | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/include/mdds/mixed_type_matrix_storage.hpp b/include/mdds/mixed_type_matrix_storage.hpp
+index fa0bf25..bb4e354 100644
+--- a/include/mdds/mixed_type_matrix_storage.hpp
++++ b/include/mdds/mixed_type_matrix_storage.hpp
+@@ -32,6 +32,10 @@
+ #include <boost/ptr_container/ptr_vector.hpp>
+ #include <boost/ptr_container/ptr_map.hpp>
++// Boost.Pool indirectly pulls in Boost.System, causing linking error
++// with Boost 1.50, because some (deprecated) symbols from System are
++// not found.
++#define BOOST_SYSTEM_NO_DEPRECATED
+ #include <boost/pool/object_pool.hpp>
+ namespace mdds {
+-- 
+1.7.11.2
+
diff --git a/0001-help-compiler-select-the-right-overload-of-vector-in.patch b/0001-help-compiler-select-the-right-overload-of-vector-in.patch
new file mode 100644 (file)
index 0000000..03cf1c3
--- /dev/null
@@ -0,0 +1,52 @@
+From 900cbea3ec067833b4284584f6dfa5502dc36de8 Mon Sep 17 00:00:00 2001
+From: David Tardon <dtardon@redhat.com>
+Date: Fri, 20 Jul 2012 10:30:38 +0200
+Subject: [PATCH] help compiler select the right overload of vector::insert
+
+---
+ include/mdds/multi_type_vector_def.inl | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/include/mdds/multi_type_vector_def.inl b/include/mdds/multi_type_vector_def.inl
+index 252a260..fb72070 100644
+--- a/include/mdds/multi_type_vector_def.inl
++++ b/include/mdds/multi_type_vector_def.inl
+@@ -1148,7 +1148,7 @@ void multi_type_vector<_CellBlockFunc>::insert_empty_impl(size_type row, size_ty
+     // Insert two new block below the current; one for the empty block being
+     // inserted, and one for the lower part of the current non-empty block.
+-    m_blocks.insert(m_blocks.begin()+block_index+1, 2, NULL);
++    m_blocks.insert(m_blocks.begin()+block_index+1, 2u, NULL);
+     m_blocks[block_index+1] = new block(length);
+     m_blocks[block_index+2] = new block(size_blk_next);
+@@ -1302,7 +1302,7 @@ void multi_type_vector<_CellBlockFunc>::insert_cells_to_middle(
+     // Insert two new blocks.
+     size_type n1 = row - start_row;
+     size_type n2 = blk->m_size - n1;
+-    m_blocks.insert(m_blocks.begin()+block_index+1, 2, NULL);
++    m_blocks.insert(m_blocks.begin()+block_index+1, 2u, NULL);
+     blk->m_size = n1;
+     m_blocks[block_index+1] = new block(length);
+@@ -1467,7 +1467,7 @@ void multi_type_vector<_CellBlockFunc>::set_cells_to_single_block(
+     assert(start_row_in_block < start_row && end_row < end_row_in_block);
+     // Insert two new blocks below the current one.
+-    m_blocks.insert(m_blocks.begin()+block_index+1, 2, NULL);
++    m_blocks.insert(m_blocks.begin()+block_index+1, 2u, NULL);
+     // first new block is for the data array being inserted.
+     size_type new_size = end_row - start_row + 1;
+@@ -1985,7 +1985,7 @@ void multi_type_vector<_CellBlockFunc>::set_empty_in_single_block(
+     // First, insert two new blocks at position past the current block.
+     size_type lower_block_size = end_row_in_block - end_row;
+-    m_blocks.insert(m_blocks.begin()+block_index+1, 2, NULL);
++    m_blocks.insert(m_blocks.begin()+block_index+1, 2u, NULL);
+     m_blocks[block_index+1] = new block(empty_block_size); // empty block.
+     m_blocks[block_index+2] = new block(lower_block_size);
+-- 
+1.7.11.2
+
index 2ed41980bebf8aad940647902c748395a7421dc3..ff1a6ca8ff098d8e2026ea2ecbc579231bd51764 100644 (file)
--- a/mdds.spec
+++ b/mdds.spec
@@ -1,12 +1,15 @@
 Summary:       A collection of multi-dimensional data structures and indexing algorithms
 Name:          mdds
-Version:       0.5.4
+Version:       0.6.0
 Release:       1
 License:       MIT
 Group:         Development/Libraries
 URL:           http://code.google.com/p/multidimalgorithm/
 Source0:       http://multidimalgorithm.googlecode.com/files/%{name}_%{version}.tar.bz2
-# Source0-md5: d33e6871e05709963d7feb48f9620900
+# Source0-md5: 3e89a35f253a4f1c7de68c57d851ef38
+Patch0:                0001-Fixes-build-breakage-on-Debian.patch
+Patch1:                0001-fix-linking-error-with-boost-1.50.patch
+Patch2:                0001-help-compiler-select-the-right-overload-of-vector-in.patch
 BuildRequires: boost-devel
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -32,6 +35,10 @@ Headers for %{name}.
 
 %prep
 %setup -q -n %{name}_%{version}
+%patch0 -p1
+%patch1 -p1
+%patch2 -p1
+
 # this is only used in tests
 sed -i -e '/^CPPFLAGS/s/-Wall.*-std/%{rpmcflags} -std/' Makefile.in
 
This page took 0.148137 seconds and 4 git commands to generate.