]> git.pld-linux.org Git - packages/mbedtls.git/blame - mbedtls.spec
- use _libexecdir for tools
[packages/mbedtls.git] / mbedtls.spec
CommitLineData
a3f8074d
JB
1Summary: Light-weight cryptographic and SSL/TLS library
2Summary(pl.UTF-8): Lekka biblioteka kryptograficzna oraz SSL/TLS
3Name: mbedtls
b069308d
JB
4Version: 3.4.0
5Release: 1
a3f8074d
JB
6License: GPL v2+
7Group: Libraries
9874b67a
JB
8#Source0Download: https://github.com/ARMmbed/mbedtls/releases
9Source0: https://github.com/ARMmbed/mbedtls/archive/v%{version}/%{name}-%{version}.tar.gz
b069308d 10# Source0-md5: 3f6c2eadc1243e9895d65c67b46eb890
543346bc 11Patch0: %{name}-config-dtls-srtp.patch
9874b67a 12URL: https://www.trustedfirmware.org/projects/mbed-tls/
b069308d 13BuildRequires: cmake >= 3.5.1
a3f8074d 14BuildRequires: doxygen
9874b67a 15BuildRequires: rpm-build >= 4.6
a3f8074d
JB
16BuildRequires: rpmbuild(macros) >= 1.605
17BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
9735fbf4
JB
19# some false positives for format-truncation(?)
20# for stringop-overflow see library/ssl_tls.c /stringop-overflow (workaround no longer works with gcc 11)
645d2dc1 21# maybe-uninitialized fails in tests/suites/test_suite_ssl.function only on i686 builder(???)
07b0e160 22%define specflags -Wno-error=format-truncation -Wno-error=stringop-overflow -Wno-error=maybe-uninitialized
59cd7fbe 23
a3f8074d
JB
24%description
25mbedTLS is a light-weight open source cryptographic and SSL/TLS
26library written in C. mbedTLS makes it easy for developers to include
27cryptographic and SSL/TLS capabilities in their (embedded)
28applications with as little hassle as possible.
29
30%description -l pl.UTF-8
31mbedTLS to lekka, mająca otwarte źródła biblioteka kryptograficzna
32oraz SSL/TLS napisana w C. mbedTLS ułatwia programistom dołączanie
33funkcji kryptograficznych i SSL/TLS do swoich (wbudowanych) aplikacji
34przy jak najmniejszym narzucie.
35
36%package devel
37Summary: Development files for mbedTLS
38Summary(pl.UTF-8): Pliki programistyczne biblioteki mbedTLS
39Group: Development/Libraries
40Requires: %{name} = %{version}-%{release}
a3f8074d
JB
41
42%description devel
43This package contains the header files for developing applications
44that use mbedTLS.
45
46%description devel -l pl.UTF-8
47Ten pakiet zawiera pliki nagłówkowe do tworzenia aplikacji
48wykorzystujących bibliotekę mbedTLS.
49
50%package static
51Summary: Static mbedTLS library
52Summary(pl.UTF-8): Statyczna biblioteka mbedTLS
53Group: Development/Libraries
54Requires: %{name}-devel = %{version}-%{release}
55
56%description static
57Static mbedTLS library.
58
59%description static -l pl.UTF-8
60Statyczna biblioteka mbedTLS.
61
875e57b3
JB
62%package apidocs
63Summary: API documentation for mbedTLS library
64Summary(pl.UTF-8): Dokumentacja API biblioteki mbedTLS
65Group: Documentation
9874b67a 66BuildArch: noarch
875e57b3
JB
67
68%description apidocs
69API documentation for mbedTLS library.
70
71%description apidocs -l pl.UTF-8
72Dokumentacja API biblioteki mbedTLS.
73
a3f8074d
JB
74%prep
75%setup -q
543346bc 76%patch0 -p1
a3f8074d
JB
77
78%build
79install -d build
80cd build
81%cmake .. \
82 -DLIB_INSTALL_DIR:PATH=%{_libdir} \
eb99b0ca
JP
83 -DUSE_SHARED_MBEDTLS_LIBRARY=ON \
84 -DGEN_FILES=OFF
a3f8074d
JB
85
86%{__make}
87%{__make} apidoc
88
89%if %{with tests}
90# Tests are not stable on 64-bit
91ctest --output-on-failure
92%endif
93
94%install
95rm -rf $RPM_BUILD_ROOT
96
97%{__make} -C build install \
95a6445e 98 CMAKE_INSTALL_PREFIX=%{_libdir} \
a3f8074d
JB
99 DESTDIR=$RPM_BUILD_ROOT
100
80553f47
JB
101install -d $RPM_BUILD_ROOT%{_libexecdir}
102%{__mv} $RPM_BUILD_ROOT%{_bindir} $RPM_BUILD_ROOT%{_libexecdir}/%{name}
95a6445e 103
a3f8074d
JB
104%clean
105rm -rf $RPM_BUILD_ROOT
106
107%post -p /sbin/ldconfig
108%postun -p /sbin/ldconfig
109
110%files
111%defattr(644,root,root,755)
95cbb035 112%doc ChangeLog LICENSE README.md
64c8d752 113%attr(755,root,root) %{_libdir}/libmbedcrypto.so.*.*.*
b069308d 114%attr(755,root,root) %ghost %{_libdir}/libmbedcrypto.so.14
a3f8074d 115%attr(755,root,root) %{_libdir}/libmbedtls.so.*.*.*
b069308d 116%attr(755,root,root) %ghost %{_libdir}/libmbedtls.so.19
64c8d752 117%attr(755,root,root) %{_libdir}/libmbedx509.so.*.*.*
b069308d 118%attr(755,root,root) %ghost %{_libdir}/libmbedx509.so.5
80553f47
JB
119%dir %{_libexecdir}/%{name}
120%attr(755,root,root) %{_libexecdir}/%{name}/aead_demo
121%attr(755,root,root) %{_libexecdir}/%{name}/benchmark
122%attr(755,root,root) %{_libexecdir}/%{name}/cert_app
123%attr(755,root,root) %{_libexecdir}/%{name}/cert_req
124%attr(755,root,root) %{_libexecdir}/%{name}/cert_write
125%attr(755,root,root) %{_libexecdir}/%{name}/cipher_aead_demo
126%attr(755,root,root) %{_libexecdir}/%{name}/crl_app
127%attr(755,root,root) %{_libexecdir}/%{name}/crypt_and_hash
128%attr(755,root,root) %{_libexecdir}/%{name}/crypto_examples
129%attr(755,root,root) %{_libexecdir}/%{name}/dh_client
130%attr(755,root,root) %{_libexecdir}/%{name}/dh_genprime
131%attr(755,root,root) %{_libexecdir}/%{name}/dh_server
132%attr(755,root,root) %{_libexecdir}/%{name}/dtls_client
133%attr(755,root,root) %{_libexecdir}/%{name}/dtls_server
134%attr(755,root,root) %{_libexecdir}/%{name}/ecdh_curve25519
135%attr(755,root,root) %{_libexecdir}/%{name}/ecdsa
136%attr(755,root,root) %{_libexecdir}/%{name}/gen_entropy
137%attr(755,root,root) %{_libexecdir}/%{name}/gen_key
138%attr(755,root,root) %{_libexecdir}/%{name}/gen_random_ctr_drbg
139%attr(755,root,root) %{_libexecdir}/%{name}/generic_sum
140%attr(755,root,root) %{_libexecdir}/%{name}/hello
141%attr(755,root,root) %{_libexecdir}/%{name}/hmac_demo
142%attr(755,root,root) %{_libexecdir}/%{name}/key_app
143%attr(755,root,root) %{_libexecdir}/%{name}/key_app_writer
144%attr(755,root,root) %{_libexecdir}/%{name}/key_ladder_demo
145%attr(755,root,root) %{_libexecdir}/%{name}/key_ladder_demo.sh
146%attr(755,root,root) %{_libexecdir}/%{name}/load_roots
147%attr(755,root,root) %{_libexecdir}/%{name}/md_hmac_demo
148%attr(755,root,root) %{_libexecdir}/%{name}/mini_client
149%attr(755,root,root) %{_libexecdir}/%{name}/mpi_demo
150%attr(755,root,root) %{_libexecdir}/%{name}/pem2der
151%attr(755,root,root) %{_libexecdir}/%{name}/pk_decrypt
152%attr(755,root,root) %{_libexecdir}/%{name}/pk_encrypt
153%attr(755,root,root) %{_libexecdir}/%{name}/pk_sign
154%attr(755,root,root) %{_libexecdir}/%{name}/pk_verify
155%attr(755,root,root) %{_libexecdir}/%{name}/psa_constant_names
156%attr(755,root,root) %{_libexecdir}/%{name}/query_compile_time_config
157%attr(755,root,root) %{_libexecdir}/%{name}/query_included_headers
158%attr(755,root,root) %{_libexecdir}/%{name}/req_app
159%attr(755,root,root) %{_libexecdir}/%{name}/rsa_decrypt
160%attr(755,root,root) %{_libexecdir}/%{name}/rsa_encrypt
161%attr(755,root,root) %{_libexecdir}/%{name}/rsa_genkey
162%attr(755,root,root) %{_libexecdir}/%{name}/rsa_sign
163%attr(755,root,root) %{_libexecdir}/%{name}/rsa_sign_pss
164%attr(755,root,root) %{_libexecdir}/%{name}/rsa_verify
165%attr(755,root,root) %{_libexecdir}/%{name}/rsa_verify_pss
166%attr(755,root,root) %{_libexecdir}/%{name}/selftest
167%attr(755,root,root) %{_libexecdir}/%{name}/ssl_client1
168%attr(755,root,root) %{_libexecdir}/%{name}/ssl_client2
169%attr(755,root,root) %{_libexecdir}/%{name}/ssl_context_info
170%attr(755,root,root) %{_libexecdir}/%{name}/ssl_fork_server
171%attr(755,root,root) %{_libexecdir}/%{name}/ssl_mail_client
172%attr(755,root,root) %{_libexecdir}/%{name}/ssl_pthread_server
173%attr(755,root,root) %{_libexecdir}/%{name}/ssl_server
174%attr(755,root,root) %{_libexecdir}/%{name}/ssl_server2
175%attr(755,root,root) %{_libexecdir}/%{name}/strerror
176%attr(755,root,root) %{_libexecdir}/%{name}/udp_proxy
177%attr(755,root,root) %{_libexecdir}/%{name}/zeroize
a3f8074d
JB
178
179%files devel
180%defattr(644,root,root,755)
64c8d752 181%attr(755,root,root) %{_libdir}/libmbedcrypto.so
a3f8074d 182%attr(755,root,root) %{_libdir}/libmbedtls.so
64c8d752
JB
183%attr(755,root,root) %{_libdir}/libmbedx509.so
184%{_includedir}/mbedtls
59cd7fbe 185%{_includedir}/psa
b069308d 186%{_libdir}/cmake/MbedTLS
a3f8074d
JB
187
188%files static
189%defattr(644,root,root,755)
95cbb035 190%{_libdir}/libmbedcrypto.a
a3f8074d 191%{_libdir}/libmbedtls.a
64c8d752 192%{_libdir}/libmbedx509.a
875e57b3
JB
193
194%files apidocs
195%defattr(644,root,root,755)
b069308d 196%doc apidoc/{search,*.css,*.html,*.js,*.png}
This page took 0.192528 seconds and 4 git commands to generate.