]> git.pld-linux.org Git - packages/mbedtls.git/blame - mbedtls.spec
- updated to 2.0.0
[packages/mbedtls.git] / mbedtls.spec
CommitLineData
a3f8074d
JB
1Summary: Light-weight cryptographic and SSL/TLS library
2Summary(pl.UTF-8): Lekka biblioteka kryptograficzna oraz SSL/TLS
3Name: mbedtls
64c8d752 4Version: 2.0.0
bf36c92e 5Release: 1
a3f8074d
JB
6License: GPL v2+
7Group: Libraries
8Source0: https://tls.mbed.org/code/releases/%{name}-%{version}-gpl.tgz
64c8d752 9# Source0-md5: 6b8246a19a7a77737856e729cc8a0952
e64b4bc8 10Patch0: %{name}-x32.patch
a3f8074d
JB
11URL: https://tls.mbed.org/
12BuildRequires: cmake >= 2.6
13BuildRequires: doxygen
14BuildRequires: rpmbuild(macros) >= 1.605
15BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17%description
18mbedTLS is a light-weight open source cryptographic and SSL/TLS
19library written in C. mbedTLS makes it easy for developers to include
20cryptographic and SSL/TLS capabilities in their (embedded)
21applications with as little hassle as possible.
22
23%description -l pl.UTF-8
24mbedTLS to lekka, mająca otwarte źródła biblioteka kryptograficzna
25oraz SSL/TLS napisana w C. mbedTLS ułatwia programistom dołączanie
26funkcji kryptograficznych i SSL/TLS do swoich (wbudowanych) aplikacji
27przy jak najmniejszym narzucie.
28
29%package devel
30Summary: Development files for mbedTLS
31Summary(pl.UTF-8): Pliki programistyczne biblioteki mbedTLS
32Group: Development/Libraries
33Requires: %{name} = %{version}-%{release}
a3f8074d
JB
34
35%description devel
36This package contains the header files for developing applications
37that use mbedTLS.
38
39%description devel -l pl.UTF-8
40Ten pakiet zawiera pliki nagłówkowe do tworzenia aplikacji
41wykorzystujących bibliotekę mbedTLS.
42
43%package static
44Summary: Static mbedTLS library
45Summary(pl.UTF-8): Statyczna biblioteka mbedTLS
46Group: Development/Libraries
47Requires: %{name}-devel = %{version}-%{release}
48
49%description static
50Static mbedTLS library.
51
52%description static -l pl.UTF-8
53Statyczna biblioteka mbedTLS.
54
55%prep
56%setup -q
e64b4bc8 57%patch0 -p1
a3f8074d
JB
58
59%build
60install -d build
61cd build
62%cmake .. \
63 -DLIB_INSTALL_DIR:PATH=%{_libdir} \
64 -DUSE_SHARED_MBEDTLS_LIBRARY:BOOL=1
65
66%{__make}
67%{__make} apidoc
68
69%if %{with tests}
70# Tests are not stable on 64-bit
71ctest --output-on-failure
72%endif
73
74%install
75rm -rf $RPM_BUILD_ROOT
76
77%{__make} -C build install \
78 DESTDIR=$RPM_BUILD_ROOT
79
80install -d $RPM_BUILD_ROOT%{_libdir}
81mv $RPM_BUILD_ROOT%{_bindir} $RPM_BUILD_ROOT%{_libdir}/%{name}
82
83%clean
84rm -rf $RPM_BUILD_ROOT
85
86%post -p /sbin/ldconfig
87%postun -p /sbin/ldconfig
88
89%files
90%defattr(644,root,root,755)
91%doc ChangeLog README.rst
64c8d752
JB
92%attr(755,root,root) %{_libdir}/libmbedcrypto.so.*.*.*
93%attr(755,root,root) %ghost %{_libdir}/libmbedcrypto.so.0
a3f8074d 94%attr(755,root,root) %{_libdir}/libmbedtls.so.*.*.*
64c8d752
JB
95%attr(755,root,root) %ghost %{_libdir}/libmbedtls.so.10
96%attr(755,root,root) %{_libdir}/libmbedx509.so.*.*.*
97%attr(755,root,root) %ghost %{_libdir}/libmbedx509.so.0
a3f8074d
JB
98%dir %{_libdir}/%{name}
99%attr(755,root,root) %{_libdir}/%{name}/aescrypt2
100%attr(755,root,root) %{_libdir}/%{name}/benchmark
101%attr(755,root,root) %{_libdir}/%{name}/cert_app
102%attr(755,root,root) %{_libdir}/%{name}/cert_req
103%attr(755,root,root) %{_libdir}/%{name}/cert_write
104%attr(755,root,root) %{_libdir}/%{name}/crl_app
105%attr(755,root,root) %{_libdir}/%{name}/crypt_and_hash
106%attr(755,root,root) %{_libdir}/%{name}/dh_client
107%attr(755,root,root) %{_libdir}/%{name}/dh_genprime
108%attr(755,root,root) %{_libdir}/%{name}/dh_server
64c8d752
JB
109%attr(755,root,root) %{_libdir}/%{name}/dtls_client
110%attr(755,root,root) %{_libdir}/%{name}/dtls_server
a3f8074d
JB
111%attr(755,root,root) %{_libdir}/%{name}/gen_entropy
112%attr(755,root,root) %{_libdir}/%{name}/gen_key
113%attr(755,root,root) %{_libdir}/%{name}/gen_random_ctr_drbg
114%attr(755,root,root) %{_libdir}/%{name}/gen_random_havege
115%attr(755,root,root) %{_libdir}/%{name}/generic_sum
116%attr(755,root,root) %{_libdir}/%{name}/hello
117%attr(755,root,root) %{_libdir}/%{name}/key_app
bf36c92e 118%attr(755,root,root) %{_libdir}/%{name}/mini_client
a3f8074d 119%attr(755,root,root) %{_libdir}/%{name}/mpi_demo
a3f8074d
JB
120%attr(755,root,root) %{_libdir}/%{name}/pem2der
121%attr(755,root,root) %{_libdir}/%{name}/pk_decrypt
122%attr(755,root,root) %{_libdir}/%{name}/pk_encrypt
123%attr(755,root,root) %{_libdir}/%{name}/pk_sign
124%attr(755,root,root) %{_libdir}/%{name}/pk_verify
125%attr(755,root,root) %{_libdir}/%{name}/req_app
126%attr(755,root,root) %{_libdir}/%{name}/rsa_decrypt
127%attr(755,root,root) %{_libdir}/%{name}/rsa_encrypt
128%attr(755,root,root) %{_libdir}/%{name}/rsa_genkey
129%attr(755,root,root) %{_libdir}/%{name}/rsa_sign
130%attr(755,root,root) %{_libdir}/%{name}/rsa_verify
131%attr(755,root,root) %{_libdir}/%{name}/selftest
a3f8074d
JB
132%attr(755,root,root) %{_libdir}/%{name}/ssl_cert_test
133%attr(755,root,root) %{_libdir}/%{name}/ssl_client1
134%attr(755,root,root) %{_libdir}/%{name}/ssl_client2
135%attr(755,root,root) %{_libdir}/%{name}/ssl_fork_server
136%attr(755,root,root) %{_libdir}/%{name}/ssl_mail_client
137%attr(755,root,root) %{_libdir}/%{name}/ssl_pthread_server
138%attr(755,root,root) %{_libdir}/%{name}/ssl_server
a3f8074d 139%attr(755,root,root) %{_libdir}/%{name}/strerror
64c8d752 140%attr(755,root,root) %{_libdir}/%{name}/udp_proxy
a3f8074d
JB
141
142%files devel
143%defattr(644,root,root,755)
144%doc apidoc/*
64c8d752 145%attr(755,root,root) %{_libdir}/libmbedcrypto.so
a3f8074d 146%attr(755,root,root) %{_libdir}/libmbedtls.so
64c8d752
JB
147%attr(755,root,root) %{_libdir}/libmbedx509.so
148%{_includedir}/mbedtls
a3f8074d
JB
149
150%files static
151%defattr(644,root,root,755)
152%{_libdir}/libmbedtls.a
64c8d752 153%{_libdir}/libmbedx509.a
This page took 0.280706 seconds and 4 git commands to generate.