]> git.pld-linux.org Git - packages/mate-session-manager.git/blob - mate-session-manager.spec
up to 1.10.2
[packages/mate-session-manager.git] / mate-session-manager.spec
1 #
2 # TODO
3 # - Terminal=true, depends on mate-terminal, but probably should take preferred terminal application
4 # mate-session[4970]: WARNING: Could not launch application 'nvidia-settings.desktop': Unable to start application: Failed to execute child process "xdg-terminal" (No such file or directory)
5
6 # Conditional build:
7 %bcond_without  apidocs # DocBook docs
8 %bcond_with     gtk3    # use GTK+ 3.x instead of 2.x
9 %bcond_without  systemd # systemd support for default (when systemd is not running fallback to ConsoleKit)
10 %bcond_with     upower  # UPower suspend/hibernate support (0.9.x only)
11
12 Summary:        MATE Desktop session manager
13 Summary(pl.UTF-8):      Zarządca sesji środowiska MATE Desktop
14 Name:           mate-session-manager
15 Version:        1.10.2
16 Release:        1
17 License:        GPL v2+
18 Group:          X11/Applications
19 Source0:        http://pub.mate-desktop.org/releases/1.10/%{name}-%{version}.tar.xz
20 # Source0-md5:  245301a55c7d0a76ce5a6cdc8f5d2d18
21 Patch0:         %{name}-en_us_suspend_hotkey.patch
22 URL:            http://wiki.mate-desktop.org/mate-session-manager
23 BuildRequires:  autoconf >= 2.53
24 BuildRequires:  automake >= 1:1.9
25 BuildRequires:  dbus-glib-devel >= 0.76
26 BuildRequires:  desktop-file-utils
27 BuildRequires:  glib2-devel >= 1:2.36.0
28 %{!?with_gtk3:BuildRequires:    gtk+2-devel >= 2:2.24.0}
29 %{?with_gtk3:BuildRequires:     gtk+3-devel >= 3.0.0}
30 BuildRequires:  intltool >= 0.40.0
31 BuildRequires:  libtool >= 1:1.4.3
32 %{?with_apidocs:BuildRequires:  libxslt-progs}
33 BuildRequires:  mate-common
34 BuildRequires:  mate-desktop-devel >= 1.9.3
35 BuildRequires:  pango-devel
36 BuildRequires:  pangox-compat-devel
37 BuildRequires:  pkgconfig
38 %{?with_systemd:BuildRequires:  systemd-devel >= 1:183}
39 BuildRequires:  tar >= 1:1.22
40 %{?with_upower:BuildRequires:   upower-devel >= 0.9.0}
41 %{?with_apidocs:BuildRequires:  xmlto}
42 BuildRequires:  xorg-lib-libICE-devel
43 BuildRequires:  xorg-lib-libSM-devel
44 BuildRequires:  xorg-lib-libXau-devel
45 BuildRequires:  xorg-lib-libXext-devel
46 BuildRequires:  xorg-lib-libXrender-devel
47 BuildRequires:  xorg-lib-libXtst-devel
48 BuildRequires:  xz
49 # needed to satisfy 'filemanager' component (may be changed if alternatives available)
50 Requires:       caja
51 Requires:       dbus-glib >= 0.76
52 Requires:       glib2 >= 1:2.36.0
53 Requires:       gsettings-desktop-schemas
54 %{!?with_gtk3:Requires: gtk+2 >= 2:2.24.0}
55 %{?with_gtk3:Requires:  gtk+3 >= 3.0.0}
56 Requires:       gtk-update-icon-cache
57 Requires:       hicolor-icon-theme
58 # needed to satisfy 'windowmanager' component (may be changed if alternatives available)
59 Requires:       marco
60 Requires:       mate-desktop >= 1.9.3
61 # needed to satisfy 'panel' component (may be changed if alternatives available)
62 Requires:       mate-panel
63 %{?with_upower:Requires:        upower-libs >= 0.9.0}
64 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
65
66 %description
67 MATE Desktop session manager.
68
69 %description -l pl.UTF-8
70 Zarządca sesji środowiska MATE Desktop.
71
72 %package apidocs
73 Summary:        MATE Session Manager D-Bus API Reference
74 Summary(pl.UTF-8):      Dokumentacja API D-Bus MATE Session Managera
75 Group:          Documentation
76 %if "%{_rpmversion}" >= "5"
77 BuildArch:      noarch
78 %endif
79
80 %description apidocs
81 Session Manager D-Bus API Reference.
82
83 %description apidocs -l pl.UTF-8
84 Dokumentacja API D-Bus MATE Session Managera.
85
86 %prep
87 %setup -q
88 %patch0 -p1
89
90 %build
91 %{__intltoolize}
92 %{__aclocal}
93 %{__autoheader}
94 %{__autoconf}
95 %{__automake}
96 %configure \
97         %{!?with_apidocs:--disable-docbook-docs} \
98         %{?with_apidocs:--enable-docbook-docs --docdir=%{_gtkdocdir}/%{name}} \
99         --enable-ipv6 \
100         --disable-silent-rules \
101         --disable-static \
102         %{!?with_upower:--disable-upower} \
103         --with-default-wm=marco \
104         --with-gnu-ld \
105         %{?with_gtk3:--with-gtk=3.0} \
106         %{__with_without systemd} \
107         --with-x
108
109 %{__make}
110
111 %install
112 rm -rf $RPM_BUILD_ROOT
113 %{__make} install \
114         DESTDIR=$RPM_BUILD_ROOT
115
116 # mate < 1.5 did not exist in pld, avoid dependency on mate-conf
117 %{__rm} $RPM_BUILD_ROOT%{_datadir}/MateConf/gsettings/mate-session.convert
118
119 desktop-file-install \
120         --remove-category="MATE" \
121         --add-category="X-Mate" \
122         --delete-original \
123         --dir=$RPM_BUILD_ROOT%{_desktopdir} \
124         $RPM_BUILD_ROOT%{_desktopdir}/mate-session-properties.desktop
125
126 %find_lang %{name}
127
128 %clean
129 rm -rf $RPM_BUILD_ROOT
130
131 %post
132 %update_icon_cache hicolor
133 %glib_compile_schemas
134
135 %postun
136 %update_icon_cache hicolor
137 %glib_compile_schemas
138
139 %files -f %{name}.lang
140 %defattr(644,root,root,755)
141 %doc AUTHORS ChangeLog MAINTAINERS NEWS README
142 %attr(755,root,root) %{_bindir}/mate-session
143 %attr(755,root,root) %{_bindir}/mate-session-inhibit
144 %attr(755,root,root) %{_bindir}/mate-session-properties
145 %attr(755,root,root) %{_bindir}/mate-session-save
146 %attr(755,root,root) %{_bindir}/mate-wm
147 %{_mandir}/man1/mate-session-inhibit.1*
148 %{_mandir}/man1/mate-session-properties.1*
149 %{_mandir}/man1/mate-session-save.1*
150 %{_mandir}/man1/mate-session.1*
151 %{_mandir}/man1/mate-wm.1*
152 %{_datadir}/mate-session-manager
153 %{_datadir}/glib-2.0/schemas/org.mate.session.gschema.xml
154 %{_datadir}/xsessions/mate.desktop
155 %{_desktopdir}/mate-session-properties.desktop
156 %{_iconsdir}/hicolor/*x*/apps/mate-session-properties.png
157 %{_iconsdir}/hicolor/scalable/apps/mate-session-properties.svg
158
159 %if %{with apidocs}
160 %files apidocs
161 %defattr(644,root,root,755)
162 %{_gtkdocdir}/%{name}
163 %endif
This page took 0.050742 seconds and 4 git commands to generate.