]> git.pld-linux.org Git - packages/mate-session-manager.git/blob - mate-session-manager.spec
822ccfedd13caa64b08ed24d957513f04d37ac48
[packages/mate-session-manager.git] / mate-session-manager.spec
1 #
2 # TODO
3 # - Terminal=true, depends on mate-terminal, but probably should take preferred terminal application
4 # mate-session[4970]: WARNING: Could not launch application 'nvidia-settings.desktop': Unable to start application: Failed to execute child process "xdg-terminal" (No such file or directory)
5
6 # Conditional build:
7 %bcond_without  apidocs # DocBook docs
8 %bcond_with     gtk3    # use GTK+ 3.x instead of 2.x
9 %bcond_without  systemd # systemd support for default (when systemd is not running fallback to ConsoleKit)
10
11 Summary:        MATE Desktop session manager
12 Summary(pl.UTF-8):      Zarządca sesji środowiska MATE Desktop
13 Name:           mate-session-manager
14 Version:        1.6.1
15 Release:        1
16 License:        GPL v2+
17 Group:          X11/Applications
18 Source0:        http://pub.mate-desktop.org/releases/1.6/%{name}-%{version}.tar.xz
19 # Source0-md5:  e841ff0917f8b64ad33267b0eb5f8364
20 URL:            http://wiki.mate-desktop.org/mate-session-manager
21 BuildRequires:  autoconf >= 2.53
22 BuildRequires:  automake >= 1:1.9
23 BuildRequires:  dbus-glib-devel >= 0.76
24 BuildRequires:  desktop-file-utils
25 BuildRequires:  glib2-devel >= 1:2.26.0
26 %{!?with_gtk3:BuildRequires:    gtk+2-devel >= 2:2.14.0}
27 %{?with_gtk3:BuildRequires:     gtk+3-devel >= 3.0.0}
28 BuildRequires:  intltool >= 0.40.0
29 BuildRequires:  libtool >= 1:1.4.3
30 %{?with_apidocs:BuildRequires:  libxslt-progs}
31 BuildRequires:  mate-common
32 BuildRequires:  pango-devel
33 BuildRequires:  pangox-compat-devel
34 BuildRequires:  pkgconfig
35 %{?with_systemd:BuildRequires:  systemd-devel >= 1:183}
36 BuildRequires:  tar >= 1:1.22
37 BuildRequires:  upower-devel >= 0.9.0
38 %{?with_apidocs:BuildRequires:  xmlto}
39 BuildRequires:  xorg-lib-libICE-devel
40 BuildRequires:  xorg-lib-libSM-devel
41 BuildRequires:  xorg-lib-libXau-devel
42 BuildRequires:  xorg-lib-libXext-devel
43 BuildRequires:  xorg-lib-libXrender-devel
44 BuildRequires:  xorg-lib-libXtst-devel
45 BuildRequires:  xz
46 Requires:       dbus-glib >= 0.76
47 Requires:       glib2 >= 1:2.26.0
48 Requires:       gsettings-desktop-schemas
49 %{!?with_gtk3:Requires: gtk+2 >= 2:2.14.0}
50 %{?with_gtk3:Requires:  gtk+3 >= 3.0.0}
51 Requires:       gtk-update-icon-cache
52 Requires:       hicolor-icon-theme
53 Requires:       mate-desktop >= 1.5
54 # needed to satisfy 'filemanager' component (may be changed if alternatives available)
55 Requires:       mate-file-manager
56 # needed to satisfy 'panel' component (may be changed if alternatives available)
57 Requires:       mate-panel
58 # needed to satisfy 'windowmanager' component (may be changed if alternatives available)
59 Requires:       mate-window-manager
60 Requires:       upower-libs >= 0.9.0
61 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
62
63 %description
64 MATE Desktop session manager.
65
66 %description -l pl.UTF-8
67 Zarządca sesji środowiska MATE Desktop.
68
69 %package apidocs
70 Summary:        MATE Session Manager D-Bus API Reference
71 Summary(pl.UTF-8):      Dokumentacja API D-Bus MATE Session Managera
72 Group:          Documentation
73
74 %description apidocs
75 Session Manager D-Bus API Reference.
76
77 %description apidocs -l pl.UTF-8
78 Dokumentacja API D-Bus MATE Session Managera.
79
80 %prep
81 %setup -q
82
83 %build
84 %{__intltoolize}
85 %{__aclocal}
86 %{__autoheader}
87 %{__autoconf}
88 %{__automake}
89 %configure \
90         %{!?with_apidocs:--disable-docbook-docs} \
91         %{?with_apidocs:--enable-docbook-docs --docdir=%{_gtkdocdir}/%{name}} \
92         --enable-ipv6 \
93         --disable-silent-rules \
94         --disable-static \
95         --with-default-wm=marco \
96         --with-gnu-ld \
97         %{?with_gtk3:--with-gtk=3.0} \
98         %{__with_without systemd} \
99         --with-x
100
101 %{__make}
102
103 %install
104 rm -rf $RPM_BUILD_ROOT
105 %{__make} install \
106         DESTDIR=$RPM_BUILD_ROOT
107
108 # mate < 1.5 did not exist in pld, avoid dependency on mate-conf
109 %{__rm} $RPM_BUILD_ROOT%{_datadir}/MateConf/gsettings/mate-session.convert
110
111 desktop-file-install \
112         --remove-category="MATE" \
113         --add-category="X-Mate" \
114         --delete-original \
115         --dir=$RPM_BUILD_ROOT%{_desktopdir} \
116         $RPM_BUILD_ROOT%{_desktopdir}/mate-session-properties.desktop
117
118 %find_lang %{name}
119
120 %clean
121 rm -rf $RPM_BUILD_ROOT
122
123 %post
124 %update_icon_cache hicolor
125 %glib_compile_schemas
126
127 %postun
128 %update_icon_cache hicolor
129 %glib_compile_schemas
130
131 %files -f %{name}.lang
132 %defattr(644,root,root,755)
133 %doc AUTHORS ChangeLog MAINTAINERS NEWS README
134 %attr(755,root,root) %{_bindir}/mate-session
135 %attr(755,root,root) %{_bindir}/mate-session-properties
136 %attr(755,root,root) %{_bindir}/mate-session-save
137 %attr(755,root,root) %{_bindir}/mate-wm
138 %{_mandir}/man1/mate-session-properties.1*
139 %{_mandir}/man1/mate-session-save.1*
140 %{_mandir}/man1/mate-session.1*
141 %{_mandir}/man1/mate-wm.1*
142 %{_datadir}/mate-session-manager
143 %{_datadir}/glib-2.0/schemas/org.mate.session.gschema.xml
144 %{_datadir}/xsessions/mate.desktop
145 %{_desktopdir}/mate-session-properties.desktop
146 %{_iconsdir}/hicolor/*x*/apps/mate-session-properties.png
147 %{_iconsdir}/hicolor/scalable/apps/mate-session-properties.svg
148
149 %if %{with apidocs}
150 %files apidocs
151 %defattr(644,root,root,755)
152 %{_gtkdocdir}/%{name}
153 %endif
This page took 0.074595 seconds and 2 git commands to generate.