]> git.pld-linux.org Git - packages/m17n-lib.git/blob - m17n-lib.spec
- unconditional noarch subpackages
[packages/m17n-lib.git] / m17n-lib.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4 %bcond_without  static_libs     # don't build static libraries
5
6 %define doc_ver 1.6.2
7 Summary:        A multilingual text processing library
8 Summary(pl.UTF-8):      Biblioteka przetwarzania tekstów wielojęzycznych
9 Name:           m17n-lib
10 Version:        1.8.0
11 Release:        1
12 License:        LGPL v2.1+
13 Group:          Libraries
14 Source0:        http://download.savannah.gnu.org/releases/m17n/%{name}-%{version}.tar.gz
15 # Source0-md5:  35a7c29b4c5892c643153eeaefd1f787
16 # no longer functional
17 #Source1:       http://www.m17n.org/m17n-lib-download/m17n-docs-%{doc_ver}.tar.gz
18 Source1:        m17n-docs-%{doc_ver}.tar.gz
19 # Source1-md5:  5b9652fb714772fc7c7946e282ebedb3
20 Source2:        http://download.savannah.gnu.org/releases/m17n/m17n-db-%{version}.tar.gz
21 # Source2-md5:  49378f8ed738f84abfaf5e09699e1fa0
22 Patch0:         DESTDIR.patch
23 URL:            http://www.nongnu.org/m17n/
24 BuildRequires:  anthy-devel
25 BuildRequires:  autoconf >= 2.50
26 BuildRequires:  automake
27 BuildRequires:  fontconfig-devel
28 BuildRequires:  freetype-devel >= 2
29 BuildRequires:  fribidi-devel
30 BuildRequires:  gd-devel
31 BuildRequires:  gettext-tools >= 0.17
32 BuildRequires:  ispell
33 BuildRequires:  libotf-devel >= 0.9.4
34 BuildRequires:  libthai-devel
35 BuildRequires:  libxml2-devel >= 2
36 BuildRequires:  localedb-src
37 BuildRequires:  pkgconfig
38 # if not libthai
39 #BuildRequires: wordcut-devel
40 BuildRequires:  xorg-lib-libX11-devel
41 BuildRequires:  xorg-lib-libXaw-devel
42 BuildRequires:  xorg-lib-libXft-devel >= 2.0.0
43 BuildRequires:  xorg-lib-libXmu-devel
44 BuildRequires:  xorg-lib-libXrender-devel
45 BuildRequires:  xorg-lib-libXt-devel
46 Requires:       ispell
47 Requires:       m17n-db = %{version}-%{release}
48 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50 %description
51 The m17n library is a multilingual text processing library for the C
52 language. This library has following features:
53  - The m17n library is an open source software.
54  - The m17n library for any Linux/Unix applications.
55  - The m17n library realizes multilingualization of many aspects of
56    applications.
57  - The m17n library represents multilingual text as an object named
58    M-text. M-text is a string with attributes called text properties, and
59    designed to substitute for string in C. Text properties carry any
60    information required to input, display and edit the text.
61  - The m17n library supports functions to handle M-texts.
62
63 m17n is an abbreviation of Multilingualization.
64
65 %description -l pl.UTF-8
66 Biblioteka m17n jest przeznaczona do przetwarzania tekstów
67 wielojęzycznych w języku C. Ma następujące cechy:
68  - jest oprogramowaniem o otwartych źródłach
69  - może być używana przez dowolne aplikacje linuksowe/uniksowe
70  - realizuje wielojęzyczność w wielu aspektach i zastosowaniach
71  - reprezentuje tekst wielojęzyczny jako obiekt o nazwie M-text (M-text
72    to łańcuch z atrybutami będącymi właściwościami tekstu, zaprojektowany
73    do podstawienia do dowolnego łańcucha w C. Właściwości tekstu
74    przechowują dowolne informacje wymagane przy wprowadzaniu,
75    wyświetlaniu i edycji tekstu)
76  - obsługuje funkcje przetwarzające M-text.
77
78 m17n to skrót od "multilingualization", czyli uwielojęzycznienie.
79
80 %package devel
81 Summary:        Header files for m17n library
82 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki m17n
83 Group:          Development/Libraries
84 Requires:       %{name} = %{version}-%{release}
85
86 %description devel
87 Header files for m17n library.
88
89 %description devel -l pl.UTF-8
90 Pliki nagłówkowe biblioteki m17n.
91
92 %package static
93 Summary:        Static m17n library
94 Summary(pl.UTF-8):      Statyczna biblioteka m17n
95 Group:          Development/Libraries
96 Requires:       %{name}-devel = %{version}-%{release}
97
98 %description static
99 Static m17n library.
100
101 %description static -l pl.UTF-8
102 Statyczna biblioteka m17n.
103
104 %package apidocs
105 Summary:        m17n API documentation
106 Summary(pl.UTF-8):      Dokumentacja API biblioteki m17n
107 Group:          Documentation
108 BuildArch:      noarch
109
110 %description apidocs
111 API and internal documentation for m17n library.
112
113 %description apidocs -l pl.UTF-8
114 Dokumentacja API biblioteki m17n.
115
116 %package -n m17n-db
117 Summary:        Database files for m17n library
118 Summary(pl.UTF-8):      Baza danych biblioteki m17n
119 Group:          Development/Libraries
120
121 %description -n m17n-db
122 Database files for m17n library.
123
124 %description -n m17n-db -l pl.UTF-8
125 Baza danych biblioteki m17n.
126
127 %prep
128 %setup -q -T -c -a0 -a1 -a2
129
130 cd m17n-docs-%{doc_ver}
131 %patch0 -p1
132
133 %build
134 cd %{name}-%{version}
135 %configure \
136         --enable-gui \
137         %{!?with_static_libs:--disable-static}
138 %{__make} -j1
139
140 cd ../m17n-docs-%{doc_ver}
141 %{__aclocal}
142 %{__autoconf}
143 %{__automake}
144 %configure \
145         %{!?with_static_libs:--disable-static}
146 %{__make} -j1
147
148 cd ../m17n-db-%{version}
149 %configure \
150         %{!?with_static_libs:--disable-static}
151 %{__make} -j1
152
153 %install
154 rm -rf $RPM_BUILD_ROOT
155
156 %{__make} -j1 -C %{name}-%{version} install \
157         BINSCRIPTS="m17n-config" \
158         DESTDIR=$RPM_BUILD_ROOT
159
160 %{__make} -j1 -C m17n-docs-%{doc_ver} install \
161         DESTDIR=$RPM_BUILD_ROOT
162
163 %{__make} -j1 -C m17n-db-%{version} install \
164         DESTDIR=$RPM_BUILD_ROOT
165
166 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/m17n/docs
167
168 # dlopened modules
169 %{__rm} $RPM_BUILD_ROOT%{_libdir}/m17n/1.0/lib*.{la,a}
170 # obsoleted by pkg-config
171 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libm17n*.la
172
173 %find_lang m17n-db
174
175 %clean
176 rm -rf $RPM_BUILD_ROOT
177
178 %post   -p /sbin/ldconfig
179 %postun -p /sbin/ldconfig
180
181 %files
182 %defattr(644,root,root,755)
183 %doc %{name}-%{version}/{AUTHORS,ChangeLog,NEWS,README,TODO}
184 %attr(755,root,root) %{_bindir}/m17n-conv
185 %attr(755,root,root) %{_bindir}/m17n-date
186 %attr(755,root,root) %{_bindir}/m17n-dump
187 %attr(755,root,root) %{_bindir}/m17n-edit
188 %attr(755,root,root) %{_bindir}/m17n-view
189 %attr(755,root,root) %{_libdir}/libm17n.so.*.*.*
190 %attr(755,root,root) %ghost %{_libdir}/libm17n.so.0
191 %attr(755,root,root) %{_libdir}/libm17n-core.so.*.*.*
192 %attr(755,root,root) %ghost %{_libdir}/libm17n-core.so.0
193 %attr(755,root,root) %{_libdir}/libm17n-flt.so.*.*.*
194 %attr(755,root,root) %ghost %{_libdir}/libm17n-flt.so.0
195 %attr(755,root,root) %{_libdir}/libm17n-gui.so.*.*.*
196 %attr(755,root,root) %ghost %{_libdir}/libm17n-gui.so.0
197 %dir %{_libdir}/m17n
198 %dir %{_libdir}/m17n/1.0
199 %attr(755,root,root) %{_libdir}/m17n/1.0/libm17n-X.so
200 %attr(755,root,root) %{_libdir}/m17n/1.0/libm17n-gd.so
201 %attr(755,root,root) %{_libdir}/m17n/1.0/libmimx-anthy.so
202 %attr(755,root,root) %{_libdir}/m17n/1.0/libmimx-ispell.so
203 %{_mandir}/man1/m17n-conv.1*
204 %{_mandir}/man1/m17n-date.1*
205 %{_mandir}/man1/m17n-dump.1*
206 %{_mandir}/man1/m17n-edit.1*
207 %{_mandir}/man1/m17n-view.1*
208
209 %files devel
210 %defattr(644,root,root,755)
211 %attr(755,root,root) %{_bindir}/m17n-config
212 %attr(755,root,root) %{_libdir}/libm17n.so
213 %attr(755,root,root) %{_libdir}/libm17n-core.so
214 %attr(755,root,root) %{_libdir}/libm17n-flt.so
215 %attr(755,root,root) %{_libdir}/libm17n-gui.so
216 %{_includedir}/m17n*.h
217 %{_pkgconfigdir}/m17n-core.pc
218 %{_pkgconfigdir}/m17n-flt.pc
219 %{_pkgconfigdir}/m17n-gui.pc
220 %{_pkgconfigdir}/m17n-shell.pc
221 %{_mandir}/man1/m17n-config.1*
222 %{_mandir}/man3/m17n*.3*
223 %{_mandir}/man3/mchar*.3*
224 %{_mandir}/man3/mconv_*.3*
225 %{_mandir}/man3/mdatabase_*.3*
226 %{_mandir}/man3/mdebug_*.3*
227 %{_mandir}/man3/mdraw_*.3*
228 %{_mandir}/man3/mface*.3*
229 %{_mandir}/man3/mflt_*.3*
230 %{_mandir}/man3/mfont*.3*
231 %{_mandir}/man3/mframe*.3*
232 %{_mandir}/man3/minput_*.3*
233 %{_mandir}/man3/mlocale_*.3*
234 %{_mandir}/man3/mplist*.3*
235 %{_mandir}/man3/msymbol*.3*
236 %{_mandir}/man3/mtext*.3*
237
238 %if %{with static_libs}
239 %files static
240 %defattr(644,root,root,755)
241 %{_libdir}/libm17n.a
242 %{_libdir}/libm17n-core.a
243 %{_libdir}/libm17n-flt.a
244 %{_libdir}/libm17n-gui.a
245 %endif
246
247 %if %{with apidocs}
248 %files apidocs
249 %defattr(644,root,root,755)
250 %doc m17n-docs-%{doc_ver}/usr/{html,latex/m17n-lib.pdf}
251 %endif
252
253 %files -n m17n-db -f m17n-db.lang
254 %defattr(644,root,root,755)
255 %doc m17n-db-%{version}/{AUTHORS,ChangeLog,NEWS,README}
256 %attr(755,root,root) %{_bindir}/m17n-db
257 %{_mandir}/man1/m17n-db.1*
258 %{_mandir}/man5/mdb*.5*
259 %{_datadir}/m17n
260 %{_npkgconfigdir}/m17n-db.pc
This page took 0.097158 seconds and 4 git commands to generate.