]> git.pld-linux.org Git - packages/lxd.git/commitdiff
- fixed last commit auto/th/lxd-2.9.2-1
authormis <mis@pld-linux.org>
Wed, 22 Feb 2017 08:47:26 +0000 (09:47 +0100)
committermis <mis@pld-linux.org>
Wed, 22 Feb 2017 08:47:26 +0000 (09:47 +0100)
lxd.init
lxd.spec
lxd.sysconfig

index 2bf5fa4e578ad5f55fba1d7e3b72b2b320c461d4..1ed4147deaeb7dc763c364c5f993942ad28f890c 100755 (executable)
--- a/lxd.init
+++ b/lxd.init
@@ -36,14 +36,6 @@ start() {
                RETVAL=1
                return
        fi
-
-       if [ -n "$BRIDGE_DEV" ]; then
-               if ! ip link show $BRIDGE_DEV up 2>/dev/null | grep -q $BRIDGE_DEV; then
-                       nls "lxd bridge %s is down, start lxdbr service first" "$BRIDGE_DEV"
-                       RETVAL=1
-                       return
-               fi
-       fi
                 
        msg_starting "lxd"
        daemon --fork --waitforname lxd /usr/lib/lxd-wrapper daemon $OPTIONS 
@@ -55,7 +47,7 @@ start() {
        ntry=0
        while [ -z "$pid" -a $ntry -lt 5 ]; do
                [ -z "$pid" ] && sleep 1
-               pid=$(lxc info 2>/dev/null | awk '/serverpid:/{print $2}')
+               pid=$(lxc info 2>/dev/null | awk '/server_pid:/{print $2}')
                [ -n "$pid" ] && echo $pid > $pidfile
                ntry=$(($ntry+1))
        done
index 733b70ab48935568f506008a2fbc833daca259a0..5bace047a0cc42a86b04b5cb45ed7db94b0fc042 100644 (file)
--- a/lxd.spec
+++ b/lxd.spec
@@ -1,20 +1,18 @@
 # TODO
-# - lxdbr0 interface setup for systemd
 # - Consider use of lxd group for lxd
 
 Summary:       Fast, dense and secure container management
 Name:          lxd
-Version:       2.6.2
+Version:       2.9.2
 Release:       1       
 License:       Apache v2.0
 Group:         Applications/System
 Source0:       https://linuxcontainers.org/downloads/lxd/%{name}-%{version}.tar.gz
-# Source0-md5: 59a4f949c7cc6bb3846998e9d4e9adaa
+# Source0-md5: f09c333ea237014ab3f6abf4f9173339
 Source1:       %{name}.service
 Source2:       %{name}.init
-Source3:       %{name}br.init
-Source4:       %{name}.sysconfig
-Source5:       %{name}.sh
+Source3:       %{name}.sysconfig
+Source4:       %{name}.sh
 URL:           http://linuxcontainers.org/
 %ifarch %{x8664} arm aarch64 ppc64
 BuildRequires: criu-devel >= 1.7
@@ -88,16 +86,14 @@ install -p dist/bin/lxc $RPM_BUILD_ROOT%{_bindir}
 
 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{systemdunitdir}
 install -p %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
-install -p %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}br
-cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
+cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
 
-install -p %{SOURCE5} $RPM_BUILD_ROOT%{_libexecdir}/lxd-wrapper
+install -p %{SOURCE4} $RPM_BUILD_ROOT%{_libexecdir}/lxd-wrapper
 
 %pre
 %groupadd -g 273 %{name}
 
 %post
-/sbin/chkconfig --add %{name}br
 /sbin/chkconfig --add %{name}
 %service -n %{name} restart
 %systemd_post %{name}.service
@@ -105,9 +101,7 @@ install -p %{SOURCE5} $RPM_BUILD_ROOT%{_libexecdir}/lxd-wrapper
 %preun
 if [ "$1" = "0" ]; then
        %service -q %{name} stop
-       %service -q %{name}br stop
        /sbin/chkconfig --del %{name}
-       /sbin/chkconfig --del %{name}br
 fi
 %systemd_preun %{name}.service
 
@@ -125,7 +119,6 @@ rm -rf $RPM_BUILD_ROOT
 %doc README.md CONTRIBUTING.md AUTHORS doc/*
 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
 %attr(754,root,root) /etc/rc.d/init.d/%{name}
-%attr(754,root,root) /etc/rc.d/init.d/%{name}br
 %attr(755,root,root) %{_bindir}/lxc
 %attr(755,root,root) %{_sbindir}/lxd
 %{systemdunitdir}/%{name}.service
index 666d6a7b86df9d0c6e8929cf23cd2136ffd4f5bb..fdae0d0d799e98fc4090627d0f2d11ad22c666c9 100644 (file)
@@ -9,6 +9,3 @@ SERVICE_LIMITS="-n 1048576 -u 1048576"
 # Modify these options if you want to change the way the lxd daemon runs
 #OPTIONS=""
 
-# LXD bridge dev and ip address 
-BRIDGE_DEV="lxdbr0"
-#BRIDGE_IPADDR="192.168.1.1/24"
\ No newline at end of file
This page took 0.215753 seconds and 4 git commands to generate.