]> git.pld-linux.org Git - packages/lxc.git/blob - lxc.spec
templates need to be executable
[packages/lxc.git] / lxc.spec
1 #
2 # Conditional build:
3 %bcond_without  seccomp # SecComp syscall filter
4 %bcond_without  lua     # Lua binding
5 %bcond_without  python  # Python binding
6
7 Summary:        Linux Container Tools
8 Summary(pl.UTF-8):      Narzędzia do kontenerów linuksowych (LXC)
9 Name:           lxc
10 Version:        0.9.0
11 Release:        5
12 License:        LGPL v2.1+
13 Group:          Applications/System
14 Source0:        http://lxc.sourceforge.net/download/lxc/%{name}-%{version}.tar.gz
15 # Source0-md5:  8552a4479090616f4bc04d8473765fc9
16 Patch0:         %{name}-devpts.patch
17 Patch1:         %{name}-pld.patch
18 Patch2:         am-1.14.patch
19 Patch3:         checkconfig-module.patch
20 Patch4:         checkconfig-vserver-config.patch
21 URL:            http://lxc.sourceforge.net/
22 BuildRequires:  autoconf >= 2.50
23 BuildRequires:  automake
24 BuildRequires:  docbook-dtd30-sgml
25 BuildRequires:  docbook-utils
26 BuildRequires:  docbook2X
27 BuildRequires:  libapparmor-devel
28 BuildRequires:  libcap-devel
29 %{?with_seccomp:BuildRequires:  libseccomp-devel}
30 %{?with_lua:BuildRequires:      lua51-devel >= 5.1}
31 BuildRequires:  pkgconfig
32 %{?with_python:BuildRequires:   python3-devel >= 3.2}
33 BuildRequires:  rpmbuild(macros) >= 1.612
34 BuildRequires:  sed >= 4.0
35 Suggests:       net-tools
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %define         configpath      /var/lib/lxc
39
40 %description
41 Tools to create and manage containers. It contains a full featured
42 container with the isolation / virtualization of the pids, the ipc,
43 the utsname, the mount points, /proc, /sys, the network and it takes
44 into account the control groups. It is very light, flexible, and
45 provides a set of tools around the container like the monitoring with
46 asynchronous events notification, or the freeze of the container. This
47 package is useful to create Virtual Private Server, or to run isolated
48 applications like bash or sshd.
49
50 %description -l pl.UTF-8
51 Narzędzia do tworzenia i zarządzania kontenerami. System ten obejmuje
52 w pełni funkcjonalne kontenery z ilozacją/wirtualizacją pidów, ipc,
53 utsname, punktów montowania, /proc, /sys, sieci oraz uwzględniające
54 grupy kontrolne. Jest bardzo lekki, elastyczny i udostępnia narzędzia
55 do czynności związanych z kontenerami, takich jak monitorowanie z
56 asynchronicznym powiadamianiem o zdarzeniach czy zamrażanie. Ten
57 pakiet jest przydatny do tworzenia wirtualnych serwerów prywatnych
58 oraz uruchamiania izolowanych aplikacji, takich jak bash czy sshd.
59
60 %package devel
61 Summary:        Header files for lxc library
62 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki lxc
63 Group:          Development/Libraries
64 Requires:       %{name} = %{version}-%{release}
65
66 %description devel
67 Header files for lxc library.
68
69 %description devel -l pl.UTF-8
70 Pliki nagłówkowe biblioteki lxc.
71
72 %package -n lua-lxc
73 Summary:        Lua binding for LXC
74 Summary(pl.UTF-8):      Wiązanie Lua do LXC
75 Group:          Libraries
76 Requires:       %{name} = %{version}-%{release}
77 Requires:       lua51-libs >= 5.1
78
79 %description -n lua-lxc
80 Lua binding for LXC.
81
82 %description -n lua-lxc -l pl.UTF-8
83 Wiązanie Lua do LXC.
84
85 %package -n python3-lxc
86 Summary:        Python (3.x) binding for LXC
87 Summary(pl.UTF-8):      Wiązanie Pythona (3.x) do LXC
88 Group:          Libraries
89 Requires:       %{name} = %{version}-%{release}
90 Requires:       python3-libs >= 3.2
91
92 %description -n python3-lxc
93 Python (3.x) binding for LXC.
94
95 %description -n python3-lxc -l pl.UTF-8
96 Wiązanie Pythona (3.x) do LXC.
97
98 %prep
99 %setup -q
100 %patch0 -p1
101 %patch1 -p1
102 %patch2 -p1
103 %patch3 -p1
104 %patch4 -p1
105
106 %build
107 %{__aclocal} -I config
108 %{__autoconf}
109 %{__autoheader}
110 %{__automake}
111 %configure \
112         db2xman=docbook2X2man \
113         --disable-rpath \
114         --enable-doc \
115         %{?with_lua:--enable-lua} \
116         %{?with_python:--enable-python} \
117         %{?with_seccomp:--enable-seccomp} \
118         --with-config-path=%{configpath} \
119         --with-distro=pld
120
121 %{__make}
122 %{__make} -C doc
123
124 %install
125 rm -rf $RPM_BUILD_ROOT
126
127 %{__make} install \
128         DESTDIR=$RPM_BUILD_ROOT \
129         pcdatadir=%{_pkgconfigdir}
130
131 %{__make} -C doc install \
132         DESTDIR=$RPM_BUILD_ROOT
133
134 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}
135
136 install -d $RPM_BUILD_ROOT%{configpath}
137
138 %if %{with python}
139 %py3_comp $RPM_BUILD_ROOT%{py3_sitedir}/lxc
140 %py3_ocomp $RPM_BUILD_ROOT%{py3_sitedir}/lxc
141 %endif
142 %if %{with lua}
143 %{__sed} -i -e '1s,#!/usr/bin/env lua,#!/usr/bin/lua51,' $RPM_BUILD_ROOT%{_bindir}/lxc-top
144 %endif
145
146 %clean
147 rm -rf $RPM_BUILD_ROOT
148
149 %post   -p /sbin/ldconfig
150 %postun -p /sbin/ldconfig
151
152 %files
153 %defattr(644,root,root,755)
154 %doc AUTHORS ChangeLog CONTRIBUTING MAINTAINERS README TODO doc/FAQ.txt doc/examples/*.conf
155 %attr(755,root,root) %{_bindir}/lxc-attach
156 %attr(755,root,root) %{_bindir}/lxc-cgroup
157 %attr(755,root,root) %{_bindir}/lxc-checkconfig
158 %attr(755,root,root) %{_bindir}/lxc-checkpoint
159 %attr(755,root,root) %{_bindir}/lxc-clone
160 %attr(755,root,root) %{_bindir}/lxc-console
161 %attr(755,root,root) %{_bindir}/lxc-create
162 %attr(755,root,root) %{_bindir}/lxc-destroy
163 %attr(755,root,root) %{_bindir}/lxc-execute
164 %attr(755,root,root) %{_bindir}/lxc-freeze
165 %attr(755,root,root) %{_bindir}/lxc-info
166 %attr(755,root,root) %{_bindir}/lxc-kill
167 %attr(755,root,root) %{_bindir}/lxc-monitor
168 %attr(755,root,root) %{_bindir}/lxc-netstat
169 %attr(755,root,root) %{_bindir}/lxc-ps
170 %attr(755,root,root) %{_bindir}/lxc-restart
171 %attr(755,root,root) %{_bindir}/lxc-shutdown
172 %attr(755,root,root) %{_bindir}/lxc-start
173 %attr(755,root,root) %{_bindir}/lxc-stop
174 %attr(755,root,root) %{_bindir}/lxc-unfreeze
175 %attr(755,root,root) %{_bindir}/lxc-unshare
176 %attr(755,root,root) %{_bindir}/lxc-version
177 %attr(755,root,root) %{_bindir}/lxc-wait
178 %attr(755,root,root) %{_libdir}/liblxc.so.*.*.*
179 %attr(755,root,root) %ghost %{_libdir}/liblxc.so.0
180 %dir %{configpath}
181 %dir %{_libdir}/lxc
182 %dir %{_libdir}/lxc/rootfs
183 %{_libdir}/lxc/rootfs/README
184 %attr(755,root,root) %{_libdir}/lxc/lxc-init
185 %dir %{_sysconfdir}/lxc
186 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lxc/default.conf
187 %dir %{_datadir}/lxc
188 %{_datadir}/%{name}/lxc.functions
189 %dir %{_datadir}/%{name}/hooks
190 %dir %{_datadir}/%{name}/templates
191 %attr(755,root,root) %{_datadir}/%{name}/hooks/mount*
192 %attr(755,root,root) %{_datadir}/%{name}/templates/lxc-*
193 %{_mandir}/man1/lxc-attach.1*
194 %{_mandir}/man1/lxc-cgroup.1*
195 %{_mandir}/man1/lxc-checkconfig.1*
196 %{_mandir}/man1/lxc-checkpoint.1*
197 %{_mandir}/man1/lxc-clone.1*
198 %{_mandir}/man1/lxc-console.1*
199 %{_mandir}/man1/lxc-create.1*
200 %{_mandir}/man1/lxc-destroy.1*
201 %{_mandir}/man1/lxc-execute.1*
202 %{_mandir}/man1/lxc-freeze.1*
203 %{_mandir}/man1/lxc-info.1*
204 %{_mandir}/man1/lxc-kill.1*
205 %{_mandir}/man1/lxc-monitor.1*
206 %{_mandir}/man1/lxc-netstat.1*
207 %{_mandir}/man1/lxc-ps.1*
208 %{_mandir}/man1/lxc-restart.1*
209 %{_mandir}/man1/lxc-shutdown.1*
210 %{_mandir}/man1/lxc-start.1*
211 %{_mandir}/man1/lxc-stop.1*
212 %{_mandir}/man1/lxc-unfreeze.1*
213 %{_mandir}/man1/lxc-unshare.1*
214 %{_mandir}/man1/lxc-version.1*
215 %{_mandir}/man1/lxc-wait.1*
216 %{_mandir}/man5/lxc.conf.5*
217 %{_mandir}/man7/lxc.7*
218 %if %{without python}
219 # legacy version
220 %attr(755,root,root) %{_bindir}/lxc-ls
221 %{_mandir}/man1/lxc-ls.1*
222 %endif
223
224 %files devel
225 %defattr(644,root,root,755)
226 %attr(755,root,root) %{_libdir}/liblxc.so
227 %{_includedir}/lxc
228 %{_pkgconfigdir}/lxc.pc
229
230 %if %{with lua}
231 %files -n lua-lxc
232 %defattr(644,root,root,755)
233 %attr(755,root,root) %{_bindir}/lxc-top
234 %dir %{_libdir}/lua/5.1/lxc
235 %attr(755,root,root) %{_libdir}/lua/5.1/lxc/core.so
236 %{_datadir}/lua/5.1/lxc.lua
237 %{_mandir}/man1/lxc-top.1*
238 %endif
239
240 %if %{with python}
241 %files -n python3-lxc
242 %defattr(644,root,root,755)
243 %attr(755,root,root) %{_bindir}/lxc-device
244 %attr(755,root,root) %{_bindir}/lxc-ls
245 %attr(755,root,root) %{_bindir}/lxc-start-ephemeral
246 %{py3_sitedir}/lxc
247 %attr(755,root,root) %{py3_sitedir}/_lxc.cpython-*.so
248 %{py3_sitedir}/_lxc-0.1-py*.egg-info
249 %{_mandir}/man1/lxc-device.1*
250 %{_mandir}/man1/lxc-ls.1*
251 %{_mandir}/man1/lxc-start-ephemeral.1*
252 %endif
This page took 0.053564 seconds and 4 git commands to generate.