]> git.pld-linux.org Git - packages/lxc.git/blob - lxc.spec
89ee268c103b1e12d3fd9e50e129dd3ebbe5ef47
[packages/lxc.git] / lxc.spec
1 # TODO: move lua/python-dependent utils to lya-/python-
2 #
3 # Conditional build:
4 %bcond_without  seccomp # SecComp syscall filter
5 %bcond_without  lua     # Lua binding
6 %bcond_without  python  # Python binding
7 #
8 Summary:        Linux Container Tools
9 Summary(pl.UTF-8):      Narzędzia do kontenerów linuksowych (LXC)
10 Name:           lxc
11 Version:        0.9.0
12 Release:        1
13 License:        GPL
14 Group:          Applications/System
15 Source0:        http://lxc.sourceforge.net/download/lxc/%{name}-%{version}.tar.gz
16 # Source0-md5:  8552a4479090616f4bc04d8473765fc9
17 Patch0:         %{name}-devpts.patch
18 Patch1:         %{name}-pld.patch
19 URL:            http://lxc.sourceforge.net/
20 BuildRequires:  autoconf >= 2.50
21 BuildRequires:  automake
22 BuildRequires:  docbook2X
23 BuildRequires:  docbook-dtd30-sgml
24 BuildRequires:  docbook-utils
25 BuildRequires:  libapparmor-devel
26 BuildRequires:  libcap-devel
27 %{?with_seccomp:BuildRequires:  libseccomp-devel}
28 %{?with_lua:BuildRequires:      lua51-devel >= 5.1}
29 BuildRequires:  pkgconfig
30 %{?with_python:BuildRequires:   python3-devel >= 3.2}
31 BuildRequires:  rpmbuild(macros) >= 1.612
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %define         configpath      /var/lib/lxc
35
36 %description
37 Tools to create and manage containers. It contains a full featured
38 container with the isolation / virtualization of the pids, the ipc,
39 the utsname, the mount points, /proc, /sys, the network and it takes
40 into account the control groups. It is very light, flexible, and
41 provides a set of tools around the container like the monitoring with
42 asynchronous events notification, or the freeze of the container. This
43 package is useful to create Virtual Private Server, or to run isolated
44 applications like bash or sshd.
45
46 %description -l pl.UTF-8
47 Narzędzia do tworzenia i zarządzania kontenerami. System ten obejmuje
48 w pełni funkcjonalne kontenery z ilozacją/wirtualizacją pidów, ipc,
49 utsname, punktów montowania, /proc, /sys, sieci oraz uwzględniające
50 grupy kontrolne. Jest bardzo lekki, elastyczny i udostępnia narzędzia
51 do czynności związanych z kontenerami, takich jak monitorowanie z
52 asynchronicznym powiadamianiem o zdarzeniach czy zamrażanie. Ten
53 pakiet jest przydatny do tworzenia wirtualnych serwerów prywatnych
54 oraz uruchamiania izolowanych aplikacji, takich jak bash czy sshd.
55
56 %package devel
57 Summary:        Header files for lxc library
58 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki lxc
59 Group:          Development/Libraries
60 Requires:       %{name} = %{version}-%{release}
61
62 %description devel
63 Header files for lxc library.
64
65 %description devel -l pl.UTF-8
66 Pliki nagłówkowe biblioteki lxc.
67
68 %package -n lua-lxc
69 Summary:        Lua binding for LXC
70 Summary(pl.UTF-8):      Wiązanie Lua do LXC
71 Group:          Libraries
72 Requires:       %{name} = %{version}-%{release}
73 Requires:       lua51-libs >= 5.1
74
75 %description -n lua-lxc
76 Lua binding for LXC.
77
78 %description -n lua-lxc -l pl.UTF-8
79 Wiązanie Lua do LXC.
80
81 %package -n python3-lxc
82 Summary:        Python (3.x) binding for LXC
83 Summary(pl.UTF-8):      Wiązanie Pythona (3.x) do LXC
84 Group:          Libraries
85 Requires:       %{name} = %{version}-%{release}
86 Requires:       python3-libs >= 3.2
87
88 %description -n python3-lxc
89 Python (3.x) binding for LXC.
90
91 %description -n python3-lxc -l pl.UTF-8
92 Wiązanie Pythona (3.x) do LXC.
93
94 %prep
95 %setup -q
96 %patch0 -p1
97 %patch1 -p1
98
99 %build
100 %{__aclocal} -I config
101 %{__autoconf}
102 %{__autoheader}
103 %{__automake}
104 %configure \
105         db2xman=docbook2X2man \
106         --disable-rpath \
107         --enable-doc \
108         %{?with_lua:--enable-lua} \
109         %{?with_python:--enable-python} \
110         %{?with_seccomp:--enable-seccomp} \
111         --with-config-path=%{configpath} \
112         --with-distro=pld
113
114 %{__make}
115 %{__make} -C doc
116
117 %install
118 rm -rf $RPM_BUILD_ROOT
119
120 %{__make} install \
121         DESTDIR=$RPM_BUILD_ROOT \
122         pcdatadir=%{_pkgconfigdir}
123
124 %{__make} -C doc install \
125         DESTDIR=$RPM_BUILD_ROOT
126
127 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/doc
128
129 install -d $RPM_BUILD_ROOT%{configpath}
130
131 %if %{with python}
132 %py3_comp $RPM_BUILD_ROOT%{py3_sitedir}/lxc
133 %py3_ocomp $RPM_BUILD_ROOT%{py3_sitedir}/lxc
134 %endif
135
136 %clean
137 rm -rf $RPM_BUILD_ROOT
138
139 %post   -p /sbin/ldconfig
140 %postun -p /sbin/ldconfig
141
142 %files
143 %defattr(644,root,root,755)
144 %doc AUTHORS ChangeLog CONTRIBUTING MAINTAINERS README TODO doc/FAQ.txt doc/examples/*.conf
145 %attr(755,root,root) %{_bindir}/lxc-*
146 %attr(755,root,root) %{_libdir}/liblxc.so.*.*.*
147 %attr(755,root,root) %ghost %{_libdir}/liblxc.so.0
148 %dir %{configpath}
149 %dir %{_libdir}/lxc
150 %dir %{_libdir}/lxc/rootfs
151 %{_libdir}/lxc/rootfs/README
152 %attr(755,root,root) %{_libdir}/lxc/lxc-init
153 %dir %{_sysconfdir}/lxc
154 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lxc/default.conf
155 %{_datadir}/lxc
156 %{_mandir}/man1/lxc-*.1*
157 %{_mandir}/man5/lxc.conf.5*
158 %{_mandir}/man7/lxc.7*
159
160 %files devel
161 %defattr(644,root,root,755)
162 %attr(755,root,root) %{_libdir}/liblxc.so
163 %{_includedir}/lxc
164 %{_pkgconfigdir}/lxc.pc
165
166 %if %{with lua}
167 %files -n lua-lxc
168 %defattr(644,root,root,755)
169 %dir %{_libdir}/lua/5.1/lxc
170 %attr(755,root,root) %{_libdir}/lua/5.1/lxc/core.so
171 %{_datadir}/lua/5.1/lxc.lua
172 %endif
173
174 %if %{with python}
175 %files -n python3-lxc
176 %defattr(644,root,root,755)
177 %{py3_sitedir}/lxc
178 %attr(755,root,root) %{py3_sitedir}/_lxc.cpython-*.so
179 %{py3_sitedir}/_lxc-0.1-py*.egg-info
180 %endif
This page took 0.039348 seconds and 2 git commands to generate.