]> git.pld-linux.org Git - packages/lxc.git/blame - lxc.spec
up to 1.0.0.beta1
[packages/lxc.git] / lxc.spec
CommitLineData
67c70229
JB
1#
2# Conditional build:
3%bcond_without seccomp # SecComp syscall filter
ccd4948a 4%bcond_without apparmor # apparmor
67c70229
JB
5%bcond_without lua # Lua binding
6%bcond_without python # Python binding
120ac263 7%bcond_with selinux # SELinux
21c5c666 8
120ac263 9%define subver beta1
247c2ba9
ER
10%define rel 0.1
11Summary: Linux Containers userspace tools
67c70229 12Summary(pl.UTF-8): Narzędzia do kontenerów linuksowych (LXC)
0886a606 13Name: lxc
247c2ba9
ER
14Version: 1.0.0
15Release: 0.%{subver}.%{rel}
c34ce688 16License: LGPL v2.1+
67c70229 17Group: Applications/System
247c2ba9 18Source0: https://github.com/lxc/lxc/archive/%{name}-%{version}.%{subver}.tar.gz
120ac263 19# Source0-md5: 82ddad563fe31b80595543d838788551
adc39309 20Source1: %{name}-pld.in.sh
67c70229 21Patch1: %{name}-pld.patch
bf6a07ce 22Patch4: checkconfig-vserver-config.patch
247c2ba9 23URL: http://linuxcontainers.org/
67c70229
JB
24BuildRequires: autoconf >= 2.50
25BuildRequires: automake
e5afa52e 26BuildRequires: docbook-dtd30-sgml
27BuildRequires: docbook-utils
21c5c666 28BuildRequires: docbook2X
ccd4948a 29%{?with_apparmor:BuildRequires: libapparmor-devel}
4e32c712 30BuildRequires: libcap-devel
67c70229
JB
31%{?with_seccomp:BuildRequires: libseccomp-devel}
32%{?with_lua:BuildRequires: lua51-devel >= 5.1}
33BuildRequires: pkgconfig
34%{?with_python:BuildRequires: python3-devel >= 3.2}
35BuildRequires: rpmbuild(macros) >= 1.612
c34ce688 36BuildRequires: sed >= 4.0
7e514b06 37Requires: rc-scripts >= 0.4.6
adc39309 38Requires: which
21c5c666 39Suggests: net-tools
b335abc0 40Suggests: rsync
0886a606
AM
41BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
e5afa52e 43%define configpath /var/lib/lxc
44
0886a606
AM
45%description
46Tools to create and manage containers. It contains a full featured
47container with the isolation / virtualization of the pids, the ipc,
48the utsname, the mount points, /proc, /sys, the network and it takes
49into account the control groups. It is very light, flexible, and
50provides a set of tools around the container like the monitoring with
51asynchronous events notification, or the freeze of the container. This
52package is useful to create Virtual Private Server, or to run isolated
53applications like bash or sshd.
54
67c70229
JB
55%description -l pl.UTF-8
56Narzędzia do tworzenia i zarządzania kontenerami. System ten obejmuje
57w pełni funkcjonalne kontenery z ilozacją/wirtualizacją pidów, ipc,
58utsname, punktów montowania, /proc, /sys, sieci oraz uwzględniające
59grupy kontrolne. Jest bardzo lekki, elastyczny i udostępnia narzędzia
60do czynności związanych z kontenerami, takich jak monitorowanie z
61asynchronicznym powiadamianiem o zdarzeniach czy zamrażanie. Ten
62pakiet jest przydatny do tworzenia wirtualnych serwerów prywatnych
63oraz uruchamiania izolowanych aplikacji, takich jak bash czy sshd.
64
0886a606 65%package devel
67c70229
JB
66Summary: Header files for lxc library
67Summary(pl.UTF-8): Pliki nagłówkowe biblioteki lxc
0886a606 68Group: Development/Libraries
67c70229 69Requires: %{name} = %{version}-%{release}
0886a606
AM
70
71%description devel
67c70229
JB
72Header files for lxc library.
73
74%description devel -l pl.UTF-8
75Pliki nagłówkowe biblioteki lxc.
76
77%package -n lua-lxc
78Summary: Lua binding for LXC
79Summary(pl.UTF-8): Wiązanie Lua do LXC
80Group: Libraries
81Requires: %{name} = %{version}-%{release}
82Requires: lua51-libs >= 5.1
83
84%description -n lua-lxc
85Lua binding for LXC.
86
87%description -n lua-lxc -l pl.UTF-8
88Wiązanie Lua do LXC.
89
90%package -n python3-lxc
91Summary: Python (3.x) binding for LXC
92Summary(pl.UTF-8): Wiązanie Pythona (3.x) do LXC
93Group: Libraries
94Requires: %{name} = %{version}-%{release}
95Requires: python3-libs >= 3.2
96
97%description -n python3-lxc
98Python (3.x) binding for LXC.
99
100%description -n python3-lxc -l pl.UTF-8
101Wiązanie Pythona (3.x) do LXC.
0886a606 102
0886a606 103%prep
247c2ba9 104%setup -q -n %{name}-%{name}-%{version}%{?subver:.%{subver}}
67c70229 105%patch1 -p1
bf6a07ce 106%patch4 -p1
0886a606 107
8a96554a
ER
108cp -p %{SOURCE1} templates/lxc-pld.in
109
0886a606 110%build
67c70229
JB
111%{__aclocal} -I config
112%{__autoconf}
113%{__autoheader}
114%{__automake}
e5afa52e 115%configure \
67c70229
JB
116 db2xman=docbook2X2man \
117 --disable-rpath \
118 --enable-doc \
120ac263 119 --enable-examples \
ccd4948a 120 %{__enable_disable apparmor} \
247c2ba9 121 %{__enable_disable lua} %{?with_lua:--with-lua-pc=lua51} \
ccd4948a
ER
122 %{__enable_disable python} \
123 %{__enable_disable seccomp} \
120ac263 124 %{__enable_disable selinux} \
67c70229 125 --with-config-path=%{configpath} \
120ac263 126 --with-init-script=sysv,systemd \
67c70229 127 --with-distro=pld
0886a606
AM
128
129%{__make}
e5afa52e 130%{__make} -C doc
0886a606
AM
131
132%install
133rm -rf $RPM_BUILD_ROOT
f10dfb13 134install -d $RPM_BUILD_ROOT{%{configpath},/var/{cache,log}/lxc}
0886a606 135%{__make} install \
e5afa52e 136 DESTDIR=$RPM_BUILD_ROOT \
137 pcdatadir=%{_pkgconfigdir}
33aee790 138
e5afa52e 139%{__make} -C doc install \
0886a606 140 DESTDIR=$RPM_BUILD_ROOT
33aee790 141
21c5c666 142%{__rm} -r $RPM_BUILD_ROOT%{_docdir}
0886a606 143
67c70229
JB
144%if %{with python}
145%py3_comp $RPM_BUILD_ROOT%{py3_sitedir}/lxc
146%py3_ocomp $RPM_BUILD_ROOT%{py3_sitedir}/lxc
147%endif
c34ce688
JB
148%if %{with lua}
149%{__sed} -i -e '1s,#!/usr/bin/env lua,#!/usr/bin/lua51,' $RPM_BUILD_ROOT%{_bindir}/lxc-top
150%endif
67c70229 151
0886a606
AM
152%clean
153rm -rf $RPM_BUILD_ROOT
154
67c70229
JB
155%post -p /sbin/ldconfig
156%postun -p /sbin/ldconfig
0886a606
AM
157
158%files
159%defattr(644,root,root,755)
247c2ba9 160%doc AUTHORS CONTRIBUTING MAINTAINERS README TODO doc/FAQ.txt doc/examples/*.conf
c34ce688
JB
161%attr(755,root,root) %{_bindir}/lxc-attach
162%attr(755,root,root) %{_bindir}/lxc-cgroup
163%attr(755,root,root) %{_bindir}/lxc-checkconfig
164%attr(755,root,root) %{_bindir}/lxc-checkpoint
165%attr(755,root,root) %{_bindir}/lxc-clone
247c2ba9 166%attr(755,root,root) %{_bindir}/lxc-config
c34ce688
JB
167%attr(755,root,root) %{_bindir}/lxc-console
168%attr(755,root,root) %{_bindir}/lxc-create
169%attr(755,root,root) %{_bindir}/lxc-destroy
170%attr(755,root,root) %{_bindir}/lxc-execute
171%attr(755,root,root) %{_bindir}/lxc-freeze
172%attr(755,root,root) %{_bindir}/lxc-info
173%attr(755,root,root) %{_bindir}/lxc-kill
174%attr(755,root,root) %{_bindir}/lxc-monitor
247c2ba9 175%attr(755,root,root) %{_bindir}/lxc-monitord
c34ce688
JB
176%attr(755,root,root) %{_bindir}/lxc-netstat
177%attr(755,root,root) %{_bindir}/lxc-ps
178%attr(755,root,root) %{_bindir}/lxc-restart
247c2ba9 179%attr(755,root,root) %{_bindir}/lxc-snapshot
c34ce688
JB
180%attr(755,root,root) %{_bindir}/lxc-start
181%attr(755,root,root) %{_bindir}/lxc-stop
182%attr(755,root,root) %{_bindir}/lxc-unfreeze
183%attr(755,root,root) %{_bindir}/lxc-unshare
247c2ba9 184%attr(755,root,root) %{_bindir}/lxc-user-nic
120ac263 185%attr(755,root,root) %{_bindir}/lxc-usernsexec
c34ce688
JB
186%attr(755,root,root) %{_bindir}/lxc-version
187%attr(755,root,root) %{_bindir}/lxc-wait
e5afa52e 188%attr(755,root,root) %{_libdir}/liblxc.so.*.*.*
247c2ba9 189%attr(755,root,root) %ghost %{_libdir}/liblxc.so.1
70f9d22b 190%dir %{_libdir}/lxc
70f9d22b 191%dir %{_libdir}/lxc/rootfs
67c70229 192%{_libdir}/lxc/rootfs/README
70f9d22b 193%attr(755,root,root) %{_libdir}/lxc/lxc-init
dc9a5b3b 194%dir %{_sysconfdir}/lxc
67c70229 195%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lxc/default.conf
120ac263 196%dir %{_datadir}/%{name}
f5933d47 197%{_datadir}/%{name}/lxc.functions
120ac263
ER
198%dir %{_datadir}/%{name}/config
199%{_datadir}/%{name}/config/ubuntu*.conf
f5933d47
ER
200%dir %{_datadir}/%{name}/hooks
201%dir %{_datadir}/%{name}/templates
202%attr(755,root,root) %{_datadir}/%{name}/hooks/mount*
247c2ba9
ER
203%attr(755,root,root) %{_datadir}/%{name}/hooks/clonehostname
204%attr(755,root,root) %{_datadir}/%{name}/hooks/ubuntu-cloud-prep
f5933d47 205%attr(755,root,root) %{_datadir}/%{name}/templates/lxc-*
c34ce688
JB
206%{_mandir}/man1/lxc-attach.1*
207%{_mandir}/man1/lxc-cgroup.1*
208%{_mandir}/man1/lxc-checkconfig.1*
209%{_mandir}/man1/lxc-checkpoint.1*
210%{_mandir}/man1/lxc-clone.1*
211%{_mandir}/man1/lxc-console.1*
212%{_mandir}/man1/lxc-create.1*
213%{_mandir}/man1/lxc-destroy.1*
214%{_mandir}/man1/lxc-execute.1*
215%{_mandir}/man1/lxc-freeze.1*
216%{_mandir}/man1/lxc-info.1*
217%{_mandir}/man1/lxc-kill.1*
218%{_mandir}/man1/lxc-monitor.1*
219%{_mandir}/man1/lxc-netstat.1*
220%{_mandir}/man1/lxc-ps.1*
221%{_mandir}/man1/lxc-restart.1*
247c2ba9 222%{_mandir}/man1/lxc-snapshot.1*
c34ce688
JB
223%{_mandir}/man1/lxc-start.1*
224%{_mandir}/man1/lxc-stop.1*
225%{_mandir}/man1/lxc-unfreeze.1*
226%{_mandir}/man1/lxc-unshare.1*
120ac263 227%{_mandir}/man1/lxc-user-nic.1*
c34ce688
JB
228%{_mandir}/man1/lxc-version.1*
229%{_mandir}/man1/lxc-wait.1*
120ac263 230%{_mandir}/man5/lxc-usernet.5*
67c70229
JB
231%{_mandir}/man5/lxc.conf.5*
232%{_mandir}/man7/lxc.7*
247c2ba9
ER
233%lang(ja) %{_mandir}/ja/man1/lxc*.1*
234%lang(ja) %{_mandir}/ja/man5/lxc.conf.5*
235%lang(ja) %{_mandir}/ja/man7/lxc.7*
236%exclude %{_mandir}/ja/man1/lxc-device.1*
237%exclude %{_mandir}/ja/man1/lxc-ls.1*
238%exclude %{_mandir}/ja/man1/lxc-start-ephemeral.1*
239%exclude %{_mandir}/ja/man1/lxc-top.1*
240
c34ce688
JB
241%if %{without python}
242# legacy version
243%attr(755,root,root) %{_bindir}/lxc-ls
244%{_mandir}/man1/lxc-ls.1*
245%endif
0886a606 246
ff8ce371 247%dir %{configpath}
f10dfb13
ER
248%dir %attr(750,root,root) /var/log/lxc
249%dir %attr(750,root,root) /var/cache/lxc
ff8ce371 250
0886a606
AM
251%files devel
252%defattr(644,root,root,755)
0886a606 253%attr(755,root,root) %{_libdir}/liblxc.so
67c70229 254%{_includedir}/lxc
e5afa52e 255%{_pkgconfigdir}/lxc.pc
67c70229
JB
256
257%if %{with lua}
258%files -n lua-lxc
259%defattr(644,root,root,755)
c34ce688 260%attr(755,root,root) %{_bindir}/lxc-top
247c2ba9
ER
261%dir %{_libdir}/lua/lxc
262%attr(755,root,root) %{_libdir}/lua/lxc/core.so
263%{_datadir}/lua/lxc.lua
c34ce688 264%{_mandir}/man1/lxc-top.1*
247c2ba9 265%lang(ja) %{_mandir}/ja/man1/lxc-top.1*
67c70229
JB
266%endif
267
268%if %{with python}
269%files -n python3-lxc
270%defattr(644,root,root,755)
c34ce688
JB
271%attr(755,root,root) %{_bindir}/lxc-device
272%attr(755,root,root) %{_bindir}/lxc-ls
273%attr(755,root,root) %{_bindir}/lxc-start-ephemeral
67c70229
JB
274%{py3_sitedir}/lxc
275%attr(755,root,root) %{py3_sitedir}/_lxc.cpython-*.so
276%{py3_sitedir}/_lxc-0.1-py*.egg-info
c34ce688
JB
277%{_mandir}/man1/lxc-device.1*
278%{_mandir}/man1/lxc-ls.1*
279%{_mandir}/man1/lxc-start-ephemeral.1*
247c2ba9
ER
280%lang(ja) %{_mandir}/ja/man1/lxc-device.1*
281%lang(ja) %{_mandir}/ja/man1/lxc-ls.1*
282%lang(ja) %{_mandir}/ja/man1/lxc-start-ephemeral.1*
67c70229 283%endif
This page took 0.127575 seconds and 4 git commands to generate.