]> git.pld-linux.org Git - packages/lxc.git/blame - lxc.spec
- added pld patch
[packages/lxc.git] / lxc.spec
CommitLineData
67c70229
JB
1# TODO: move lua/python-dependent utils to lya-/python-
2#
3# Conditional build:
4%bcond_without seccomp # SecComp syscall filter
5%bcond_without lua # Lua binding
6%bcond_without python # Python binding
7#
0886a606 8Summary: Linux Container Tools
67c70229 9Summary(pl.UTF-8): Narzędzia do kontenerów linuksowych (LXC)
0886a606 10Name: lxc
dc9a5b3b 11Version: 0.9.0
a859d7b5 12Release: 1
0886a606 13License: GPL
67c70229 14Group: Applications/System
a859d7b5
AS
15Source0: http://lxc.sourceforge.net/download/lxc/%{name}-%{version}.tar.gz
16# Source0-md5: 8552a4479090616f4bc04d8473765fc9
33aee790 17Patch0: %{name}-devpts.patch
67c70229
JB
18Patch1: %{name}-pld.patch
19URL: http://lxc.sourceforge.net/
20BuildRequires: autoconf >= 2.50
21BuildRequires: automake
22BuildRequires: docbook2X
e5afa52e 23BuildRequires: docbook-dtd30-sgml
24BuildRequires: docbook-utils
67c70229 25BuildRequires: libapparmor-devel
4e32c712 26BuildRequires: libcap-devel
67c70229
JB
27%{?with_seccomp:BuildRequires: libseccomp-devel}
28%{?with_lua:BuildRequires: lua51-devel >= 5.1}
29BuildRequires: pkgconfig
30%{?with_python:BuildRequires: python3-devel >= 3.2}
31BuildRequires: rpmbuild(macros) >= 1.612
0886a606
AM
32BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
e5afa52e 34%define configpath /var/lib/lxc
35
0886a606
AM
36%description
37Tools to create and manage containers. It contains a full featured
38container with the isolation / virtualization of the pids, the ipc,
39the utsname, the mount points, /proc, /sys, the network and it takes
40into account the control groups. It is very light, flexible, and
41provides a set of tools around the container like the monitoring with
42asynchronous events notification, or the freeze of the container. This
43package is useful to create Virtual Private Server, or to run isolated
44applications like bash or sshd.
45
67c70229
JB
46%description -l pl.UTF-8
47Narzędzia do tworzenia i zarządzania kontenerami. System ten obejmuje
48w pełni funkcjonalne kontenery z ilozacją/wirtualizacją pidów, ipc,
49utsname, punktów montowania, /proc, /sys, sieci oraz uwzględniające
50grupy kontrolne. Jest bardzo lekki, elastyczny i udostępnia narzędzia
51do czynności związanych z kontenerami, takich jak monitorowanie z
52asynchronicznym powiadamianiem o zdarzeniach czy zamrażanie. Ten
53pakiet jest przydatny do tworzenia wirtualnych serwerów prywatnych
54oraz uruchamiania izolowanych aplikacji, takich jak bash czy sshd.
55
0886a606 56%package devel
67c70229
JB
57Summary: Header files for lxc library
58Summary(pl.UTF-8): Pliki nagłówkowe biblioteki lxc
0886a606 59Group: Development/Libraries
67c70229 60Requires: %{name} = %{version}-%{release}
0886a606
AM
61
62%description devel
67c70229
JB
63Header files for lxc library.
64
65%description devel -l pl.UTF-8
66Pliki nagłówkowe biblioteki lxc.
67
68%package -n lua-lxc
69Summary: Lua binding for LXC
70Summary(pl.UTF-8): Wiązanie Lua do LXC
71Group: Libraries
72Requires: %{name} = %{version}-%{release}
73Requires: lua51-libs >= 5.1
74
75%description -n lua-lxc
76Lua binding for LXC.
77
78%description -n lua-lxc -l pl.UTF-8
79Wiązanie Lua do LXC.
80
81%package -n python3-lxc
82Summary: Python (3.x) binding for LXC
83Summary(pl.UTF-8): Wiązanie Pythona (3.x) do LXC
84Group: Libraries
85Requires: %{name} = %{version}-%{release}
86Requires: python3-libs >= 3.2
87
88%description -n python3-lxc
89Python (3.x) binding for LXC.
90
91%description -n python3-lxc -l pl.UTF-8
92Wiązanie Pythona (3.x) do LXC.
0886a606 93
0886a606 94%prep
67c70229 95%setup -q
33aee790 96%patch0 -p1
67c70229 97%patch1 -p1
0886a606
AM
98
99%build
67c70229
JB
100%{__aclocal} -I config
101%{__autoconf}
102%{__autoheader}
103%{__automake}
e5afa52e 104%configure \
67c70229
JB
105 db2xman=docbook2X2man \
106 --disable-rpath \
107 --enable-doc \
108 %{?with_lua:--enable-lua} \
109 %{?with_python:--enable-python} \
110 %{?with_seccomp:--enable-seccomp} \
111 --with-config-path=%{configpath} \
112 --with-distro=pld
0886a606
AM
113
114%{__make}
e5afa52e 115%{__make} -C doc
0886a606
AM
116
117%install
118rm -rf $RPM_BUILD_ROOT
119
120%{__make} install \
e5afa52e 121 DESTDIR=$RPM_BUILD_ROOT \
122 pcdatadir=%{_pkgconfigdir}
33aee790 123
e5afa52e 124%{__make} -C doc install \
0886a606 125 DESTDIR=$RPM_BUILD_ROOT
33aee790
JR
126
127%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/doc
0886a606 128
e5afa52e 129install -d $RPM_BUILD_ROOT%{configpath}
e2e45f68 130
67c70229
JB
131%if %{with python}
132%py3_comp $RPM_BUILD_ROOT%{py3_sitedir}/lxc
133%py3_ocomp $RPM_BUILD_ROOT%{py3_sitedir}/lxc
134%endif
135
0886a606
AM
136%clean
137rm -rf $RPM_BUILD_ROOT
138
67c70229
JB
139%post -p /sbin/ldconfig
140%postun -p /sbin/ldconfig
0886a606
AM
141
142%files
143%defattr(644,root,root,755)
dc9a5b3b 144%doc AUTHORS ChangeLog CONTRIBUTING MAINTAINERS README TODO doc/FAQ.txt doc/examples/*.conf
67c70229 145%attr(755,root,root) %{_bindir}/lxc-*
e5afa52e 146%attr(755,root,root) %{_libdir}/liblxc.so.*.*.*
147%attr(755,root,root) %ghost %{_libdir}/liblxc.so.0
e5afa52e 148%dir %{configpath}
70f9d22b 149%dir %{_libdir}/lxc
70f9d22b 150%dir %{_libdir}/lxc/rootfs
67c70229 151%{_libdir}/lxc/rootfs/README
70f9d22b 152%attr(755,root,root) %{_libdir}/lxc/lxc-init
dc9a5b3b 153%dir %{_sysconfdir}/lxc
67c70229 154%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lxc/default.conf
dc9a5b3b 155%{_datadir}/lxc
67c70229
JB
156%{_mandir}/man1/lxc-*.1*
157%{_mandir}/man5/lxc.conf.5*
158%{_mandir}/man7/lxc.7*
0886a606
AM
159
160%files devel
161%defattr(644,root,root,755)
0886a606 162%attr(755,root,root) %{_libdir}/liblxc.so
67c70229 163%{_includedir}/lxc
e5afa52e 164%{_pkgconfigdir}/lxc.pc
67c70229
JB
165
166%if %{with lua}
167%files -n lua-lxc
168%defattr(644,root,root,755)
169%dir %{_libdir}/lua/5.1/lxc
170%attr(755,root,root) %{_libdir}/lua/5.1/lxc/core.so
171%{_datadir}/lua/5.1/lxc.lua
172%endif
173
174%if %{with python}
175%files -n python3-lxc
176%defattr(644,root,root,755)
177%{py3_sitedir}/lxc
178%attr(755,root,root) %{py3_sitedir}/_lxc.cpython-*.so
179%{py3_sitedir}/_lxc-0.1-py*.egg-info
180%endif
This page took 0.043245 seconds and 4 git commands to generate.