]> git.pld-linux.org Git - packages/lxc.git/blame - lxc.spec
suggest net-tools, lxc-ps uses netstat(1)
[packages/lxc.git] / lxc.spec
CommitLineData
67c70229
JB
1#
2# Conditional build:
3%bcond_without seccomp # SecComp syscall filter
4%bcond_without lua # Lua binding
5%bcond_without python # Python binding
21c5c666 6
0886a606 7Summary: Linux Container Tools
67c70229 8Summary(pl.UTF-8): Narzędzia do kontenerów linuksowych (LXC)
0886a606 9Name: lxc
dc9a5b3b 10Version: 0.9.0
21c5c666 11Release: 2
c34ce688 12License: LGPL v2.1+
67c70229 13Group: Applications/System
a859d7b5
AS
14Source0: http://lxc.sourceforge.net/download/lxc/%{name}-%{version}.tar.gz
15# Source0-md5: 8552a4479090616f4bc04d8473765fc9
33aee790 16Patch0: %{name}-devpts.patch
67c70229
JB
17Patch1: %{name}-pld.patch
18URL: http://lxc.sourceforge.net/
19BuildRequires: autoconf >= 2.50
20BuildRequires: automake
e5afa52e 21BuildRequires: docbook-dtd30-sgml
22BuildRequires: docbook-utils
21c5c666 23BuildRequires: docbook2X
67c70229 24BuildRequires: libapparmor-devel
4e32c712 25BuildRequires: libcap-devel
67c70229
JB
26%{?with_seccomp:BuildRequires: libseccomp-devel}
27%{?with_lua:BuildRequires: lua51-devel >= 5.1}
28BuildRequires: pkgconfig
29%{?with_python:BuildRequires: python3-devel >= 3.2}
30BuildRequires: rpmbuild(macros) >= 1.612
c34ce688 31BuildRequires: sed >= 4.0
21c5c666 32Suggests: net-tools
0886a606
AM
33BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
e5afa52e 35%define configpath /var/lib/lxc
36
0886a606
AM
37%description
38Tools to create and manage containers. It contains a full featured
39container with the isolation / virtualization of the pids, the ipc,
40the utsname, the mount points, /proc, /sys, the network and it takes
41into account the control groups. It is very light, flexible, and
42provides a set of tools around the container like the monitoring with
43asynchronous events notification, or the freeze of the container. This
44package is useful to create Virtual Private Server, or to run isolated
45applications like bash or sshd.
46
67c70229
JB
47%description -l pl.UTF-8
48Narzędzia do tworzenia i zarządzania kontenerami. System ten obejmuje
49w pełni funkcjonalne kontenery z ilozacją/wirtualizacją pidów, ipc,
50utsname, punktów montowania, /proc, /sys, sieci oraz uwzględniające
51grupy kontrolne. Jest bardzo lekki, elastyczny i udostępnia narzędzia
52do czynności związanych z kontenerami, takich jak monitorowanie z
53asynchronicznym powiadamianiem o zdarzeniach czy zamrażanie. Ten
54pakiet jest przydatny do tworzenia wirtualnych serwerów prywatnych
55oraz uruchamiania izolowanych aplikacji, takich jak bash czy sshd.
56
0886a606 57%package devel
67c70229
JB
58Summary: Header files for lxc library
59Summary(pl.UTF-8): Pliki nagłówkowe biblioteki lxc
0886a606 60Group: Development/Libraries
67c70229 61Requires: %{name} = %{version}-%{release}
0886a606
AM
62
63%description devel
67c70229
JB
64Header files for lxc library.
65
66%description devel -l pl.UTF-8
67Pliki nagłówkowe biblioteki lxc.
68
69%package -n lua-lxc
70Summary: Lua binding for LXC
71Summary(pl.UTF-8): Wiązanie Lua do LXC
72Group: Libraries
73Requires: %{name} = %{version}-%{release}
74Requires: lua51-libs >= 5.1
75
76%description -n lua-lxc
77Lua binding for LXC.
78
79%description -n lua-lxc -l pl.UTF-8
80Wiązanie Lua do LXC.
81
82%package -n python3-lxc
83Summary: Python (3.x) binding for LXC
84Summary(pl.UTF-8): Wiązanie Pythona (3.x) do LXC
85Group: Libraries
86Requires: %{name} = %{version}-%{release}
87Requires: python3-libs >= 3.2
88
89%description -n python3-lxc
90Python (3.x) binding for LXC.
91
92%description -n python3-lxc -l pl.UTF-8
93Wiązanie Pythona (3.x) do LXC.
0886a606 94
0886a606 95%prep
67c70229 96%setup -q
33aee790 97%patch0 -p1
67c70229 98%patch1 -p1
0886a606
AM
99
100%build
67c70229
JB
101%{__aclocal} -I config
102%{__autoconf}
103%{__autoheader}
104%{__automake}
e5afa52e 105%configure \
67c70229
JB
106 db2xman=docbook2X2man \
107 --disable-rpath \
108 --enable-doc \
109 %{?with_lua:--enable-lua} \
110 %{?with_python:--enable-python} \
111 %{?with_seccomp:--enable-seccomp} \
112 --with-config-path=%{configpath} \
113 --with-distro=pld
0886a606
AM
114
115%{__make}
e5afa52e 116%{__make} -C doc
0886a606
AM
117
118%install
119rm -rf $RPM_BUILD_ROOT
120
121%{__make} install \
e5afa52e 122 DESTDIR=$RPM_BUILD_ROOT \
123 pcdatadir=%{_pkgconfigdir}
33aee790 124
e5afa52e 125%{__make} -C doc install \
0886a606 126 DESTDIR=$RPM_BUILD_ROOT
33aee790 127
21c5c666 128%{__rm} -r $RPM_BUILD_ROOT%{_docdir}
0886a606 129
e5afa52e 130install -d $RPM_BUILD_ROOT%{configpath}
e2e45f68 131
67c70229
JB
132%if %{with python}
133%py3_comp $RPM_BUILD_ROOT%{py3_sitedir}/lxc
134%py3_ocomp $RPM_BUILD_ROOT%{py3_sitedir}/lxc
135%endif
c34ce688
JB
136%if %{with lua}
137%{__sed} -i -e '1s,#!/usr/bin/env lua,#!/usr/bin/lua51,' $RPM_BUILD_ROOT%{_bindir}/lxc-top
138%endif
67c70229 139
0886a606
AM
140%clean
141rm -rf $RPM_BUILD_ROOT
142
67c70229
JB
143%post -p /sbin/ldconfig
144%postun -p /sbin/ldconfig
0886a606
AM
145
146%files
147%defattr(644,root,root,755)
dc9a5b3b 148%doc AUTHORS ChangeLog CONTRIBUTING MAINTAINERS README TODO doc/FAQ.txt doc/examples/*.conf
c34ce688
JB
149%attr(755,root,root) %{_bindir}/lxc-attach
150%attr(755,root,root) %{_bindir}/lxc-cgroup
151%attr(755,root,root) %{_bindir}/lxc-checkconfig
152%attr(755,root,root) %{_bindir}/lxc-checkpoint
153%attr(755,root,root) %{_bindir}/lxc-clone
154%attr(755,root,root) %{_bindir}/lxc-console
155%attr(755,root,root) %{_bindir}/lxc-create
156%attr(755,root,root) %{_bindir}/lxc-destroy
157%attr(755,root,root) %{_bindir}/lxc-execute
158%attr(755,root,root) %{_bindir}/lxc-freeze
159%attr(755,root,root) %{_bindir}/lxc-info
160%attr(755,root,root) %{_bindir}/lxc-kill
161%attr(755,root,root) %{_bindir}/lxc-monitor
162%attr(755,root,root) %{_bindir}/lxc-netstat
163%attr(755,root,root) %{_bindir}/lxc-ps
164%attr(755,root,root) %{_bindir}/lxc-restart
165%attr(755,root,root) %{_bindir}/lxc-shutdown
166%attr(755,root,root) %{_bindir}/lxc-start
167%attr(755,root,root) %{_bindir}/lxc-stop
168%attr(755,root,root) %{_bindir}/lxc-unfreeze
169%attr(755,root,root) %{_bindir}/lxc-unshare
170%attr(755,root,root) %{_bindir}/lxc-version
171%attr(755,root,root) %{_bindir}/lxc-wait
e5afa52e 172%attr(755,root,root) %{_libdir}/liblxc.so.*.*.*
173%attr(755,root,root) %ghost %{_libdir}/liblxc.so.0
e5afa52e 174%dir %{configpath}
70f9d22b 175%dir %{_libdir}/lxc
70f9d22b 176%dir %{_libdir}/lxc/rootfs
67c70229 177%{_libdir}/lxc/rootfs/README
70f9d22b 178%attr(755,root,root) %{_libdir}/lxc/lxc-init
dc9a5b3b 179%dir %{_sysconfdir}/lxc
67c70229 180%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lxc/default.conf
dc9a5b3b 181%{_datadir}/lxc
c34ce688
JB
182%{_mandir}/man1/lxc-attach.1*
183%{_mandir}/man1/lxc-cgroup.1*
184%{_mandir}/man1/lxc-checkconfig.1*
185%{_mandir}/man1/lxc-checkpoint.1*
186%{_mandir}/man1/lxc-clone.1*
187%{_mandir}/man1/lxc-console.1*
188%{_mandir}/man1/lxc-create.1*
189%{_mandir}/man1/lxc-destroy.1*
190%{_mandir}/man1/lxc-execute.1*
191%{_mandir}/man1/lxc-freeze.1*
192%{_mandir}/man1/lxc-info.1*
193%{_mandir}/man1/lxc-kill.1*
194%{_mandir}/man1/lxc-monitor.1*
195%{_mandir}/man1/lxc-netstat.1*
196%{_mandir}/man1/lxc-ps.1*
197%{_mandir}/man1/lxc-restart.1*
198%{_mandir}/man1/lxc-shutdown.1*
199%{_mandir}/man1/lxc-start.1*
200%{_mandir}/man1/lxc-stop.1*
201%{_mandir}/man1/lxc-unfreeze.1*
202%{_mandir}/man1/lxc-unshare.1*
203%{_mandir}/man1/lxc-version.1*
204%{_mandir}/man1/lxc-wait.1*
67c70229
JB
205%{_mandir}/man5/lxc.conf.5*
206%{_mandir}/man7/lxc.7*
c34ce688
JB
207%if %{without python}
208# legacy version
209%attr(755,root,root) %{_bindir}/lxc-ls
210%{_mandir}/man1/lxc-ls.1*
211%endif
0886a606
AM
212
213%files devel
214%defattr(644,root,root,755)
0886a606 215%attr(755,root,root) %{_libdir}/liblxc.so
67c70229 216%{_includedir}/lxc
e5afa52e 217%{_pkgconfigdir}/lxc.pc
67c70229
JB
218
219%if %{with lua}
220%files -n lua-lxc
221%defattr(644,root,root,755)
c34ce688 222%attr(755,root,root) %{_bindir}/lxc-top
67c70229
JB
223%dir %{_libdir}/lua/5.1/lxc
224%attr(755,root,root) %{_libdir}/lua/5.1/lxc/core.so
225%{_datadir}/lua/5.1/lxc.lua
c34ce688 226%{_mandir}/man1/lxc-top.1*
67c70229
JB
227%endif
228
229%if %{with python}
230%files -n python3-lxc
231%defattr(644,root,root,755)
c34ce688
JB
232%attr(755,root,root) %{_bindir}/lxc-device
233%attr(755,root,root) %{_bindir}/lxc-ls
234%attr(755,root,root) %{_bindir}/lxc-start-ephemeral
67c70229
JB
235%{py3_sitedir}/lxc
236%attr(755,root,root) %{py3_sitedir}/_lxc.cpython-*.so
237%{py3_sitedir}/_lxc-0.1-py*.egg-info
c34ce688
JB
238%{_mandir}/man1/lxc-device.1*
239%{_mandir}/man1/lxc-ls.1*
240%{_mandir}/man1/lxc-start-ephemeral.1*
67c70229 241%endif
This page took 0.144671 seconds and 4 git commands to generate.