]> git.pld-linux.org Git - packages/luajit.git/blob - luajit.spec
use amalgamated build as per documentation suggestion doc/install.html
[packages/luajit.git] / luajit.spec
1 Summary:        Just-in-Time compiler for Lua
2 Summary(pl.UTF-8):      Kompilator JIT dla języka Lua
3 Name:           luajit
4 Version:        2.0.3
5 Release:        2
6 License:        MIT
7 Group:          Libraries
8 # Source0Download: http://luajit.org/download.html
9 Source0:        http://luajit.org/download/LuaJIT-%{version}.tar.gz
10 # Source0-md5:  f14e9104be513913810cd59c8c658dc0
11 URL:            http://luajit.org/
12 BuildRequires:  sed >= 4.0
13 ExclusiveArch:  %{ix86} %{x8664} arm mips ppc
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %define         lua_abi         5.1
17
18 %description
19 LuaJIT is a Just-In-Time (JIT) compiler for the Lua programming
20 language.
21
22 %description -l pl.UTF-8
23 LuaJIT to działający w locie (Just-In-Time) kompilator języka Lua.
24
25 %package devel
26 Summary:        Header files for LuaJIT library
27 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki LuaJIT
28 Group:          Development/Libraries
29 Requires:       %{name} = %{version}-%{release}
30
31 %description devel
32 Header files for LuaJIT library.
33
34 %description devel -l pl.UTF-8
35 Pliki nagłówkowe biblioteki LuaJIT.
36
37 %package static
38 Summary:        Static LuaJIT library
39 Summary(pl.UTF-8):      Statyczna biblioteka LuaJIT
40 Group:          Development/Libraries
41 Requires:       %{name}-devel = %{version}-%{release}
42
43 %description static
44 Static LuaJIT library.
45
46 %description static -l pl.UTF-8
47 Statyczna biblioteka LuaJIT.
48
49 %prep
50 %setup -q -n LuaJIT-%{version}
51
52 # preserve timestamps
53 sed -i -e '/install -m/s/-m/-p -m/' Makefile
54
55 %build
56 # Q= - enable verbose output
57 # E= @: - disable @echo messages
58 # NOTE: we use amalgamated build as per documentation suggestion doc/install.html
59 %{__make} \
60         CC="%{__cc}" \
61         CCOPT="%{rpmcflags} -fomit-frame-pointer" \
62         CCOPT_x86= \
63         MULTILIB=%{_lib} \
64         E="@:" \
65         Q= \
66         amalg
67
68 %install
69 rm -rf $RPM_BUILD_ROOT
70 %{__make} install \
71         DESTDIR=$RPM_BUILD_ROOT \
72         PREFIX=%{_prefix} \
73         MULTILIB=%{_lib} \
74         LDCONFIG="/sbin/ldconfig -n"
75
76 %clean
77 rm -rf $RPM_BUILD_ROOT
78
79 %post   -p /sbin/ldconfig
80 %postun -p /sbin/ldconfig
81
82 %files
83 %defattr(644,root,root,755)
84 %doc COPYRIGHT README
85 %attr(755,root,root) %{_bindir}/luajit
86 %attr(755,root,root) %{_bindir}/luajit-%{version}
87 %attr(755,root,root) %{_libdir}/libluajit-%{lua_abi}.so.*.*.*
88 %attr(755,root,root) %ghost %{_libdir}/libluajit-%{lua_abi}.so.2
89 %{_datadir}/luajit-%{version}
90 %{_mandir}/man1/luajit.1*
91 # lua module dirs (shared with lua interpreters)
92 %dir %{_libdir}/lua
93 %dir %{_libdir}/lua/%{lua_abi}
94 %dir %{_datadir}/lua
95 %dir %{_datadir}/lua/%{lua_abi}
96
97 %files devel
98 %defattr(644,root,root,755)
99 %doc doc/*
100 %attr(755,root,root) %{_libdir}/libluajit-%{lua_abi}.so
101 %{_includedir}/luajit-2.0
102 %{_pkgconfigdir}/luajit.pc
103
104 %files static
105 %defattr(644,root,root,755)
106 %{_libdir}/libluajit-%{lua_abi}.a
This page took 0.093537 seconds and 3 git commands to generate.