]> git.pld-linux.org Git - packages/lttng-modules.git/commitdiff
- fix building with kernel 6.2, rel 3 auto/th/lttng-modules-2.13.8-3
authorJan Rękorajski <baggins@pld-linux.org>
Sat, 25 Feb 2023 12:52:45 +0000 (13:52 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Sat, 25 Feb 2023 12:52:45 +0000 (13:52 +0100)
kernel-6.2.patch [new file with mode: 0644]
lttng-modules.spec

diff --git a/kernel-6.2.patch b/kernel-6.2.patch
new file mode 100644 (file)
index 0000000..378bca1
--- /dev/null
@@ -0,0 +1,38 @@
+commit 4e4fb933c8a6b85ac3d5a60a417726e20e2cc695
+Author: Michael Jeanson <mjeanson@efficios.com>
+Date:   Mon Jan 16 15:01:51 2023 -0500
+
+    fix: btrfs: move accessor helpers into accessors.h (v6.2)
+    
+    See upstream commit :
+    
+      commit 07e81dc94474eb62705c6f96d9ab1a5a797b8703
+      Author: Josef Bacik <josef@toxicpanda.com>
+      Date:   Wed Oct 19 10:51:00 2022 -0400
+    
+        btrfs: move accessor helpers into accessors.h
+    
+        This is a large patch, but because they're all macros it's impossible to
+        split up.  Simply copy all of the item accessors in ctree.h and paste
+        them in accessors.h, and then update any files to include the header so
+        everything compiles.
+    
+    Change-Id: I1f0876dd8b7a8687f6802b60c3e3baabd017cc52
+    Signed-off-by: Michael Jeanson <mjeanson@efficios.com>
+    Signed-off-by: Mathieu Desnoyers <mathieu.desnoyers@efficios.com>
+
+diff --git a/include/instrumentation/events/btrfs.h b/include/instrumentation/events/btrfs.h
+index 4664d45a..3e4ac56d 100644
+--- a/include/instrumentation/events/btrfs.h
++++ b/include/instrumentation/events/btrfs.h
+@@ -9,6 +9,10 @@
+ #include <linux/writeback.h>
+ #include <lttng/kernel-version.h>
++#if (LTTNG_LINUX_VERSION_CODE >= LTTNG_KERNEL_VERSION(6,2,0))
++#include <../fs/btrfs/accessors.h>
++#endif
++
+ #ifndef _TRACE_BTRFS_DEF_
+ #define _TRACE_BTRFS_DEF_
+ struct btrfs_root;
index 418d9baa3004474223db88946ea74d165b9dd870..60acf8ae3db07c0f004dcad102593f7e2f195833 100644 (file)
@@ -6,7 +6,7 @@
 # nothing to be placed to debuginfo package
 %define                _enable_debug_packages  0
 
-%define                rel     2
+%define                rel     3
 %define                pname   lttng-modules
 Summary:       LTTng 2.x kernel modules
 Summary(pl.UTF-8):     Moduły jądra LTTng 2.x
@@ -19,6 +19,7 @@ Source0:      https://lttng.org/files/lttng-modules/%{pname}-%{version}.tar.bz2
 # Source0-md5: 6bc042ac2d67437639d6c77f6ea45f29
 Patch0:                build.patch
 Patch1:                jbd2-tid-type.patch
+Patch2:                kernel-6.2.patch
 URL:           https://lttng.org/
 %{expand:%buildrequires_kernel kernel%%{_alt_kernel}-module-build >= 3:3.0}
 %{?with_kernelsrc:%{expand:%buildrequires_kernel kernel%%{_alt_kernel}-source >= 3:3.0}}
@@ -96,6 +97,7 @@ p=`pwd`\
 cd %{pname}-%{version}
 %patch0 -p1
 %patch1 -p1
+%patch2 -p1
 
 %build
 cd  %{pname}-%{version}
This page took 0.300589 seconds and 4 git commands to generate.