]> git.pld-linux.org Git - packages/lttng-modules.git/commitdiff
- kernel 5.10 compatibility fix, rel 3 auto/th/lttng-modules-2.13.4-3
authorJan Rękorajski <baggins@pld-linux.org>
Sun, 28 Aug 2022 20:09:27 +0000 (22:09 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Sun, 28 Aug 2022 20:09:27 +0000 (22:09 +0200)
kernel-5.10.137.patch [new file with mode: 0644]
lttng-modules.spec

diff --git a/kernel-5.10.137.patch b/kernel-5.10.137.patch
new file mode 100644 (file)
index 0000000..fffe0c5
--- /dev/null
@@ -0,0 +1,86 @@
+commit 5dab3d515b6f5c5ac80c8e7674628495e3bf4ac6
+Author: Michael Jeanson <mjeanson@efficios.com>
+Date:   Mon Aug 22 14:16:27 2022 -0400
+
+    fix: adjust range v5.10.137 in block probe
+    
+    See upstream commit, backported in v5.10.137 :
+    
+    commit 1cb3032406423b25aa984854b4d78e0100d292dd
+    Author: Christoph Hellwig <hch@lst.de>
+    Date:   Thu Dec 3 17:21:39 2020 +0100
+    
+        block: remove the request_queue to argument request based tracepoints
+    
+        [ Upstream commit a54895fa057c67700270777f7661d8d3c7fda88a ]
+    
+        The request_queue can trivially be derived from the request.
+    
+    Change-Id: I01f96a437641421faf993b4b031171c372bd0374
+    Signed-off-by: Michael Jeanson <mjeanson@efficios.com>
+    Signed-off-by: Mathieu Desnoyers <mathieu.desnoyers@efficios.com>
+
+diff --git a/include/instrumentation/events/block.h b/include/instrumentation/events/block.h
+index 882e6e08..d4821c12 100644
+--- a/include/instrumentation/events/block.h
++++ b/include/instrumentation/events/block.h
+@@ -366,7 +366,8 @@ LTTNG_TRACEPOINT_EVENT(block_rq_requeue,
+                       lttng_req_op(rq), lttng_req_rw(rq), blk_rq_bytes(rq))
+       )
+ )
+-#elif (LTTNG_LINUX_VERSION_CODE >= LTTNG_KERNEL_VERSION(5,11,0))
++#elif (LTTNG_LINUX_VERSION_CODE >= LTTNG_KERNEL_VERSION(5,11,0) \
++      || LTTNG_KERNEL_RANGE(5,10,137, 5,11,0))
+ /**
+  * block_rq_requeue - place block IO request back on a queue
+  * @rq: block IO operation request
+@@ -611,7 +612,8 @@ LTTNG_TRACEPOINT_EVENT_CLASS(block_rq,
+               ctf_array_text(char, comm, current->comm, TASK_COMM_LEN)
+       )
+ )
+-#elif (LTTNG_LINUX_VERSION_CODE >= LTTNG_KERNEL_VERSION(5,11,0))
++#elif (LTTNG_LINUX_VERSION_CODE >= LTTNG_KERNEL_VERSION(5,11,0) \
++      || LTTNG_KERNEL_RANGE(5,10,137, 5,11,0))
+ LTTNG_TRACEPOINT_EVENT_CLASS(block_rq,
+       TP_PROTO(struct request *rq),
+@@ -746,7 +748,8 @@ LTTNG_TRACEPOINT_EVENT_CLASS_CODE(block_rq,
+ )
+ #endif /* #else #if (LTTNG_LINUX_VERSION_CODE >= LTTNG_KERNEL_VERSION(4,11,0)) */
+-#if (LTTNG_LINUX_VERSION_CODE >= LTTNG_KERNEL_VERSION(5,11,0))
++#if (LTTNG_LINUX_VERSION_CODE >= LTTNG_KERNEL_VERSION(5,11,0) \
++      || LTTNG_KERNEL_RANGE(5,10,137, 5,11,0))
+ /**
+  * block_rq_insert - insert block operation request into queue
+  * @rq: block IO operation request
+@@ -781,7 +784,8 @@ LTTNG_TRACEPOINT_EVENT_INSTANCE(block_rq, block_rq_insert,
+ )
+ #endif
+-#if (LTTNG_LINUX_VERSION_CODE >= LTTNG_KERNEL_VERSION(5,11,0))
++#if (LTTNG_LINUX_VERSION_CODE >= LTTNG_KERNEL_VERSION(5,11,0) \
++      || LTTNG_KERNEL_RANGE(5,10,137, 5,11,0))
+ /**
+  * block_rq_issue - issue pending block IO request operation to device driver
+  * @rq: block IO operation operation request
+@@ -812,7 +816,8 @@ LTTNG_TRACEPOINT_EVENT_INSTANCE(block_rq, block_rq_issue,
+ )
+ #endif
+-#if (LTTNG_LINUX_VERSION_CODE >= LTTNG_KERNEL_VERSION(5,11,0))
++#if (LTTNG_LINUX_VERSION_CODE >= LTTNG_KERNEL_VERSION(5,11,0) \
++      || LTTNG_KERNEL_RANGE(5,10,137, 5,11,0))
+ /**
+  * block_rq_merge - merge request with another one in the elevator
+  * @rq: block IO operation operation request
+@@ -1632,7 +1637,8 @@ LTTNG_TRACEPOINT_EVENT(block_rq_remap,
+                       lttng_req_op(rq), lttng_req_rw(rq), blk_rq_bytes(rq))
+       )
+ )
+-#elif (LTTNG_LINUX_VERSION_CODE >= LTTNG_KERNEL_VERSION(5,11,0))
++#elif (LTTNG_LINUX_VERSION_CODE >= LTTNG_KERNEL_VERSION(5,11,0) \
++      || LTTNG_KERNEL_RANGE(5,10,137, 5,11,0))
+ /**
+  * block_rq_remap - map request for a block operation request
+  * @rq: block IO operation request
index eb4ee66e8832a5facb4ec7e72323cffb7745f77e..738f2a098a7e5fc19d0467946aec6063ea8846a0 100644 (file)
@@ -6,7 +6,7 @@
 # nothing to be placed to debuginfo package
 %define                _enable_debug_packages  0
 
-%define                rel     2
+%define                rel     3
 %define                pname   lttng-modules
 Summary:       LTTng 2.x kernel modules
 Summary(pl.UTF-8):     Moduły jądra LTTng 2.x
@@ -19,6 +19,7 @@ Source0:      https://lttng.org/files/lttng-modules/%{pname}-%{version}.tar.bz2
 # Source0-md5: dbf1b247cc737183ee5994996a4a3769
 Patch0:                build.patch
 Patch1:                kernel-5.19.patch
+Patch2:                kernel-5.10.137.patch
 URL:           https://lttng.org/
 %{expand:%buildrequires_kernel kernel%%{_alt_kernel}-module-build >= 3:3.0}
 %{?with_kernelsrc:%{expand:%buildrequires_kernel kernel%%{_alt_kernel}-source >= 3:3.0}}
@@ -96,6 +97,7 @@ p=`pwd`\
 cd %{pname}-%{version}
 %patch0 -p1
 %patch1 -p1
+%patch2 -p1
 
 %build
 cd  %{pname}-%{version}
This page took 0.06228 seconds and 4 git commands to generate.