]> git.pld-linux.org Git - packages/lttng-modules.git/commitdiff
- upstream fix for building with kernel 6.6 auto/th/lttng-modules-2.13.10-1
authorJan Rękorajski <baggins@pld-linux.org>
Sun, 19 Nov 2023 12:44:28 +0000 (13:44 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Sun, 19 Nov 2023 12:44:28 +0000 (13:44 +0100)
kernel-6.6.patch [new file with mode: 0644]
lttng-modules.spec

diff --git a/kernel-6.6.patch b/kernel-6.6.patch
new file mode 100644 (file)
index 0000000..e9e375c
--- /dev/null
@@ -0,0 +1,43 @@
+From 6be48c9f6a32cdcab9824aaad0c19f92222633c4 Mon Sep 17 00:00:00 2001
+From: Kienan Stewart <kstewart@efficios.com>
+Date: Tue, 26 Sep 2023 14:45:09 -0400
+Subject: [PATCH] fix: lttng-probe-kvm-x86-mmu build with linux 6.6
+
+A small change was made upstream in `spte.h` that requires
+`arch/x86/kvm` to be added to the search path when
+building lttng-probe-kvm.x86-mmu.o.
+
+See upstream commit :
+
+  commit d10f3780bc2f80744d291e118c0c8bade54ed3b8
+  Author: Sean Christopherson <seanjc@google.com>
+  Date:   Tue Aug 8 15:40:59 2023 -0700
+
+      KVM: x86/mmu: Include mmu.h in spte.h
+
+      Explicitly include mmu.h in spte.h instead of relying on the "parent" to
+      include mmu.h.  spte.h references a variety of macros and variables that
+      are defined/declared in mmu.h, and so including spte.h before (or instead
+      of) mmu.h will result in build errors, e.g.
+
+Signed-off-by: Kienan Stewart <kstewart@efficios.com>
+Signed-off-by: Mathieu Desnoyers <mathieu.desnoyers@efficios.com>
+Change-Id: I5c3fc87d3b006cefbcca198e6e15868a342cb8dd
+---
+ src/probes/Kbuild | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/src/probes/Kbuild b/src/probes/Kbuild
+index eb0de4a8..73a15844 100644
+--- a/src/probes/Kbuild
++++ b/src/probes/Kbuild
+@@ -63,7 +63,8 @@ ifneq ($(CONFIG_KVM),)
+           ifeq ($(kvm_dep_emulate_check),ok)
+             CFLAGS_lttng-probe-kvm-x86.o += -I$(srctree)/virt/kvm \
+                        -I$(srctree)/arch/x86/kvm
+-            CFLAGS_lttng-probe-kvm-x86-mmu.o += -I$(srctree)/virt/kvm
++            CFLAGS_lttng-probe-kvm-x86-mmu.o += -I$(srctree)/virt/kvm \
++                       -I$(srctree)/arch/x86/kvm
+             obj-$(CONFIG_LTTNG) += lttng-probe-kvm-x86.o
+             obj-$(CONFIG_LTTNG) += lttng-probe-kvm-x86-mmu.o
+           else # ($(kvm_dep_emulate_check),ok)
index bd7cf3aff91bed4c7431333adc6aa31c35db4eb6..bdd562a2daee7ca689d3aac5cf9cdf74356ed91a 100644 (file)
@@ -6,7 +6,7 @@
 # nothing to be placed to debuginfo package
 %define                _enable_debug_packages  0
 
-%define                rel     0.1
+%define                rel     1
 %define                pname   lttng-modules
 Summary:       LTTng 2.x kernel modules
 Summary(pl.UTF-8):     Moduły jądra LTTng 2.x
@@ -18,6 +18,7 @@ Group:                Base/Kernel
 Source0:       https://lttng.org/files/lttng-modules/%{pname}-%{version}.tar.bz2
 # Source0-md5: eda323bb51c8fd414d30b7d6382d21a7
 Patch0:                build.patch
+Patch1:                kernel-6.6.patch
 URL:           https://lttng.org/
 %{expand:%buildrequires_kernel kernel%%{_alt_kernel}-module-build >= 3:3.0}
 %{?with_kernelsrc:%{expand:%buildrequires_kernel kernel%%{_alt_kernel}-source >= 3:3.0}}
@@ -94,6 +95,7 @@ p=`pwd`\
 %setup -qc -n %{name}-%{version}
 cd %{pname}-%{version}
 %patch0 -p1
+%patch1 -p1
 
 %build
 cd  %{pname}-%{version}
This page took 0.128889 seconds and 4 git commands to generate.