]> git.pld-linux.org Git - packages/live.git/commitdiff
- rediffed patches auto/th/live-2021.04.06-1
authorJakub Bogusz <qboosh@pld-linux.org>
Fri, 30 Apr 2021 04:58:04 +0000 (06:58 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Fri, 30 Apr 2021 04:58:04 +0000 (06:58 +0200)
live-link.patch
live-pkgconfig.patch
live.spec

index bda8bb46e05efdbbdadaf46abaffa77aa22382cc..e321edac0be4cc3d0b8452351b5104e2f7a2d771 100644 (file)
@@ -1,5 +1,5 @@
---- live/BasicUsageEnvironment/Makefile.tail.orig      2011-03-15 00:40:37.000000000 +0100
-+++ live/BasicUsageEnvironment/Makefile.tail   2011-03-16 18:09:05.547417970 +0100
+--- live/live/BasicUsageEnvironment/Makefile.tail.orig 2011-03-15 00:40:37.000000000 +0100
++++ live/live/BasicUsageEnvironment/Makefile.tail      2011-03-16 18:09:05.547417970 +0100
 @@ -8,9 +8,11 @@
        BasicTaskScheduler0.$(OBJ) BasicTaskScheduler.$(OBJ) \
        DelayQueue.$(OBJ) BasicHashTable.$(OBJ)
  
  .$(C).$(OBJ):
        $(C_COMPILER) -c $(C_FLAGS) $<       
---- live/groupsock/Makefile.tail.orig  2011-03-15 00:40:37.000000000 +0100
-+++ live/groupsock/Makefile.tail       2011-03-16 18:11:05.827411266 +0100
-@@ -25,10 +25,12 @@
+--- live-2021.04.06/live/groupsock/Makefile.tail.orig  2021-04-29 22:24:40.845013105 +0200
++++ live-2021.04.06/live/groupsock/Makefile.tail       2021-04-29 22:29:12.265873479 +0200
+@@ -24,10 +24,12 @@ NetInterface.$(CPP):       include/NetInterfac
  NetAddress.$(CPP):    include/NetAddress.hh include/GroupsockHelper.hh
- IOHandlers.$(CPP):    include/IOHandlers.hh include/TunnelEncaps.hh
+ IOHandlers.$(CPP):    include/IOHandlers.hh
  
 +LIBRARY_DEPS = ../BasicUsageEnvironment/libBasicUsageEnvironment.$(libBasicUsageEnvironment_LIB_SUFFIX) ../UsageEnvironment/libUsageEnvironment.$(libUsageEnvironment_LIB_SUFFIX)
 +
@@ -29,8 +29,8 @@
  
  clean:
        -rm -rf *.$(OBJ) $(ALL) core *.core *~ include/*~
---- live/liveMedia/Makefile.tail.orig  2020-05-19 19:11:05.573270651 +0200
-+++ live/liveMedia/Makefile.tail       2020-05-19 19:58:52.524405711 +0200
+--- live/live/liveMedia/Makefile.tail.orig     2020-05-19 19:11:05.573270651 +0200
++++ live/live/liveMedia/Makefile.tail  2020-05-19 19:58:52.524405711 +0200
 @@ -65,10 +65,12 @@
  
  LIVEMEDIA_LIB_OBJS = Media.$(OBJ) $(MISC_SOURCE_OBJS) $(MISC_SINK_OBJS) $(MISC_FILTER_OBJS) $(RTP_OBJS) $(RTCP_OBJS) $(GENERIC_MEDIA_SERVER_OBJS) $(RTSP_OBJS) $(SIP_OBJS) $(SESSION_OBJS) $(QUICKTIME_OBJS) $(AVI_OBJS) $(TRANSPORT_STREAM_TRICK_PLAY_OBJS) $(MATROSKA_OBJS) $(OGG_OBJS) $(TRANSPORT_STREAM_DEMUX_OBJS) $(HLS_OBJS) $(SECURITY_OBJS) $(MISC_OBJS)
  
  Media.$(CPP):         include/Media.hh
  include/Media.hh:     include/liveMedia_version.hh
---- live/Makefile.tail.orig    2011-03-16 19:18:57.767415456 +0100
-+++ live/Makefile.tail 2011-03-16 19:30:31.367419646 +0100
-@@ -10,10 +10,10 @@
- MEDIA_SERVER_DIR = mediaServer
+--- live-2021.04.06/live/Makefile.tail.orig    2021-04-29 22:24:40.848346613 +0200
++++ live-2021.04.06/live/Makefile.tail 2021-04-29 22:30:26.453086366 +0200
+@@ -14,10 +14,10 @@ PROXY_SERVER_DIR = proxyServer
+ HLS_PROXY_DIR = hlsProxy
  
  all:
 -      cd $(LIVEMEDIA_DIR) ; $(MAKE)
 +      cd $(LIVEMEDIA_DIR) ; $(MAKE)
        cd $(TESTPROGS_DIR) ; $(MAKE)
        cd $(MEDIA_SERVER_DIR) ; $(MAKE)
---- live/config.linux-with-shared-libraries.orig       2020-03-17 21:29:48.897335650 +0100
-+++ live/config.linux-with-shared-libraries    2020-03-17 21:35:13.995574442 +0100
-@@ -39,6 +39,7 @@
+       cd $(PROXY_SERVER_DIR) ; $(MAKE)
+--- live-2021.04.06/live/config.linux-with-shared-libraries.orig       2021-04-29 22:24:40.848346613 +0200
++++ live-2021.04.06/live/config.linux-with-shared-libraries    2021-04-29 22:31:14.575602890 +0200
+@@ -39,6 +39,7 @@ LIBRARY_LINK =               $(CC) -o
  SHORT_LIB_SUFFIX =    so.$(shell expr $($(NAME)_VERSION_CURRENT) - $($(NAME)_VERSION_AGE))
  LIB_SUFFIX =          $(SHORT_LIB_SUFFIX).$($(NAME)_VERSION_AGE).$($(NAME)_VERSION_REVISION)
  LIBRARY_LINK_OPTS =   -shared -Wl,-soname,$(NAME).$(SHORT_LIB_SUFFIX) $(LDFLAGS)
 +LIBRARY_LINK_DEPS =   $(LIBRARY_DEPS)
  LIBS_FOR_CONSOLE_APPLICATION = -lssl -lcrypto
  LIBS_FOR_GUI_APPLICATION =
- EXE =
+ LIBS_FOR_LIVEMEDIA_LIB = -lssl -lcrypto
index ca21c25091aeca61ab884d4003a4edefb2ca6320..7d1a1294e43439a2a9dcee67589f5bf7efb9e844 100644 (file)
@@ -1,15 +1,15 @@
 Description: Add a pkg-config file for the shared libraries.
 Author: Benjamin Drung <bdrung@debian.org>
 
---- a/Makefile.head
-+++ b/Makefile.head
+--- a/live/Makefile.head
++++ b/live/Makefile.head
 @@ -1 +1,4 @@
 +PREFIX = /usr/local
 +LIBDIR = /usr/local/lib
 +VERSION = $(shell grep LIVEMEDIA_LIBRARY_VERSION_STRING liveMedia/include/liveMedia_version.hh | sed 's/.*"\([^"]*\)".*/\1/')
  ##### Change the following for your environment:
 --- /dev/null
-+++ b/live555.pc.in
++++ b/live/live555.pc.in
 @@ -0,0 +1,9 @@
 +prefix=@PREFIX@
 +libdir=@LIBDIR@
@@ -20,11 +20,11 @@ Author: Benjamin Drung <bdrung@debian.org>
 +Version: @VERSION@
 +Cflags: -I${includedir}/liveMedia -I${includedir}/groupsock -I${includedir}/BasicUsageEnvironment -I${includedir}/UsageEnvironment
 +Libs: -L${libdir} -lliveMedia -lgroupsock -lBasicUsageEnvironment -lUsageEnvironment
---- a/Makefile.tail
-+++ b/Makefile.tail
-@@ -20,7 +20,12 @@
-       cd $(MEDIA_SERVER_DIR) ; $(MAKE)
-       cd $(PROXY_SERVER_DIR) ; $(MAKE)
+--- live-2021.04.06/live/Makefile.tail.orig    2021-04-29 22:32:18.998971852 +0200
++++ live-2021.04.06/live/Makefile.tail 2021-04-30 06:53:31.459794869 +0200
+@@ -25,7 +25,12 @@ all:
+       @echo
+       @echo "For more information about this source code (including your obligations under the LGPL), please see our FAQ at http://live555.com/liveMedia/faq.html"
  
 -install:
 +install_shared_libraries:
index ae915c30284795e84444e737e8f294803b5b3e2a..4850fc6e27263a36ffed194b1f894e4453097dc9 100644 (file)
--- a/live.spec
+++ b/live.spec
@@ -76,10 +76,8 @@ Biblioteki statyczne LIVE555 do strumieni multimedialnych.
 
 %prep
 %setup -q -c
-%patch0 -p0
-cd live
+%patch0 -p1
 %patch1 -p1
-cd ..
 
 # disable building test programs
 %{__sed} -i -e '/cd \$(TESTPROGS_DIR)/d' live/Makefile.tail
This page took 0.152999 seconds and 4 git commands to generate.