]> git.pld-linux.org Git - packages/linux-gpib.git/blob - linux-gpib.spec
- up to 4.3.6
[packages/linux-gpib.git] / linux-gpib.spec
1 #
2 # Conditional build:
3 %bcond_without  kernel          # kernel modules
4 %bcond_without  drivers_isa     # ISA kernel drivers [ix86 only]
5 %bcond_without  drivers_usb     # USB kernel drivers
6 %bcond_without  userspace       # userspace packages
7 %bcond_without  verbose         # verbose modules build (V=1)
8
9 %bcond_without  doc             # documentation build
10 %bcond_with     hotplug         # legacy hotplug support
11 %bcond_without  static_libs     # static library
12 %bcond_without  guile           # guile binding
13 %bcond_without  perl            # Perl binding
14 %bcond_with     php             # PHP binding
15 %bcond_without  python          # Python (any) binding
16 %bcond_without  python2         # Python 2.x binding
17 %bcond_without  tcl             # Tcl binding
18
19 # The goal here is to have main, userspace, package built once with
20 # simple release number, and only rebuild kernel packages with kernel
21 # version as part of release number, without the need to bump release
22 # with every kernel change.
23 %if 0%{?_pld_builder:1} && %{with kernel} && %{with userspace}
24 %{error:kernel and userspace cannot be built at the same time on PLD builders}
25 exit 1
26 %endif
27
28 %if %{without userspace}
29 # nothing to be placed to debuginfo package
30 %define         _enable_debug_packages  0
31 %endif
32
33 %ifnarch %{ix86}
34 %undefine       with_drivers_isa
35 %endif
36 %if %{without python}
37 %undefine       with_python2
38 %endif
39
40 %define         php_name        php%{?php_suffix}
41
42 %define         rel     1
43 %define         pname   linux-gpib
44 Summary:        GPIB (IEEE 488) Linux support
45 Summary(pl.UTF-8):      Obsługa GPIB (IEEE 488) dla Linuksa
46 Name:           %{pname}%{?_pld_builder:%{?with_kernel:-kernel}}%{_alt_kernel}
47 Version:        4.3.6
48 Release:        %{rel}%{?_pld_builder:%{?with_kernel:@%{_kernel_ver_str}}}
49 License:        GPL v2+
50 Group:          Applications/System
51 Source0:        http://downloads.sourceforge.net/linux-gpib/%{pname}-%{version}.tar.gz
52 # Source0-md5:  ffefc4e5c03b891c57f406a4b82395b7
53 Patch2:         %{pname}-python.patch
54 Patch3:         %{pname}-perl.patch
55 Patch4:         %{pname}-firmwaredir.patch
56 Patch5:         %{pname}-guile2.patch
57 Patch6:         %{pname}-php7.patch
58 Patch8:         kernel-5.2.patch
59 Patch9:         kernel-5.10.patch
60 Patch10:        pkgconfig-version.patch
61 Patch11:        linux-gpib-guile3.patch
62 URL:            http://linux-gpib.sourceforge.net/
63 BuildRequires:  autoconf >= 2.50
64 BuildRequires:  automake
65 BuildRequires:  libtool
66 BuildRequires:  rpmbuild(macros) >= 1.745
67 %{?with_kernel:%{expand:%buildrequires_kernel kernel%%{_alt_kernel}-module-build >= 3:2.6.32}}
68 %if %{with userspace}
69 BuildRequires:  bison
70 %{?with_doc:BuildRequires:      docbook-utils}
71 BuildRequires:  flex
72 %{?with_guile:BuildRequires:    guile-devel >= 1.4}
73 %{?with_perl:BuildRequires:     perl-devel}
74 %{?with_php:BuildRequires:      %{php_name}-devel >= 3:5}
75 %{?with_python:BuildRequires:   python-devel >= 2}
76 BuildRequires:  readline-devel
77 %{?with_tcl:BuildRequires:      tcl-devel}
78 %endif
79 Requires:       %{pname}-libs = %{version}-%{release}
80 # for agilent_82357a and ni_usb_gpib
81 Suggests:       fxload
82 # for agilent_82357a, agilent/hp_82341, agilent/hp_82350a, ni_usb_gpib
83 Suggests:       linux-gpib-firmware
84 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
85
86 %description
87 The Linux GPIB package provides support for GPIB (IEEE 488) hardware.
88
89 %description -l pl.UTF-8
90 Pakiet Linux GPIB służy do obsługi sprzętu GPIB (IEEE 488).
91
92 %package hotplug
93 Summary:        Linux GPIB support for legacy USB hotplug
94 Summary(pl.UTF-8):      Obsługa Linux GPIB dla starego systemu hotplug USB
95 Group:          Applications/System
96 Requires:       %{pname} = %{version}-%{release}
97 Requires:       hotplug
98
99 %description hotplug
100 Linux GPIB support for legacy USB hotplug.
101
102 %description hotplug -l pl.UTF-8
103 Obsługa Linux GPIB dla starego systemu hotplug USB.
104
105 %package libs
106 Summary:        Shared GPIB library
107 Summary(pl.UTF-8):      Biblioteka współdzielona GPIB
108 Group:          Libraries
109
110 %description libs
111 Shared GPIB library.
112
113 %description libs -l pl.UTF-8
114 Biblioteka współdzielona GPIB.
115
116 %package devel
117 Summary:        Header file for GPIB library
118 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki GPIB
119 Group:          Development/Libraries
120 Requires:       %{pname}-libs = %{version}-%{release}
121
122 %description devel
123 Header file for GPIB library.
124
125 %description devel -l pl.UTF-8
126 Plik nagłówkowy biblioteki GPIB.
127
128 %package static
129 Summary:        Static GPIB library
130 Summary(pl.UTF-8):      Biblioteka statyczna GPIB
131 Group:          Development/Libraries
132 Requires:       %{pname}-devel = %{version}-%{release}
133
134 %description static
135 Static GPIB library.
136
137 %description static -l pl.UTF-8
138 Biblioteka statyczna GPIB.
139
140 %package -n guile-gpib
141 Summary:        Guile bindings for GPIB library
142 Summary(pl.UTF-8):      Wiązania Guile do biblioteki GPIB
143 Group:          Development/Languages/Perl
144 Requires:       %{pname}-libs = %{version}-%{release}
145 Requires:       guile-libs
146
147 %description -n guile-gpib
148 Guile bindings for GPIB library.
149
150 %description -n guile-gpib -l pl.UTF-8
151 Wiązania Guile do biblioteki GPIB.
152
153 %package -n perl-gpib
154 Summary:        Perl bindings for GPIB library
155 Summary(pl.UTF-8):      Wiązania Perla do biblioteki GPIB
156 Group:          Development/Languages/Perl
157 Requires:       %{pname}-libs = %{version}-%{release}
158
159 %description -n perl-gpib
160 Perl bindings for GPIB library.
161
162 %description -n perl-gpib -l pl.UTF-8
163 Wiązania Perla do biblioteki GPIB.
164
165 %package -n %{php_name}-gpib
166 Summary:        PHP bindings for GPIB library
167 Summary(pl.UTF-8):      Wiązania PHP do biblioteki GPIB
168 Group:          Development/Languages/PHP
169 Provides:       php(gpib) = %{version}
170 Requires:       %{pname}-libs = %{version}-%{release}
171 %{?requires_php_extension}
172
173 %description -n %{php_name}-gpib
174 PHP bindings for GPIB library.
175
176 %description -n %{php_name}-gpib -l pl.UTF-8
177 Wiązania PHP do biblioteki GPIB.
178
179 %package -n python-gpib
180 Summary:        Python 2 bindings for GPIB library
181 Summary(pl.UTF-8):      Wiązania Pythona 2 do biblioteki GPIB
182 Group:          Libraries/Python
183 Requires:       %{pname}-libs = %{version}-%{release}
184 Requires:       python-libs
185
186 %description -n python-gpib
187 Python 2 bindings for GPIB library.
188
189 %description -n python-gpib -l pl.UTF-8
190 Wiązania Pythona 2 do biblioteki GPIB.
191
192 %package -n python3-gpib
193 Summary:        Python 3 bindings for GPIB library
194 Summary(pl.UTF-8):      Wiązania Pythona 3 do biblioteki GPIB
195 Group:          Libraries/Python
196 Requires:       %{pname}-libs = %{version}-%{release}
197 Requires:       python3-libs
198
199 %description -n python3-gpib
200 Python 3 bindings for GPIB library.
201
202 %description -n python3-gpib -l pl.UTF-8
203 Wiązania Pythona 3 do biblioteki GPIB.
204
205 %package -n tcl-gpib
206 Summary:        Tcl bindings for GPIB library
207 Summary(pl.UTF-8):      Wiązania Tcl-a do biblioteki GPIB
208 Group:          Libraries
209 Requires:       %{pname}-libs = %{version}-%{release}
210 Requires:       tcl
211
212 %description -n tcl-gpib
213 Tcl bindings for GPIB library.
214
215 %description -n tcl-gpib -l pl.UTF-8
216 Wiązania Tcl-a do biblioteki GPIB.
217
218 %package doc
219 Summary:        Linux-GPIB tools and library documentation
220 Summary(pl.UTF-8):      Dokumentacja narzędzi i biblioteki Linux-GPIB
221 License:        GFDL v1.2+ or GPL v2+
222 Group:          Documentation
223
224 %description doc
225 Linux-GPIB tools and library documentation.
226
227 %description doc -l pl.UTF-8
228 Dokumentacja narzędzi i biblioteki Linux-GPIB.
229
230 %define kernel_pkg()\
231 %package -n kernel%{_alt_kernel}-gpib\
232 Summary:        Linux GPIB drivers\
233 Summary(pl.UTF-8):      Sterowniki GPIB dla Linuksa\
234 Release:        %{rel}@%{_kernel_ver_str}\
235 Group:          Base/Kernel\
236 Requires(post,postun):  /sbin/depmod\
237 %requires_releq_kernel\
238 Requires(postun):       %releq_kernel\
239 \
240 %description -n kernel%{_alt_kernel}-gpib\
241 This package contains Linux drivers for GPIB (IEEE 488) hardware.\
242 \
243 %description -n kernel%{_alt_kernel}-gpib -l pl.UTF-8\
244 Ten pakiet zawiera sterowniki dla Linuksa do urządzeń GPIB (IEEE 488).\
245 \
246 %if %{with kernel}\
247 %files -n kernel%{_alt_kernel}-gpib\
248 %defattr(644,root,root,755)\
249 /lib/modules/%{_kernel_ver}/kernel/gpib\
250 %endif\
251 \
252 %post -n kernel%{_alt_kernel}-gpib\
253 %depmod %{_kernel_ver}\
254 \
255 %postun -n kernel%{_alt_kernel}-gpib\
256 %depmod %{_kernel_ver}\
257 %{nil}
258
259 %define build_kernel_pkg()\
260 %{__make} VERBOSE=1 LINUX_SRCDIR=%{_kernelsrcdir} clean\
261 %{__make} VERBOSE=1 LINUX_SRCDIR=%{_kernelsrcdir}\
262 cd drivers/gpib\
263 %if %{_kernel_version_code} < %{_kernel_version_magic 5 10 0}\
264 %if %{with drivers_usb}\
265 %install_kernel_modules -D installed -m lpvo_usb_gpib/lpvo_usb_gpib -d kernel/gpib\
266 %endif\
267 %endif\
268 %ifarch %{ix86}\
269 %install_kernel_modules -D installed -m agilent_82350b/agilent_82350b,cb7210/cb7210,cec/cec_gpib,hp_82335/hp82335,ines/ines_gpib,nec7210/nec7210,sys/gpib_common,tms9914/tms9914,tnt4882/tnt4882%{?with_drivers_isa:,pc2/pc2_gpib}%{?with_drivers_usb:,agilent_82357a/agilent_82357a,ni_usb/ni_usb_gpib} -d kernel/gpib\
270 %else\
271 %install_kernel_modules -D installed -m agilent_82350b/agilent_82350b,cb7210/cb7210,cec/cec_gpib,hp_82335/hp82335,hp_82341/hp_82341,ines/ines_gpib,nec7210/nec7210,sys/gpib_common,tms9914/tms9914,tnt4882/tnt4882%{?with_drivers_isa:,pc2/pc2_gpib}%{?with_drivers_usb:,agilent_82357a/agilent_82357a,ni_usb/ni_usb_gpib} -d kernel/gpib\
272 %endif\
273 cd ../..\
274 %{nil}
275
276 %define install_kernel_pkg()\
277 %{nil}
278
279 %{?with_kernel:%{expand:%create_kernel_packages}}
280
281 %prep
282 %setup -q -n %{pname}-%{version}
283 %if %{with userspace}
284 tar xzf linux-gpib-user-%{version}.tar.gz
285 cd linux-gpib-user-%{version}
286 %patch2 -p1
287 %patch3 -p1
288 %patch4 -p1
289 %patch5 -p1
290 #%patch6 -p1
291 %patch10 -p1
292 %patch11 -p1
293 cd ..
294 %endif
295
296 %if %{with kernel}
297 tar xzf linux-gpib-kernel-%{version}.tar.gz
298 cd linux-gpib-kernel-%{version}
299 %patch9 -p1
300 %ifarch %{ix86}
301 %patch8 -p1
302 %endif
303 %endif
304
305 %build
306 %if %{with userspace}
307 cd linux-gpib-user-%{version}
308 %{__libtoolize}
309 %{__aclocal}
310 %{__autoconf}
311 %{__autoheader}
312 %{__automake}
313 %if %{with guile}
314 CPPFLAGS="%{rpmcppflags} -I/usr/include/guile/3.0"
315 %endif
316 %configure \
317         --with-udev-libdir=/lib/udev \
318         %{!?with_doc:--disable-documentation} \
319         %{!?with_guile:--disable-guile-binding} \
320         %{!?with_perl:--disable-perl-binding} \
321         %{!?with_php:--disable-php-binding} \
322         %{!?with_python:--disable-python-binding} \
323         %{?with_static_libs:--enable-static} \
324         %{!?with_tcl:--disable-tcl-binding}
325
326 %{__make}
327
328 %if %{with python2}
329 cd language/python
330 %py_build
331 cd ../..
332 %endif
333 cd ..
334 %endif
335
336 %if %{with kernel}
337 cd linux-gpib-kernel-%{version}
338 %{expand:%build_kernel_packages}
339 %endif
340
341 %install
342 rm -rf $RPM_BUILD_ROOT
343 install -d $RPM_BUILD_ROOT%{_examplesdir}
344
345 %if %{with kernel}
346 cd linux-gpib-kernel-%{version}
347 %{expand:%install_kernel_packages}
348 cp -a drivers/gpib/installed/* $RPM_BUILD_ROOT
349 cd ..
350 %endif
351
352 %if %{with userspace}
353 cd linux-gpib-user-%{version}
354 %{__make} install \
355         DESTDIR=$RPM_BUILD_ROOT \
356         HOTPLUG_USB_CONF_DIR=/lib/udev \
357         UDEV_RULES_DIR=/lib/udev/rules.d \
358         USB_FIRMWARE_DIR=/lib/firmware
359
360 %if %{with python2}
361 cd language/python
362 %py_install
363 cd ../..
364 %endif
365
366 %if %{with hotplug}
367 # use udev paths as base and legacy hotplug as addon (not the opposite)
368 install -d $RPM_BUILD_ROOT/etc/hotplug/usb
369 %{__mv} $RPM_BUILD_ROOT/lib/udev/*.usermap $RPM_BUILD_ROOT/etc/hotplug/usb
370 ln -snf /lib/udev/agilent_82357a $RPM_BUILD_ROOT/etc/hotplug/usb/agilent_82357a
371 ln -snf /lib/udev/ni_usb_gpib $RPM_BUILD_ROOT/etc/hotplug/usb/ni_usb_gpib
372 %endif
373
374 # obsoleted by pkg-config
375 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libgpib.la
376
377 %if %{with guile}
378 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libgpib-guile.la
379 %if %{with static_libs}
380 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libgpib-guile.a
381 %endif
382 %endif
383
384 %if %{with perl}
385 %{__make} -C language/perl pure_install \
386         DESTDIR=$RPM_BUILD_ROOT
387
388 cp -pr language/perl/examples $RPM_BUILD_ROOT%{_examplesdir}/perl-gpib-%{version}
389
390 %{__rm} -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/LinuxGpib/.packlist
391 %endif
392
393 %if %{with php}
394 install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
395 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/gpib.ini
396 ; Enable gpib extension module
397 extension=gpib_php.so
398 EOF
399
400 %{__rm} $RPM_BUILD_ROOT%{php_extensiondir}/gpib_php.la
401 %if %{with static_libs}
402 %{__rm} $RPM_BUILD_ROOT%{php_extensiondir}/gpib_php.a
403 %endif
404 %endif
405
406 %if %{with python}
407 %py_postclean
408 %endif
409
410 %if %{with tcl}
411 cp -pr language/tcl/examples $RPM_BUILD_ROOT%{_examplesdir}/tcl-gpib-%{version}
412
413 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libgpib_tcl.la
414 %if %{with static_libs}
415 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libgpib_tcl.a
416 %endif
417 %endif
418
419 %if %{with doc}
420 # packaged as %doc
421 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/linux-gpib-user/html
422 %endif
423 %endif
424
425 %clean
426 rm -rf $RPM_BUILD_ROOT
427
428 %post   libs -p /sbin/ldconfig
429 %postun libs -p /sbin/ldconfig
430
431 %post   -n guile-gpib -p /sbin/ldconfig
432 %postun -n guile-gpib -p /sbin/ldconfig
433
434 %post   -n tcl-gpib -p /sbin/ldconfig
435 %postun -n tcl-gpib -p /sbin/ldconfig
436
437 %post   -n %{php_name}-gpib
438 %php_webserver_restart
439
440 %postun -n %{php_name}-gpib
441 if [ "$1" = 0 ]; then
442         %php_webserver_restart
443 fi
444
445 %if %{with userspace}
446 %files
447 %defattr(644,root,root,755)
448 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/gpib.conf
449 %attr(755,root,root) %{_bindir}/ibterm
450 %attr(755,root,root) %{_bindir}/ibtest
451 %attr(755,root,root) %{_bindir}/findlisteners
452 %attr(755,root,root) %{_sbindir}/gpib_config
453 /lib/udev/rules.d/98-gpib-generic.rules
454 /lib/udev/rules.d/99-agilent_82357a.rules
455 /lib/udev/rules.d/99-lpvo_usb_gpib.rules
456 /lib/udev/rules.d/99-ni_usb_gpib.rules
457 %attr(755,root,root) /lib/udev/gpib_udev_config
458 %attr(755,root,root) /lib/udev/gpib_udev_fxloader
459 %attr(755,root,root) /lib/udev/gpib_udevadm_wrapper
460
461 %if %{with hotplug}
462 %files hotplug
463 %defattr(644,root,root,755)
464 %attr(755,root,root) /etc/hotplug/usb/agilent_82357a
465 %attr(755,root,root) /etc/hotplug/usb/ni_usb_gpib
466 /etc/hotplug/usb/agilent_82357a.usermap
467 /etc/hotplug/usb/ni_usb_gpib.usermap
468 %endif
469
470 %files libs
471 %defattr(644,root,root,755)
472 %doc linux-gpib-user-%{version}/{AUTHORS,ChangeLog,README,README.HAMEG,README.hp82335,TODO}
473 %attr(755,root,root) %{_libdir}/libgpib.so.*.*.*
474 %attr(755,root,root) %ghost %{_libdir}/libgpib.so.0
475
476 %files devel
477 %defattr(644,root,root,755)
478 %attr(755,root,root) %{_libdir}/libgpib.so
479 %{_includedir}/gpib
480 %{_pkgconfigdir}/libgpib.pc
481
482 %if %{with static_libs}
483 %files static
484 %defattr(644,root,root,755)
485 %{_libdir}/libgpib.a
486 %endif
487
488 %if %{with guile}
489 %files -n guile-gpib
490 %defattr(644,root,root,755)
491 %attr(755,root,root) %{_libdir}/libgpib-guile-%{version}.so
492 %attr(755,root,root) %{_libdir}/libgpib-guile.so
493 %endif
494
495 %if %{with perl}
496 %files -n perl-gpib
497 %defattr(644,root,root,755)
498 %doc linux-gpib-user-%{version}/language/perl/{Changes,README}
499 %{perl_vendorarch}/LinuxGpib.pm
500 %dir %{perl_vendorarch}/auto/LinuxGpib
501 %attr(755,root,root) %{perl_vendorarch}/auto/LinuxGpib/LinuxGpib.so
502 %{perl_vendorarch}/auto/LinuxGpib/autosplit.ix
503 %{_mandir}/man3/LinuxGpib.3pm*
504 %{_examplesdir}/perl-gpib-%{version}
505 %endif
506
507 %if %{with php}
508 %files -n %{php_name}-gpib
509 %defattr(644,root,root,755)
510 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/gpib.ini
511 %attr(755,root,root) %{php_extensiondir}/gpib_php-%{version}.so
512 %attr(755,root,root) %{php_extensiondir}/gpib_php.so
513 %endif
514
515 %if %{with python2}
516 %files -n python-gpib
517 %defattr(644,root,root,755)
518 %doc linux-gpib-user-%{version}/language/python/README
519 %attr(755,root,root) %{py_sitedir}/gpib.so
520 %{py_sitedir}/Gpib.py[co]
521 %{py_sitedir}/gpib-1.0-py*.egg-info
522 %endif
523
524 %if %{with python}
525 %files -n python3-gpib
526 %defattr(644,root,root,755)
527 %doc linux-gpib-user-%{version}/language/python/README
528 %attr(755,root,root) %{py3_sitedir}/gpib.cpython-*.so
529 %{py3_sitedir}/Gpib.py
530 %{py3_sitedir}/__pycache__/Gpib.cpython-*.py[co]
531 %{py3_sitedir}/gpib-1.0-py*.egg-info
532 %endif
533
534 %if %{with tcl}
535 %files -n tcl-gpib
536 %defattr(644,root,root,755)
537 %doc linux-gpib-user-%{version}/language/tcl/README
538 %attr(755,root,root) %{_libdir}/libgpib_tcl-%{version}.so
539 %attr(755,root,root) %{_libdir}/libgpib_tcl.so
540 %{_examplesdir}/tcl-gpib-%{version}
541 %endif
542
543 %if %{with doc}
544 %files doc
545 %defattr(644,root,root,755)
546 %doc linux-gpib-user-%{version}/doc/doc_html/*
547 %endif
548 %endif
This page took 0.806714 seconds and 3 git commands to generate.