]> git.pld-linux.org Git - packages/lin_tape.git/blob - lin_tape.spec
- up to 2.1.0
[packages/lin_tape.git] / lin_tape.spec
1 #
2 # Conditional build:
3 %bcond_without  dist_kernel     # allow non-distribution kernel
4 %bcond_with     verbose         # verbose build (V=1)
5 #
6 %define         rel     1
7 %define         pname   lin_tape
8 Summary:        IBM Tape SCSI Device Driver for Linux
9 Name:           %{pname}%{_alt_kernel}
10 Version:        2.1.0
11 Release:        %{rel}
12 License:        GPL v2/LGPL
13 Group:          Base/Kernel
14 Source0:        %{pname}-%{version}.tgz
15 # Source0-md5:  a46993ee41fb438ae3b35249fe2c376f
16 Patch0:         use-module-dir.patch
17 Patch1:         linux-3.10.patch
18 # System Storage, Tape systems, Tape drivers and software, Tape device drivers (Linux)
19 URL:            http://www.ibm.com/support/fixcentral/
20 %{?with_dist_kernel:BuildRequires:      kernel%{_alt_kernel}-module-build >= 3:2.6.20.2}
21 BuildRequires:  rpmbuild(macros) >= 1.379
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 The IBM Tape Device Driver, lin_tape, product is a device driver that
26 provides attachment for the IBM TotalStorage and System Storage tape
27 devices to Linux compatible platforms.
28
29 %package -n kernel%{_alt_kernel}-scsi-lin_tape
30 Summary:        IBM Tape SCSI Device Driver for Linux
31 Release:        %{rel}@%{_kernel_ver_str}
32 Group:          Base/Kernel
33 Requires(post,postun):  /sbin/depmod
34 %if %{with dist_kernel}
35 %requires_releq_kernel
36 Requires(postun):       %releq_kernel
37 %endif
38
39 %description -n kernel%{_alt_kernel}-scsi-lin_tape
40 The IBM Tape Device Driver is a device driver that provides attachment
41 for the IBM TotalStorage and System Storage tape devices to Linux
42 compatible platforms.
43
44 %prep
45 %setup -q -n %{pname}-%{version}
46 %patch0 -p1
47 %if "%{_alt_kernel}" == "%{nil}"
48 %patch1 -p1
49 %endif
50 %ifarch %ix86 ia64
51 proc="Intel"
52 %endif
53 %ifarch %x8664
54 proc="AMD"
55 %endif
56 %ifarch ppc ppc64 powerpc powerpc64
57 proc="pSeries"
58 %endif
59 %ifarch s390 s390x
60 proc="zSeries"
61 %endif
62
63 %{__cp} -af lin_tape_359X_${proc}.ReadMe lin_tape_359X.ReadMe
64 %{__cp} -af lin_tape_Ultrium_${proc}.ReadMe lin_tape_Ultrium.ReadMe
65
66 %{__mv} Makefile Makefile.IBM
67 %{__cp} -af Makefile.GPL Makefile
68
69 %build
70 %build_kernel_modules -m lin_tape
71
72 %install
73 rm -rf $RPM_BUILD_ROOT
74
75 %install_kernel_modules -m lin_tape -d kernel/drivers/scsi
76
77 %clean
78 rm -rf $RPM_BUILD_ROOT
79
80 %post   -n kernel%{_alt_kernel}-scsi-lin_tape
81 %depmod %{_kernel_ver}
82
83 %postun -n kernel%{_alt_kernel}-scsi-lin_tape
84 %depmod %{_kernel_ver}
85
86 %files -n kernel%{_alt_kernel}-scsi-lin_tape
87 %defattr(644,root,root,755)
88 %doc lin_tape.fixlist lin_tape_Ultrium.ReadMe lin_tape_359X.ReadMe
89 /lib/modules/%{_kernel_ver}/kernel/drivers/scsi/lin_tape.ko*
This page took 0.036163 seconds and 3 git commands to generate.