]> git.pld-linux.org Git - packages/lin_tape.git/blob - lin_tape.spec
10c9c2900480fc4750eff03f6fa4edbf83f44b89
[packages/lin_tape.git] / lin_tape.spec
1 #
2 # Conditional build:
3 %bcond_with     verbose         # verbose build (V=1)
4
5 # nothing to be placed to debuginfo package
6 %define         _enable_debug_packages  0
7
8 %define         rel     1
9 %define         pname   lin_tape
10 Summary:        IBM Tape SCSI Device Driver for Linux
11 Name:           %{pname}%{_alt_kernel}
12 Version:        2.9.4
13 Release:        %{rel}%{?_pld_builder:@%{_kernel_ver_str}}
14 License:        GPL v2/LGPL
15 Group:          Base/Kernel
16 Source0:        %{pname}-%{version}.tgz
17 # Source0-md5:  343e4fbc132880bdecb4f66f061112e9
18 Patch0:         use-module-dir.patch
19 Patch1:         linux-3.19.patch
20 Patch2:         insecure-perms.patch
21 # System Storage, Tape systems, Tape drivers and software, Tape device drivers (Linux)
22 URL:            http://www.ibm.com/support/fixcentral/
23 BuildRequires:  rpmbuild(macros) >= 1.701
24 %{expand:%buildrequires_kernel kernel%%{_alt_kernel}-module-build >= 3:2.6.20.2}
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 The IBM Tape Device Driver, lin_tape, product is a device driver that
29 provides attachment for the IBM TotalStorage and System Storage tape
30 devices to Linux compatible platforms.
31
32 %define kernel_pkg()\
33 %package -n kernel%{_alt_kernel}-scsi-lin_tape\
34 Summary:        IBM Tape SCSI Device Driver for Linux\
35 Release:        %{rel}@%{_kernel_ver_str}\
36 Group:          Base/Kernel\
37 Requires(post,postun):  /sbin/depmod\
38 %requires_releq_kernel\
39 Requires(postun):       %releq_kernel\
40 \
41 %description -n kernel%{_alt_kernel}-scsi-lin_tape\
42 The IBM Tape Device Driver is a device driver that provides attachment\
43 for the IBM TotalStorage and System Storage tape devices to Linux\
44 compatible platforms.\
45 \
46 %post   -n kernel%{_alt_kernel}-scsi-lin_tape\
47 %depmod %{_kernel_ver}\
48 \
49 %postun -n kernel%{_alt_kernel}-scsi-lin_tape\
50 %depmod %{_kernel_ver}\
51 \
52 %files -n kernel%{_alt_kernel}-scsi-lin_tape\
53 %defattr(644,root,root,755)\
54 %doc lin_tape.fixlist lin_tape_Ultrium.ReadMe lin_tape_359X.ReadMe\
55 /lib/modules/%{_kernel_ver}/kernel/drivers/scsi/lin_tape.ko*\
56 %{nil}
57
58 %define build_kernel_pkg()\
59 %build_kernel_modules -m lin_tape\
60 %install_kernel_modules -D installed -m lin_tape -d kernel/drivers/scsi\
61 %{nil}
62
63 %{expand:%create_kernel_packages}
64
65 %prep
66 %setup -q -n %{pname}-%{version}
67 %patch0 -p1
68 %patch1 -p1
69 %patch2 -p1
70 %ifarch %{ix86} ia64
71 proc="Intel"
72 %endif
73 %ifarch %{x8664} x32
74 proc="AMD"
75 %endif
76 %ifarch ppc ppc64 powerpc powerpc64
77 proc="pSeries"
78 %endif
79 %ifarch s390 s390x
80 proc="zSeries"
81 %endif
82
83 %{__cp} -af lin_tape_359X_${proc}.ReadMe lin_tape_359X.ReadMe
84 %{__cp} -af lin_tape_Ultrium_${proc}.ReadMe lin_tape_Ultrium.ReadMe
85
86 %{__mv} Makefile Makefile.IBM
87 %{__cp} -af Makefile.GPL Makefile
88
89 %build
90 %{expand:%build_kernel_packages}
91
92 %install
93 rm -rf $RPM_BUILD_ROOT
94 install -d $RPM_BUILD_ROOT
95
96 cp -a installed/* $RPM_BUILD_ROOT
97
98 %clean
99 rm -rf $RPM_BUILD_ROOT
This page took 0.027513 seconds and 2 git commands to generate.