]> git.pld-linux.org Git - packages/lin_tape.git/blob - lin_tape.spec
- started update to 3.0.8
[packages/lin_tape.git] / lin_tape.spec
1 #
2 # Conditional build:
3 %bcond_with     verbose         # verbose build (V=1)
4
5 # nothing to be placed to debuginfo package
6 %define         _enable_debug_packages  0
7
8 %define         rel     0.1
9 %define         pname   lin_tape
10 Summary:        IBM Tape SCSI Device Driver for Linux
11 Name:           %{pname}%{_alt_kernel}
12 Version:        3.0.8
13 Release:        %{rel}%{?_pld_builder:@%{_kernel_ver_str}}
14 License:        GPL v2/LGPL
15 Group:          Base/Kernel
16 Source0:        %{pname}-%{version}.tgz
17 # Source0-md5:  11a219f7b32496d9c334bbcd534da349
18 Source1:        %{pname}.fixlist
19 Patch0:         use-module-dir.patch
20 Patch1:         linux-3.19.patch
21 Patch2:         insecure-perms.patch
22 # System Storage, Tape systems, Tape drivers and software, Tape device drivers (Linux)
23 URL:            http://www.ibm.com/support/fixcentral/
24 BuildRequires:  rpmbuild(macros) >= 1.701
25 %{expand:%buildrequires_kernel kernel%%{_alt_kernel}-module-build >= 3:2.6.20.2}
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 The IBM Tape Device Driver, lin_tape, product is a device driver that
30 provides attachment for the IBM TotalStorage and System Storage tape
31 devices to Linux compatible platforms.
32
33 %define kernel_pkg()\
34 %package -n kernel%{_alt_kernel}-scsi-lin_tape\
35 Summary:        IBM Tape SCSI Device Driver for Linux\
36 Release:        %{rel}@%{_kernel_ver_str}\
37 Group:          Base/Kernel\
38 Requires(post,postun):  /sbin/depmod\
39 %requires_releq_kernel\
40 Requires(postun):       %releq_kernel\
41 \
42 %description -n kernel%{_alt_kernel}-scsi-lin_tape\
43 The IBM Tape Device Driver is a device driver that provides attachment\
44 for the IBM TotalStorage and System Storage tape devices to Linux\
45 compatible platforms.\
46 \
47 %post   -n kernel%{_alt_kernel}-scsi-lin_tape\
48 %depmod %{_kernel_ver}\
49 \
50 %postun -n kernel%{_alt_kernel}-scsi-lin_tape\
51 %depmod %{_kernel_ver}\
52 \
53 %files -n kernel%{_alt_kernel}-scsi-lin_tape\
54 %defattr(644,root,root,755)\
55 %doc lin_tape.fixlist lin_tape_Ultrium.ReadMe lin_tape_359X.ReadMe\
56 /lib/modules/%{_kernel_ver}/kernel/drivers/scsi/lin_tape.ko*\
57 %{nil}
58
59 %define build_kernel_pkg()\
60 %build_kernel_modules -m lin_tape\
61 %install_kernel_modules -D installed -m lin_tape -d kernel/drivers/scsi\
62 %{nil}
63
64 %{expand:%create_kernel_packages}
65
66 %prep
67 %setup -q -n %{pname}-%{version}
68 %patch0 -p1
69 %patch1 -p1
70 %patch2 -p1
71 %ifarch %{ix86} ia64
72 proc="Intel"
73 %endif
74 %ifarch %{x8664} x32
75 proc="AMD"
76 %endif
77 %ifarch ppc ppc64 powerpc powerpc64
78 proc="pSeries"
79 %endif
80 %ifarch s390 s390x
81 proc="zSeries"
82 %endif
83
84 %{__cp} -af lin_tape_359X_${proc}.ReadMe lin_tape_359X.ReadMe
85 %{__cp} -af lin_tape_Ultrium_${proc}.ReadMe lin_tape_Ultrium.ReadMe
86
87 %{__mv} Makefile Makefile.IBM
88 %{__cp} -af Makefile.GPL Makefile
89
90 %build
91 %{expand:%build_kernel_packages}
92
93 %install
94 rm -rf $RPM_BUILD_ROOT
95 install -d $RPM_BUILD_ROOT
96
97 cp -a installed/* $RPM_BUILD_ROOT
98
99 %clean
100 rm -rf $RPM_BUILD_ROOT
This page took 0.089546 seconds and 3 git commands to generate.