]> git.pld-linux.org Git - packages/libxslt.git/blob - libxslt.spec
- exslt_crypt.patch (fixes CVE-2008-2935)
[packages/libxslt.git] / libxslt.spec
1 #
2 # Conditional build:
3 %bcond_without  python          # don't build python binding
4 %bcond_without  static_libs     # don't build static library
5 %bcond_with     tests           # run test suite
6 #
7 %define         libxml2ver      1:2.6.30
8
9 Summary:        XSLT processor
10 Summary(pl.UTF-8):      Procesor XSLT
11 Summary(pt_BR.UTF-8):   Biblioteca que disponibiliza o sistema XSLT do GNOME
12 Name:           libxslt
13 Version:        1.1.24
14 Release:        2
15 License:        MIT
16 Group:          Libraries
17 #Source0:       http://ftp.gnome.org/pub/GNOME/sources/libxslt/1.1/%{name}-%{version}.tar.bz2
18 Source0:        ftp://xmlsoft.org/libxml2/%{name}-%{version}.tar.gz
19 # Source0-md5:  e83ec5d27fc4c10c6f612879bea9a153
20 Patch0:         %{name}-exslt_crypt.patch
21 URL:            http://xmlsoft.org/XSLT/
22 BuildRequires:  autoconf
23 BuildRequires:  automake
24 BuildRequires:  libgcrypt-devel >= 1.1.42
25 BuildRequires:  libtool >= 1:1.4.2-9
26 BuildRequires:  libxml2-devel >= %{libxml2ver}
27 BuildRequires:  perl-base
28 %if %{with python}
29 BuildRequires:  python
30 BuildRequires:  python-devel
31 BuildRequires:  python-libxml2 >= %{libxml2ver}
32 %endif
33 BuildRequires:  rpm-pythonprov
34 Requires:       libgcrypt >= 1.1.42
35 Requires:       libxml2 >= %{libxml2ver}
36 Obsoletes:      libxslt1
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 Library for XSLT processing.
41
42 %description -l pl.UTF-8
43 Biblioteka do przetwarzania XSLT.
44
45 %description -l pt_BR.UTF-8
46 Esta biblioteca C permite a transformação de arquivos XML em outros
47 arquivos XML (ou HTML, texto, ...) usando o mecanismo padrão de
48 transformação dos estilos XSLT. O comando xsltproc é uma interface em
49 linha de comandos para o mecanismo XSLT.
50
51 %package devel
52 Summary:        Header files for libxslt
53 Summary(pl.UTF-8):      Pliki nagłówkowe libxslt
54 Summary(pt_BR.UTF-8):   Bibliotecas, includes, etc. para incluir o mecanismo XSLT do GNOME
55 Group:          Development/Libraries
56 Requires:       %{name} = %{version}-%{release}
57 Requires:       libgcrypt-devel >= 1.1.42
58 Requires:       libxml2-devel >= %{libxml2ver}
59 Obsoletes:      libxslt1-devel
60
61 %description devel
62 Header files for libxslt - XSLT processor.
63
64 %description devel -l pl.UTF-8
65 Pliki nagłówkowe procesora XSLT.
66
67 %description devel -l pt_BR.UTF-8
68 Esta biblioteca C permite a transformação de arquivos XML em outros
69 arquivos XML (ou HTML, texto, ...) usando o mecanismo padrão de
70 transformação dos estilos XSLT.
71
72 %package static
73 Summary:        Static libraries of libxslt
74 Summary(pl.UTF-8):      Biblioteki statyczne libxslt
75 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para incluir o mecanismo XSLT do GNOME
76 Group:          Development/Libraries
77 Requires:       %{name}-devel = %{version}-%{release}
78
79 %description static
80 Static libraries of libxslt - XSLT processor.
81
82 %description static -l pl.UTF-8
83 Statyczne biblioteki procesora XSLT.
84
85 %description static -l pt_BR.UTF-8
86 Esta biblioteca C permite a transformação de arquivos XML em outros
87 arquivos XML (ou HTML, texto, ...) usando o mecanismo padrão de
88 transformação dos estilos XSLT. Estas são as bibliotecas em sua versão
89 estática.
90
91 %package progs
92 Summary:        XSLT processor
93 Summary(pl.UTF-8):      Procesor XSLT
94 Group:          Applications/Text
95 Requires:       %{name} = %{version}-%{release}
96 Obsoletes:      libxslt-proc
97
98 %description progs
99 XSLT processor.
100
101 %description progs -l pl.UTF-8
102 Procesor XSLT.
103
104 %package -n python-%{name}
105 Summary:        Python support for libxslt
106 Summary(pl.UTF-8):      Moduły języka Python dla biblioteki libxslt
107 Group:          Libraries/Python
108 Requires:       %{name} = %{version}-%{release}
109 Requires:       python-libxml2 => %{libxml2ver}
110 %pyrequires_eq  python-modules
111 Obsoletes:      libxslt-python
112
113 %description -n python-%{name}
114 Python support for libxslt.
115
116 %description -n python-%{name} -l pl.UTF-8
117 Moduły języka Python dla biblioteki libxslt.
118
119 %prep
120 %setup -q
121 %patch0
122
123 %build
124 %{__libtoolize}
125 %{__aclocal}
126 %{__autoconf}
127 %{__autoheader}
128 %{__automake}
129 %configure \
130         --with-plugins \
131         %{!?with_static_libs:--disable-static} \
132         %{!?with_python:--without-python}
133 %{__make}
134
135 %{?with_tests:%{__make} -C tests test}
136
137 %install
138 rm -rf $RPM_BUILD_ROOT
139
140 %{__make} install \
141         DESTDIR=$RPM_BUILD_ROOT
142
143 %if %{with python}
144 # move examples to proper dir
145 install -d $RPM_BUILD_ROOT%{_examplesdir}/python-%{name}-%{version}
146 mv $RPM_BUILD_ROOT%{_docdir}/%{name}-python-%{version}/examples/* \
147   $RPM_BUILD_ROOT%{_examplesdir}/python-%{name}-%{version}
148 rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}-python-%{version}
149
150 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
151 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
152
153 rm -f $RPM_BUILD_ROOT%{py_sitedir}/*.{py,la,a}
154 %endif
155
156 %clean
157 rm -rf $RPM_BUILD_ROOT
158
159 %post   -p /sbin/ldconfig
160 %postun -p /sbin/ldconfig
161
162 %files
163 %defattr(644,root,root,755)
164 %doc AUTHORS ChangeLog Copyright FEATURES NEWS README TODO
165 %attr(755,root,root) %{_libdir}/libexslt.so.*.*.*
166 %attr(755,root,root) %ghost %{_libdir}/libexslt.so.0
167 %attr(755,root,root) %{_libdir}/libxslt.so.*.*.*
168 %attr(755,root,root) %ghost %{_libdir}/libxslt.so.1
169 %dir %{_libdir}/libxslt-plugins
170
171 %files devel
172 %defattr(644,root,root,755)
173 %doc doc/{*.{gif,html},html}
174 %attr(755,root,root) %{_bindir}/xslt-config
175 %attr(755,root,root) %{_libdir}/libexslt.so
176 %attr(755,root,root) %{_libdir}/libxslt.so
177 %{_libdir}/libexslt.la
178 %{_libdir}/libxslt.la
179 %attr(755,root,root) %{_libdir}/xsltConf.sh
180 %{_includedir}/libexslt
181 %{_includedir}/libxslt
182 %{_mandir}/man3/libexslt.3*
183 %{_mandir}/man3/libxslt.3*
184 %{_pkgconfigdir}/libexslt.pc
185 %{_pkgconfigdir}/libxslt.pc
186 %{_aclocaldir}/libxslt.m4
187
188 %if %{with static_libs}
189 %files static
190 %defattr(644,root,root,755)
191 %{_libdir}/libexslt.a
192 %{_libdir}/libxslt.a
193 %endif
194
195 %files progs
196 %defattr(644,root,root,755)
197 %attr(755,root,root) %{_bindir}/xsltproc
198 %{_mandir}/man1/xsltproc.1*
199
200 %if %{with python}
201 %files -n python-%{name}
202 %defattr(644,root,root,755)
203 %attr(755,root,root) %{py_sitedir}/libxsltmod.so
204 %{py_sitedir}/libxslt.py[co]
205 %{_examplesdir}/python-%{name}-%{version}
206 %endif
This page took 0.101611 seconds and 3 git commands to generate.