]> git.pld-linux.org Git - packages/libxml2.git/commitdiff
- added schema patch (fixes schema validation regression, incl. perl-XML-LibXML tests... auto/th/libxml2-2.9.4-2
authorJakub Bogusz <qboosh@pld-linux.org>
Fri, 4 Nov 2016 21:04:52 +0000 (22:04 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Fri, 4 Nov 2016 21:04:52 +0000 (22:04 +0100)
- release 2

libxml2-schema.patch [new file with mode: 0644]
libxml2.spec

diff --git a/libxml2-schema.patch b/libxml2-schema.patch
new file mode 100644 (file)
index 0000000..2c2efb3
--- /dev/null
@@ -0,0 +1,66 @@
+From 3169602058bd2d04913909e869c61d1540bc7fb4 Mon Sep 17 00:00:00 2001
+From: Alex Henrie <alexhenrie24@gmail.com>
+Date: Thu, 26 May 2016 17:38:35 -0600
+Subject: Fix attribute decoding during XML schema validation
+
+For https://bugzilla.gnome.org/show_bug.cgi?id=766834
+
+vctxt->parserCtxt is always NULL in xmlSchemaSAXHandleStartElementNs,
+so this function can't call xmlStringLenDecodeEntities to decode the
+entities.
+---
+ xmlschemas.c | 30 +++++++++++++++++++++++++-----
+ 1 file changed, 25 insertions(+), 5 deletions(-)
+
+diff --git a/xmlschemas.c b/xmlschemas.c
+index 7afe2eb..d42afb7 100644
+--- a/xmlschemas.c
++++ b/xmlschemas.c
+@@ -27391,6 +27391,7 @@ xmlSchemaSAXHandleStartElementNs(void *ctx,
+     * attributes yet.
+     */
+     if (nb_attributes != 0) {
++      int valueLen, k, l;
+       xmlChar *value;
+         for (j = 0, i = 0; i < nb_attributes; i++, j += 5) {
+@@ -27400,12 +27401,31 @@ xmlSchemaSAXHandleStartElementNs(void *ctx,
+           * libxml2 differs from normal SAX here in that it escapes all ampersands
+           * as &#38; instead of delivering the raw converted string. Changing the
+           * behavior at this point would break applications that use this API, so
+-          * we are forced to work around it. There is no danger of accidentally
+-          * decoding some entity other than &#38; in this step because without
+-          * unescaped ampersands there can be no other entities in the string.
++          * we are forced to work around it.
+           */
+-          value = xmlStringLenDecodeEntities(vctxt->parserCtxt, attributes[j+3],
+-              attributes[j+4] - attributes[j+3], XML_SUBSTITUTE_REF, 0, 0, 0);
++          valueLen = attributes[j+4] - attributes[j+3];
++          value = xmlMallocAtomic(valueLen + 1);
++          if (value == NULL) {
++              xmlSchemaVErrMemory(vctxt,
++                  "allocating string for decoded attribute",
++                  NULL);
++              goto internal_error;
++          }
++          for (k = 0, l = 0; k < valueLen; l++) {
++              if (k < valueLen - 4 &&
++                  attributes[j+3][k+0] == '&' &&
++                  attributes[j+3][k+1] == '#' &&
++                  attributes[j+3][k+2] == '3' &&
++                  attributes[j+3][k+3] == '8' &&
++                  attributes[j+3][k+4] == ';') {
++                  value[l] = '&';
++                  k += 5;
++              } else {
++                  value[l] = attributes[j+3][k];
++                  k++;
++              }
++          }
++          value[l] = '\0';
+           /*
+           * TODO: Set the node line.
+           */
+-- 
+cgit v0.12
+
index 41d5e6707d91cdeebc84fd207d820d3ac89b3f1e..cf607be3b8a5b5eed6003a94cb769b274a650abe 100644 (file)
@@ -16,7 +16,7 @@ Summary(pl.UTF-8):    Biblioteka libXML wersja 2
 Summary(pt_BR.UTF-8):  Biblioteca libXML versão 2
 Name:          libxml2
 Version:       2.9.4
-Release:       1
+Release:       2
 Epoch:         1
 License:       MIT
 Group:         Libraries
@@ -26,6 +26,8 @@ Source0:      ftp://xmlsoft.org/libxml2/%{name}-%{version}.tar.gz
 Patch0:                %{name}-man_fixes.patch
 Patch1:                %{name}-open.gz.patch
 Patch2:                %{name}-largefile.patch
+# https://git.gnome.org/browse/libxml2/patch/?id=3169602058bd2d04913909e869c61d1540bc7fb4
+Patch3:                %{name}-schema.patch
 URL:           http://xmlsoft.org/
 BuildRequires: autoconf >= 2.68
 BuildRequires: automake >= 1.4
@@ -173,6 +175,7 @@ do biblioteki libxml2.
 %patch1 -p1
 %endif
 %patch2 -p1
+%patch3 -p1
 
 %build
 %{__libtoolize}
This page took 0.219557 seconds and 4 git commands to generate.