]> git.pld-linux.org Git - packages/libxml2.git/commitdiff
- rel 6; don't abuse zlib internal stuff (from archlinux) auto/th/libxml2-2_7_6-6 auto/ti/libxml2-2_7_6-6
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Tue, 9 Feb 2010 18:49:22 +0000 (18:49 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    libxml2-zlib.patch -> 1.1
    libxml2.spec -> 1.176

libxml2-zlib.patch [new file with mode: 0644]
libxml2.spec

diff --git a/libxml2-zlib.patch b/libxml2-zlib.patch
new file mode 100644 (file)
index 0000000..4bf486d
--- /dev/null
@@ -0,0 +1,32 @@
+From a7e79f28689c574e0bbef17f4cb3da00249181ff Mon Sep 17 00:00:00 2001
+From: Mark Adler <madler@alumni.caltech.edu>
+Date: Tue, 19 Jan 2010 15:28:48 +0000
+Subject: libxml violates the zlib interface and crashes
+
+* xmlIO.c: remove an abuse of zlib API and use a clean interface
+  available in zlib >= 1.2.3
+---
+diff --git a/xmlIO.c b/xmlIO.c
+index c03ac43..8fc00e3 100644
+--- a/xmlIO.c
++++ b/xmlIO.c
+@@ -2518,6 +2518,9 @@ __xmlParserInputBufferCreateFilename(const char *URI, xmlCharEncoding enc) {
+ #ifdef HAVE_ZLIB_H
+       if ((xmlInputCallbackTable[i].opencallback == xmlGzfileOpen) &&
+               (strcmp(URI, "-") != 0)) {
++#if defined(ZLIB_VERNUM) && ZLIB_VERNUM >= 0x1230
++            ret->compressed = !gzdirect(context);
++#else
+           if (((z_stream *)context)->avail_in > 4) {
+               char *cptr, buff4[4];
+               cptr = (char *) ((z_stream *)context)->next_in;
+@@ -2529,6 +2532,7 @@ __xmlParserInputBufferCreateFilename(const char *URI, xmlCharEncoding enc) {
+                   gzrewind(context);
+               }
+           }
++#endif
+       }
+ #endif
+     }
+--
+cgit v0.8.3.1
index 69b76d23f231eb6b46736a2c174d8ee907fbda01..6c936fd285a9cb41884c297c253ad9e88f46ba60 100644 (file)
@@ -10,7 +10,7 @@ Summary(pl.UTF-8):    Biblioteka libXML wersja 2
 Summary(pt_BR.UTF-8):  Biblioteca libXML versão 2
 Name:          libxml2
 Version:       2.7.6
-Release:       5
+Release:       6
 Epoch:         1
 License:       MIT
 Group:         Libraries
@@ -21,6 +21,7 @@ Patch0:               %{name}-amfix.patch
 Patch1:                %{name}-man_fixes.patch
 Patch2:                %{name}-open.gz.patch
 Patch3:                %{name}-largefile.patch
+Patch4:                %{name}-zlib.patch
 URL:           http://xmlsoft.org/
 BuildRequires: autoconf >= 2.2
 BuildRequires: automake >= 1.4
@@ -141,6 +142,7 @@ Moduły języka Python dla biblioteki libxml2.
 %patch2 -p1
 %endif
 %patch3 -p1
+%patch4 -p1
 
 %build
 %{__libtoolize}
This page took 0.22623 seconds and 4 git commands to generate.