]> git.pld-linux.org Git - packages/libx264.git/commitdiff
- ac gcc 3.3.6 on ppc has no "vand" instructions, drop altivec detect; rel 3 auto/ac/libx264-0_1_3-1_20100512_2245_3
authorElan Ruusamäe <glen@pld-linux.org>
Thu, 26 Aug 2010 10:59:20 +0000 (10:59 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    altivec-no-vand.patch -> 1.1
    libx264.spec -> 1.30

altivec-no-vand.patch [new file with mode: 0644]
libx264.spec

diff --git a/altivec-no-vand.patch b/altivec-no-vand.patch
new file mode 100644 (file)
index 0000000..ca7d003
--- /dev/null
@@ -0,0 +1,20 @@
+--- x264-snapshot-20100512-2245/common/cpu.c~  2010-05-12 23:45:09.000000000 +0300
++++ x264-snapshot-20100512-2245/common/cpu.c   2010-08-26 13:57:43.790488230 +0300
+@@ -251,6 +251,9 @@
+ uint32_t x264_cpu_detect( void )
+ {
++#if 1
++    return 0;
++#else
+     static void (*oldsig)( int );
+     oldsig = signal( SIGILL, sigill_handler );
+@@ -270,6 +273,7 @@
+     signal( SIGILL, oldsig );
+     return X264_CPU_ALTIVEC;
++#endif
+ }
+ #endif
index 04e776c53ae0c83563d511a655ad8e827dc8d257..30bea6e3ac9d66fc5a8e9d6d07e903c5557b34b6 100644 (file)
@@ -1,6 +1,6 @@
 %define                snap    20100512
 %define                snaph   2245
-%define                rel     2
+%define                rel             3
 Summary:       H264 encoder library
 Summary(pl.UTF-8):     Biblioteka kodująca H264
 Name:          libx264
@@ -15,6 +15,7 @@ Source0:      ftp://ftp.videolan.org/pub/videolan/x264/snapshots/x264-snapshot-%{snap
 # Source0-md5: 38c331e76ab11517261522a60da8dd31
 Patch0:                %{name}-alpha.patch
 Patch1:                %{name}-syms.patch
+Patch2:                altivec-no-vand.patch
 URL:           http://www.videolan.org/developers/x264.html
 BuildRequires: pkgconfig
 %ifarch %{ix86} %{x8664}
@@ -59,6 +60,7 @@ Statyczna biblioteka x264.
 %setup -q -n x264-snapshot-%{snap}-%{snaph}
 %patch0 -p1
 %patch1 -p1
+%patch2 -p1
 sed -i 's:-O4::g' configure
 
 %build
This page took 0.216062 seconds and 4 git commands to generate.