]> git.pld-linux.org Git - packages/libx264.git/commitdiff
- updated to latest version (last change 20240219; API 164); use API-based versioning... auto/th/libx264-0.164-0.20240220.1
authorJakub Bogusz <qboosh@pld-linux.org>
Wed, 28 Feb 2024 18:08:47 +0000 (19:08 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Wed, 28 Feb 2024 18:08:47 +0000 (19:08 +0100)
altivec-no-vand.patch [deleted file]
libx264-gpac.patch
libx264.spec

diff --git a/altivec-no-vand.patch b/altivec-no-vand.patch
deleted file mode 100644 (file)
index ca7d003..0000000
+++ /dev/null
@@ -1,20 +0,0 @@
---- x264-snapshot-20100512-2245/common/cpu.c~  2010-05-12 23:45:09.000000000 +0300
-+++ x264-snapshot-20100512-2245/common/cpu.c   2010-08-26 13:57:43.790488230 +0300
-@@ -251,6 +251,9 @@
- uint32_t x264_cpu_detect( void )
- {
-+#if 1
-+    return 0;
-+#else
-     static void (*oldsig)( int );
-     oldsig = signal( SIGILL, sigill_handler );
-@@ -270,6 +273,7 @@
-     signal( SIGILL, oldsig );
-     return X264_CPU_ALTIVEC;
-+#endif
- }
- #endif
index c07c54e468107e43a2e3dd69c59996311aa0b385..4ba3b1eeff073e249f7fe3431762126a46acc6e4 100644 (file)
@@ -1,11 +1,11 @@
---- x264-snapshot-20140328-2245/configure~     2014-03-29 08:43:39.000000000 +0100
-+++ x264-snapshot-20140328-2245/configure      2014-03-29 08:44:32.177299477 +0100
-@@ -950,7 +950,7 @@
- if [ "$gpac" = "auto" -a "$lsmash" != "yes" ] ; then
-     gpac="no"
--    GPAC_LIBS="-lgpac_static"
-+    GPAC_LIBS="-lgpac"
-     cc_check "" -lz && GPAC_LIBS="$GPAC_LIBS -lz"
-     if [ "$SYS" = "WINDOWS" ] ; then
-         cc_check "" -lws2_32 && GPAC_LIBS="$GPAC_LIBS -lws2_32"
+--- x264-12426f5f4906e34d483a07da0debb6d56c6f8434/configure.orig       2024-02-20 00:03:00.000000000 +0100
++++ x264-12426f5f4906e34d483a07da0debb6d56c6f8434/configure    2024-02-28 06:09:32.303124601 +0100
+@@ -1285,7 +1285,7 @@ if [ "$gpac" = "auto" -a "$lsmash" != "y
+         fi
+     fi
+     if [ -z "$GPAC_LIBS" ] ; then
+-        GPAC_LIBS="-lgpac_static"
++        GPAC_LIBS="-lgpac"
+         cc_check "" -lz && GPAC_LIBS="$GPAC_LIBS -lz"
+         cc_check "" -ldl && GPAC_LIBS="$GPAC_LIBS -ldl"
+         if [ "$SYS" = "WINDOWS" ] ; then
index ff8bf94e2bc5a2376bf97521f69decbff159f5ce..cc74ce1038e3a0d41e26c7da21a6ef253ee5f42b 100644 (file)
@@ -8,29 +8,31 @@
 %undefine      with_asm
 %endif
 
-%define                rel     2
-%define                snap    20191217
-%define                snaph   2245
+%define                gitref  12426f5f4906e34d483a07da0debb6d56c6f8434
+%define                rel     1
+%define                snap    20240220
+%define                api_ver 164
 Summary:       H264 encoder library
 Summary(pl.UTF-8):     Biblioteka kodująca H264
 Name:          libx264
-Version:       0.1.3
-Release:       1.%{snap}_%{snaph}.%{rel}
+Version:       0.%{api_ver}
+Release:       0.%{snap}.%{rel}
 License:       GPL v2+
 Group:         Libraries
 # still no releases, use snapshots
+# previously available at https://download.videolan.org/videolan/x264/snapshots/
 # for further changes see: https://code.videolan.org/videolan/x264/
-Source0:       https://download.videolan.org/videolan/x264/snapshots/x264-snapshot-%{snap}-%{snaph}.tar.bz2
-# Source0-md5: 6d6b7b49518ddfd42c4e3577b5242b31
+Source0:       https://code.videolan.org/videolan/x264/-/archive/%{gitref}/x264-%{gitref}.tar.bz2
+# Source0-md5: b46bb3b0521e2d5fdefeed345bd42f94
 Patch0:                %{name}-alpha.patch
-Patch1:                altivec-no-vand.patch
-Patch2:                %{name}-gpac.patch
-Patch3:                x32.patch
+Patch1:                %{name}-gpac.patch
+Patch2:                x32.patch
 URL:           http://www.videolan.org/developers/x264.html
 %ifarch %{ix86} %{x8664}
 %{?with_asm:BuildRequires:     nasm >= 2.13}
 %endif
 BuildRequires: pkgconfig
+BuildRequires: rpmbuild(macros) >= 1.673
 %if %{without bootstrap}
 # which version exactly???
 # for full x264 CLI utility functionality it wants:
@@ -39,7 +41,7 @@ BuildRequires:        pkgconfig
 BuildRequires: ffmpeg-devel >= 0.7.1
 BuildRequires: ffms2-devel >= 2.21
 # gpac >= 2007-06-21
-%{!?with_lsmash:BuildRequires: gpac-devel >= 0.5.0-3}
+%{!?with_lsmash:BuildRequires: gpac-devel >= 0.8.0}
 %{?with_lsmash:BuildRequires:  l-smash-devel >= 1.5}
 %endif
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -87,7 +89,7 @@ Requires:     ffms2 >= 2.21
 %if %{with lsmash}
 Requires:      l-smash >= 1.5
 %else
-Requires:      gpac >= 0.5.0-3
+Requires:      gpac >= 0.8.0
 %endif
 %endif
 
@@ -98,13 +100,10 @@ x264 CLI decoder.
 Dekoder x264 działający z linii poleceń.
 
 %prep
-%setup -q -n x264-snapshot-%{snap}-%{snaph}
+%setup -q -n x264-%{gitref}
 %patch0 -p1
-%if "%{pld_release}" == "ac"
 %patch1 -p1
-%endif
 %patch2 -p1
-%patch3 -p1
 
 %build
 CC="%{__cc}" \
@@ -138,7 +137,7 @@ rm -rf $RPM_BUILD_ROOT
 %files
 %defattr(644,root,root,755)
 %doc AUTHORS
-%attr(755,root,root) %{_libdir}/libx264.so.157
+%attr(755,root,root) %{_libdir}/libx264.so.%{api_ver}
 
 %files devel
 %defattr(644,root,root,755)
@@ -154,3 +153,4 @@ rm -rf $RPM_BUILD_ROOT
 %files -n x264
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/x264
+%{bash_compdir}/x264
This page took 0.156569 seconds and 4 git commands to generate.