]> git.pld-linux.org Git - packages/libx264.git/blob - libx264.spec
- up to 20111212_2245
[packages/libx264.git] / libx264.spec
1 #
2 # Conditional build:
3 %bcond_with     bootstrap
4 #
5 %define         snap    20111212
6 %define         snaph   2245
7 %define         rel             1
8 Summary:        H264 encoder library
9 Summary(pl.UTF-8):      Biblioteka kodująca H264
10 Name:           libx264
11 Version:        0.1.3
12 Release:        1.%{snap}_%{snaph}.%{rel}
13 License:        GPL v2+
14 Group:          Libraries
15 # still no releases, use snapshots
16 Source0:        ftp://ftp.videolan.org/pub/videolan/x264/snapshots/x264-snapshot-%{snap}-%{snaph}.tar.bz2
17 # Source0-md5:  586e5a6e49bef5b026702c327b1edda2
18 Patch0:         %{name}-alpha.patch
19 Patch1:         altivec-no-vand.patch
20 Patch2:         %{name}-gpac.patch
21 URL:            http://www.videolan.org/developers/x264.html
22 BuildRequires:  pkgconfig
23 %ifarch %{ix86} %{x8664}
24 BuildRequires:  yasm >= 0.6.0
25 %endif
26 %if %{without bootstrap}
27 # which version exactly???
28 # for full x264 CLI utility functionality it wants:
29 # libswscale >= 0.9.0 (in pkgconfig file)
30 # libav{format,codec,util} from ffmpeg >= r21854
31 BuildRequires:  ffmpeg-devel >= 0.7.1
32 BuildRequires:  ffmpegsource-devel >= 2.16
33 # gpac >= 2007-06-21
34 BuildRequires:  gpac-devel >= 0.4.5-2
35 Requires:       gpac >= 0.4.5-2
36 %endif
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 # encoder/macroblock.c breaks strict-aliasing rules
40 %define         specflags       -fno-strict-aliasing
41
42 %description
43 libx264 library for encoding H264 video format.
44
45 %description -l pl.UTF-8
46 Biblioteka libx264 do kodowania w formacie obrazu H264.
47
48 %package devel
49 Summary:        Header files for x264 library
50 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki x264
51 Group:          Development/Libraries
52 Requires:       %{name} = %{version}-%{release}
53
54 %description devel
55 Header files for x264 library.
56
57 %description devel -l pl.UTF-8
58 Pliki nagłówkowe biblioteki x264.
59
60 %package static
61 Summary:        Static x264 library
62 Summary(pl.UTF-8):      Statyczna biblioteka x264
63 Group:          Development/Libraries
64 Requires:       %{name}-devel = %{version}-%{release}
65
66 %description static
67 Static x264 library.
68
69 %description static -l pl.UTF-8
70 Statyczna biblioteka x264.
71
72 %package -n x264
73 Summary:        x264 CLI decoder
74 Summary(pl.UTF-8):      Dekoder x264 działający z linii poleceń
75 Group:          Applications/Multimedia
76 Requires:       %{name} = %{version}-%{release}
77
78 %description -n x264
79 x264 CLI decoder.
80
81 %description -n x264 -l pl.UTF-8
82 Dekoder x264 działający z linii poleceń.
83
84 %prep
85 %setup -q -n x264-snapshot-%{snap}-%{snaph}
86 %patch0 -p1
87 %if "%{pld_release}" == "ac"
88 %patch1 -p1
89 %endif
90 %patch2 -p1
91
92 %build
93 CC="%{__cc}" \
94 ./configure \
95         --prefix=%{_prefix} \
96         --exec-prefix=%{_prefix} \
97         --bindir=%{_bindir} \
98         --includedir=%{_includedir} \
99         --libdir=%{_libdir} \
100         --extra-cflags="%{rpmcflags}" \
101         --enable-pic \
102         --enable-shared \
103         --enable-static
104
105 %{__make}
106
107 %install
108 rm -rf $RPM_BUILD_ROOT
109
110 %{__make} install \
111         DESTDIR=$RPM_BUILD_ROOT
112
113 %clean
114 rm -rf $RPM_BUILD_ROOT
115
116 %post   -p /sbin/ldconfig
117 %postun -p /sbin/ldconfig
118
119 %files
120 %defattr(644,root,root,755)
121 %doc AUTHORS
122 %attr(755,root,root) %{_libdir}/libx264.so.120
123
124 %files devel
125 %defattr(644,root,root,755)
126 %attr(755,root,root) %{_libdir}/libx264.so
127 %{_includedir}/x264.h
128 %{_includedir}/x264_config.h
129 %{_pkgconfigdir}/x264.pc
130
131 %files static
132 %defattr(644,root,root,755)
133 %{_libdir}/libx264.a
134
135 %files -n x264
136 %defattr(644,root,root,755)
137 %attr(755,root,root) %{_bindir}/x264
This page took 0.056542 seconds and 3 git commands to generate.