]> git.pld-linux.org Git - packages/libx264.git/blob - libx264.spec
- dropped acam patch, pass CC
[packages/libx264.git] / libx264.spec
1 Summary:        H264 encoder library
2 Summary(pl):    Biblioteka koduj±ca H264
3 Name:           libx264
4 Version:        0.1.2
5 %define snap    20060430
6 %define snaph   2245
7 Release:        1.%{snap}_%{snaph}.1
8 License:        GPL v2
9 Group:          Libraries
10 # unofficial, debianized/libtoolized packaging:
11 #Source0:       http://www.acarlab.com/misc-dnlds/%{name}-%{version}.tar.gz
12 # but it's too old, so use snapshots...
13 Source0:        ftp://ftp.videolan.org/pub/videolan/x264/snapshots/x264-snapshot-%{snap}-%{snaph}.tar.bz2
14 # Source0-md5:  667c760dda91e9a3f50186d4676b5d5a
15 Patch0:         %{name}-liblink.patch
16 URL:            http://developers.videolan.org/x264.html
17 %ifarch %{ix86}
18 BuildRequires:  nasm
19 %endif
20 BuildRequires:  sed >= 4.0
21 %ifarch %{x8664}
22 BuildRequires:  yasm
23 %endif
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 # encoder/macroblock.c breaks strict-aliasing rules
27 %define         specflags       -fno-strict-aliasing
28
29 %description
30 libx264 library for encoding H264 video format.
31
32 %description -l pl
33 Biblioteka libx264 do kodowania w formacie obrazu H264.
34
35 %package devel
36 Summary:        Header files for x264 library
37 Summary(pl):    Pliki nag³ówkowe biblioteki x264
38 Group:          Development/Libraries
39 Requires:       %{name} = %{version}-%{release}
40
41 %description devel
42 Header files for x264 library.
43
44 %description devel -l pl
45 Pliki nag³ówkowe biblioteki x264.
46
47 %package static
48 Summary:        Static x264 library
49 Summary(pl):    Statyczna biblioteka x264
50 Group:          Development/Libraries
51 Requires:       %{name}-devel = %{version}-%{release}
52
53 %description static
54 Static x264 library.
55
56 %description static -l pl
57 Statyczna biblioteka x264.
58
59 %prep
60 %setup -q -n x264-snapshot-%{snap}-%{snaph}
61 %patch0 -p0
62 sed -i 's:-O4::g' configure
63
64 %build
65 CC="%{__cc}" \
66 ./configure \
67         --prefix=%{_prefix} \
68         --exec-prefix=%{_prefix} \
69         --bindir=%{_bindir} \
70         --includedir=%{_includedir} \
71         --libdir=%{_libdir} \
72         --extra-cflags="%{rpmcflags}" \
73         --enable-shared
74
75 %{__make}
76
77 %install
78 rm -rf $RPM_BUILD_ROOT
79
80 %{__make} install \
81         DESTDIR=$RPM_BUILD_ROOT
82
83 %clean
84 rm -rf $RPM_BUILD_ROOT
85
86 %post   -p /sbin/ldconfig
87 %postun -p /sbin/ldconfig
88
89 %files
90 %defattr(644,root,root,755)
91 %doc AUTHORS
92 %attr(755,root,root) %{_bindir}/x264
93 %attr(755,root,root) %{_libdir}/libx264.so.*
94
95 %files devel
96 %defattr(644,root,root,755)
97 %attr(755,root,root) %{_libdir}/libx264.so
98 %{_includedir}/x264.h
99 %{_pkgconfigdir}/x264.pc
100
101 %files static
102 %defattr(644,root,root,755)
103 %{_libdir}/libx264.a
This page took 0.060286 seconds and 3 git commands to generate.