]> git.pld-linux.org Git - packages/libx264.git/blob - libx264.spec
- update to 20061024 snap (X264_BUILD 54)
[packages/libx264.git] / libx264.spec
1 Summary:        H264 encoder library
2 Summary(pl):    Biblioteka koduj±ca H264
3 Name:           libx264
4 Version:        0.1.2
5 %define snap    20061024
6 %define snaph   2245
7 Release:        1.%{snap}_%{snaph}.1
8 License:        GPL v2
9 Group:          Libraries
10 # unofficial, debianized/libtoolized packaging:
11 #Source0:       http://www.acarlab.com/misc-dnlds/%{name}-%{version}.tar.gz
12 # but it's too old, so use snapshots...
13 Source0:        ftp://ftp.videolan.org/pub/videolan/x264/snapshots/x264-snapshot-%{snap}-%{snaph}.tar.bz2
14 # Source0-md5:  529d619bd7ba8185143ba35b05fa69d0
15 URL:            http://developers.videolan.org/x264.html
16 %ifarch %{ix86}
17 BuildRequires:  nasm
18 %endif
19 BuildRequires:  sed >= 4.0
20 %ifarch %{x8664}
21 BuildRequires:  yasm
22 %endif
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 # encoder/macroblock.c breaks strict-aliasing rules
26 %define         specflags       -fno-strict-aliasing
27
28 %description
29 libx264 library for encoding H264 video format.
30
31 %description -l pl
32 Biblioteka libx264 do kodowania w formacie obrazu H264.
33
34 %package devel
35 Summary:        Header files for x264 library
36 Summary(pl):    Pliki nag³ówkowe biblioteki x264
37 Group:          Development/Libraries
38 Requires:       %{name} = %{version}-%{release}
39
40 %description devel
41 Header files for x264 library.
42
43 %description devel -l pl
44 Pliki nag³ówkowe biblioteki x264.
45
46 %package static
47 Summary:        Static x264 library
48 Summary(pl):    Statyczna biblioteka x264
49 Group:          Development/Libraries
50 Requires:       %{name}-devel = %{version}-%{release}
51
52 %description static
53 Static x264 library.
54
55 %description static -l pl
56 Statyczna biblioteka x264.
57
58 %prep
59 %setup -q -n x264-snapshot-%{snap}-%{snaph}
60 sed -i 's:-O4::g' configure
61
62 %build
63 CC="%{__cc}" \
64 ./configure \
65         --prefix=%{_prefix} \
66         --exec-prefix=%{_prefix} \
67         --bindir=%{_bindir} \
68         --includedir=%{_includedir} \
69         --libdir=%{_libdir} \
70         --extra-cflags="%{rpmcflags}" \
71         --enable-shared
72
73 %{__make}
74
75 %install
76 rm -rf $RPM_BUILD_ROOT
77
78 %{__make} install \
79         DESTDIR=$RPM_BUILD_ROOT
80
81 %clean
82 rm -rf $RPM_BUILD_ROOT
83
84 %post   -p /sbin/ldconfig
85 %postun -p /sbin/ldconfig
86
87 %files
88 %defattr(644,root,root,755)
89 %doc AUTHORS
90 %attr(755,root,root) %{_bindir}/x264
91 %attr(755,root,root) %{_libdir}/libx264.so.*
92
93 %files devel
94 %defattr(644,root,root,755)
95 %attr(755,root,root) %{_libdir}/libx264.so
96 %{_includedir}/x264.h
97 %{_pkgconfigdir}/x264.pc
98
99 %files static
100 %defattr(644,root,root,755)
101 %{_libdir}/libx264.a
This page took 0.074714 seconds and 3 git commands to generate.