]> git.pld-linux.org Git - packages/libwmf.git/blob - libwmf.spec
- -libs split
[packages/libwmf.git] / libwmf.spec
1 #
2 # Conditional build:
3 %bcond_without  gtk             # without gtk-loader package (which requires gtk+2-devel)
4 %bcond_without  static_libs     # don't build static version of library
5 #
6 Summary:        libwmf - library to convert wmf files
7 Summary(pl):    libwmf - biblioteka z funkcjami do konwersji plików wmf
8 Name:           libwmf
9 Version:        0.2.8.4
10 Release:        1.1
11 Epoch:          2
12 License:        GPL
13 Group:          Applications/Text
14 Source0:        http://dl.sourceforge.net/wvware/%{name}-%{version}.tar.gz
15 # Source0-md5:  d1177739bf1ceb07f57421f0cee191e0
16 Patch0:         %{name}-fontmap-pld.patch
17 Patch1:         %{name}-includes.patch
18 Patch2:         %{name}-segv.patch
19 URL:            http://wvware.sourceforge.net/
20 BuildRequires:  XFree86-devel
21 BuildRequires:  autoconf
22 BuildRequires:  automake
23 BuildRequires:  expat-devel
24 BuildRequires:  freetype-devel >= 2.0
25 %{?with_gtk:BuildRequires:      gtk+2-devel >= 1:2.1.2}
26 BuildRequires:  libjpeg-devel
27 BuildRequires:  libpng-devel
28 BuildRequires:  libtool >= 1:1.4.2-9
29 PreReq:         ghostscript-fonts-std
30 Requires(post): /sbin/ldconfig
31 Requires(post): sed
32 Requires:       sed
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %define         specflags_ia32  -fomit-frame-pointer
36
37 %description
38 libwmf is a library for unix like machines that can convert wmf files
39 into other formats, currently it supports fig, eps, a gd binding to
40 convert to png, and an X one to draw direct to an X window or pixmap.
41
42 %description -l pl
43 libwmf jest bibliotek± dla systemów uniksowych, która konwertuje pliki
44 wmf na inne formaty. Aktualnie obs³uguje formaty fig i eps, format png
45 poprzez bibliotekê gd oraz - poprzez biblioteki X Window - rysowanie w
46 okienku oraz format xpm.
47
48 %package devel
49 Summary:        libwmf - header files
50 Summary(pl):    libwmf - pliki nag³ówkowe
51 Group:          Development/Libraries
52 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
53 # libwmflite(.la) has no additional deps
54 # libwmf(.la) needs freetype-devel, XFree86-devel, expat-devel, libjpeg-devel, libpng-devel
55
56 %description devel
57 This package contains libwmf header files.
58
59 %description devel -l pl
60 Pakiet zawiera pliki nag³ówkowe do biblioteki libwmf.
61
62 %package libs
63 Summary:        libwmf - libraries
64 Group:          Libraries
65
66 %description libs
67 This package contains libwmf libraries.
68
69 %package static
70 Summary:        libwmf - static libraries
71 Summary(pl):    libwmf - biblioteki statyczne
72 Group:          Development/Libraries
73 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
74
75 %description static
76 This package contains libwmf static libraries.
77
78 %description static -l pl
79 Pakiet zawiera statyczn± wersjê biblioteki libwmf.
80
81 %package gtk-loader
82 Summary:        WMF loader for gdk_pixbuf 2.x library
83 Summary(pl):    Modu³ wczytuj±cy WMF dla biblioteki gdk_pixbuf 2.x
84 Group:          X11/Libraries
85 Requires:       %{name} = %{epoch}:%{version}-%{release}
86
87 %description gtk-loader
88 WMF loader for gdk_pixbuf 2.x library.
89
90 %description gtk-loader -l pl
91 Modu³ wczytuj±cy WMF dla biblioteki gdk_pixbuf 2.x
92
93 %prep
94 %setup -q
95 %patch0 -p1
96 %patch1 -p1
97 %patch2 -p1
98
99 %build
100 %{__libtoolize}
101 %{__aclocal}
102 %{__autoheader}
103 %{__autoconf}
104 %{__automake}
105 %configure \
106         %{!?with_static_libs:--disable-static} \
107         --with-sysfontmap=%{_fontsdir}/ghostscript-fonts-std.font \
108         --with-gsfontmap=%{_fontsdir}/Type1/Fontmap \
109         --with-gsfontdir=%{_fontsdir}/Type1
110
111 %{__make}
112
113 %install
114 rm -rf $RPM_BUILD_ROOT
115
116 %{__make} install \
117         DESTDIR=$RPM_BUILD_ROOT
118
119 mv -f $RPM_BUILD_ROOT%{_datadir}/doc ./html-doc
120
121 # no static modules and *.la for GTK+ loaders - shut up check-files
122 rm -f $RPM_BUILD_ROOT%{_libdir}/gtk-2*/*/loaders/*.{a,la}
123
124 %clean
125 rm -rf $RPM_BUILD_ROOT
126
127 %post
128 %{_bindir}/libwmf-fontmap > /dev/null
129
130 %post   libs -p /sbin/ldconfig
131 %postun libs -p /sbin/ldconfig
132
133 %files
134 %defattr(644,root,root,755)
135 %doc CREDITS ChangeLog README TODO
136 %attr(755,root,root) %{_bindir}/libwmf-fontmap
137 %attr(755,root,root) %{_bindir}/wmf2eps
138 %attr(755,root,root) %{_bindir}/wmf2fig
139 %attr(755,root,root) %{_bindir}/wmf2gd
140 %attr(755,root,root) %{_bindir}/wmf2svg
141 %attr(755,root,root) %{_bindir}/wmf2x
142 %dir %{_datadir}/libwmf
143 %dir %{_datadir}/libwmf/fonts
144 %ghost %{_datadir}/libwmf/fonts/fontmap
145
146 %files devel
147 %defattr(644,root,root,755)
148 %doc html-doc examples
149 %attr(755,root,root) %{_bindir}/libwmf-config
150 %attr(755,root,root) %{_libdir}/*.so
151 %{_libdir}/*.la
152 %{_includedir}/*
153
154 %files libs
155 %defattr(644,root,root,755)
156 %attr(755,root,root) %{_libdir}/*.so.*.*
157
158 %if %{with static_libs}
159 %files static
160 %defattr(644,root,root,755)
161 %{_libdir}/*.a
162 %endif
163
164 %if %{with gtk}
165 %files gtk-loader
166 %defattr(644,root,root,755)
167 %attr(755,root,root) %{_libdir}/gtk-2*/*/loaders/*.so
168 %endif
This page took 0.055237 seconds and 4 git commands to generate.