]> git.pld-linux.org Git - packages/libwmf.git/blob - libwmf.spec
- rel 2
[packages/libwmf.git] / libwmf.spec
1 #
2 # Conditional build:
3 %bcond_without  gtk             # without gtk-loader package (which requires gtk+2-devel)
4 %bcond_without  static_libs     # don't build static version of library
5 #
6 Summary:        libwmf - library to convert wmf files
7 Summary(pl):    libwmf - biblioteka z funkcjami do konwersji plików wmf
8 Name:           libwmf
9 Version:        0.2.8.4
10 Release:        2
11 Epoch:          2
12 License:        GPL
13 Group:          Applications/Text
14 Source0:        http://dl.sourceforge.net/wvware/%{name}-%{version}.tar.gz
15 # Source0-md5:  d1177739bf1ceb07f57421f0cee191e0
16 Patch0:         %{name}-fontmap-pld.patch
17 Patch1:         %{name}-includes.patch
18 Patch2:         %{name}-segv.patch
19 URL:            http://wvware.sourceforge.net/
20 BuildRequires:  XFree86-devel
21 BuildRequires:  autoconf
22 BuildRequires:  automake
23 BuildRequires:  expat-devel
24 BuildRequires:  freetype-devel >= 2.0
25 %{?with_gtk:BuildRequires:      gtk+2-devel >= 1:2.1.2}
26 BuildRequires:  libjpeg-devel
27 BuildRequires:  libpng-devel
28 BuildRequires:  libtool >= 1:1.4.2-9
29 PreReq:         ghostscript-fonts-std
30 Requires(post): /sbin/ldconfig
31 Requires(post): sed
32 Requires:       sed
33 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %define         specflags_ia32  -fomit-frame-pointer
37
38 %description
39 libwmf is a library for unix like machines that can convert wmf files
40 into other formats, currently it supports fig, eps, a gd binding to
41 convert to png, and an X one to draw direct to an X window or pixmap.
42
43 %description -l pl
44 libwmf jest bibliotek± dla systemów uniksowych, która konwertuje pliki
45 wmf na inne formaty. Aktualnie obs³uguje formaty fig i eps, format png
46 poprzez bibliotekê gd oraz - poprzez biblioteki X Window - rysowanie w
47 okienku oraz format xpm.
48
49 %package libs
50 Summary:        libwmf - libraries
51 Summary(pl):    libwmf - biblioteki
52 Group:          Libraries
53
54 %description libs
55 This package contains libwmf libraries.
56
57 %description libs -l pl
58 Ten pakiet zawiera biblioteki libwmf.
59
60 %package devel
61 Summary:        libwmf - header files
62 Summary(pl):    libwmf - pliki nag³ówkowe
63 Group:          Development/Libraries
64 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
65 # libwmflite(.la) has no additional deps
66 # libwmf(.la) needs freetype-devel, XFree86-devel, expat-devel, libjpeg-devel, libpng-devel
67
68 %description devel
69 This package contains libwmf header files.
70
71 %description devel -l pl
72 Pakiet zawiera pliki nag³ówkowe do biblioteki libwmf.
73
74 %package static
75 Summary:        libwmf - static libraries
76 Summary(pl):    libwmf - biblioteki statyczne
77 Group:          Development/Libraries
78 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
79
80 %description static
81 This package contains libwmf static libraries.
82
83 %description static -l pl
84 Pakiet zawiera statyczn± wersjê biblioteki libwmf.
85
86 %package gtk-loader
87 Summary:        WMF loader for gdk_pixbuf 2.x library
88 Summary(pl):    Modu³ wczytuj±cy WMF dla biblioteki gdk_pixbuf 2.x
89 Group:          X11/Libraries
90 Requires:       %{name} = %{epoch}:%{version}-%{release}
91
92 %description gtk-loader
93 WMF loader for gdk_pixbuf 2.x library.
94
95 %description gtk-loader -l pl
96 Modu³ wczytuj±cy WMF dla biblioteki gdk_pixbuf 2.x
97
98 %prep
99 %setup -q
100 %patch0 -p1
101 %patch1 -p1
102 %patch2 -p1
103
104 %build
105 %{__libtoolize}
106 %{__aclocal}
107 %{__autoheader}
108 %{__autoconf}
109 %{__automake}
110 %configure \
111         %{!?with_static_libs:--disable-static} \
112         --with-sysfontmap=%{_fontsdir}/ghostscript-fonts-std.font \
113         --with-gsfontmap=%{_fontsdir}/Type1/Fontmap \
114         --with-gsfontdir=%{_fontsdir}/Type1
115
116 %{__make}
117
118 %install
119 rm -rf $RPM_BUILD_ROOT
120
121 %{__make} install \
122         DESTDIR=$RPM_BUILD_ROOT
123
124 rm -rf html-doc
125 mv -f $RPM_BUILD_ROOT%{_datadir}/doc ./html-doc
126
127 # no static modules and *.la for GTK+ loaders - shut up check-files
128 rm -f $RPM_BUILD_ROOT%{_libdir}/gtk-2*/*/loaders/*.{a,la}
129
130 %clean
131 rm -rf $RPM_BUILD_ROOT
132
133 %post
134 %{_bindir}/libwmf-fontmap > /dev/null
135
136 %post   libs -p /sbin/ldconfig
137 %postun libs -p /sbin/ldconfig
138
139 %files
140 %defattr(644,root,root,755)
141 %doc CREDITS ChangeLog README TODO
142 %attr(755,root,root) %{_bindir}/libwmf-fontmap
143 %attr(755,root,root) %{_bindir}/wmf2eps
144 %attr(755,root,root) %{_bindir}/wmf2fig
145 %attr(755,root,root) %{_bindir}/wmf2gd
146 %attr(755,root,root) %{_bindir}/wmf2svg
147 %attr(755,root,root) %{_bindir}/wmf2x
148 %dir %{_datadir}/libwmf
149 %dir %{_datadir}/libwmf/fonts
150 %ghost %{_datadir}/libwmf/fonts/fontmap
151
152 %files libs
153 %defattr(644,root,root,755)
154 %attr(755,root,root) %{_libdir}/*.so.*.*
155
156 %files devel
157 %defattr(644,root,root,755)
158 %doc html-doc examples
159 %attr(755,root,root) %{_bindir}/libwmf-config
160 %attr(755,root,root) %{_libdir}/*.so
161 %{_libdir}/*.la
162 %{_includedir}/*
163
164 %if %{with static_libs}
165 %files static
166 %defattr(644,root,root,755)
167 %{_libdir}/*.a
168 %endif
169
170 %if %{with gtk}
171 %files gtk-loader
172 %defattr(644,root,root,755)
173 %attr(755,root,root) %{_libdir}/gtk-2*/*/loaders/*.so
174 %endif
This page took 1.433761 seconds and 4 git commands to generate.