]> git.pld-linux.org Git - packages/libwmf.git/blob - libwmf.spec
- New style bconds
[packages/libwmf.git] / libwmf.spec
1 #
2 # Conditional build:
3 %bcond_without gtk              # without gtk-loader package (which requires gtk+2-devel)
4 %bcond_without static_libs      # without static version
5
6 Summary:        libwmf - library to convert wmf files
7 Summary(pl):    libwmf - biblioteka z funkcjami do konwersji plików wmf
8 Name:           libwmf
9 Version:        0.2.8.2
10 Release:        1
11 Epoch:          2
12 License:        GPL
13 Group:          Applications/Text
14 Source0:        http://dl.sourceforge.net/wvware/%{name}-%{version}.tar.gz
15 # Source0-md5:  1e0422026dd392651f0b8641fa33599d
16 Patch0:         %{name}-fontmap-pld.patch
17 Patch1:         %{name}-includes.patch
18 Patch2:         %{name}-segv.patch
19 URL:            http://wvware.sourceforge.net/
20 BuildRequires:  XFree86-devel
21 BuildRequires:  autoconf
22 BuildRequires:  automake
23 BuildRequires:  expat-devel
24 BuildRequires:  freetype-devel >= 2.0
25 %{?with_gtk:BuildRequires:      gtk+2-devel >= 2.1.2}
26 BuildRequires:  libjpeg-devel
27 BuildRequires:  libpng-devel
28 BuildRequires:  libtool >= 1:1.4.2-9
29 PreReq:         ghostscript-fonts-std
30 Requires(post): /sbin/ldconfig
31 Requires(post): sed
32 Requires:       sed
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %define         specflags_ia32  -fomit-frame-pointer
36
37 %description
38 libwmf is a library for unix like machines that can convert wmf files
39 into other formats, currently it supports fig, eps, a gd binding to
40 convert to png, and an X one to draw direct to an X window or pixmap.
41
42 %description -l pl
43 libwmf jest bibliotek± dla systemów uniksowych, która konwertuje pliki
44 wmf na inne formaty. Aktualnie obs³uguje formaty fig i eps, format png
45 poprzez bibliotekê gd oraz - poprzez biblioteki X Window - rysowanie w
46 okienku oraz format xpm.
47
48 %package devel
49 Summary:        libwmf - header files
50 Summary(pl):    libwmf - pliki nag³ówkowe
51 Group:          Development/Libraries
52 Requires:       %{name} = %{epoch}:%{version}
53
54 %description devel
55 This package contains libwmf header files.
56
57 %description devel -l pl
58 Pakiet zawiera pliki nag³ówkowe do biblioteki libwmf.
59
60 %package static
61 Summary:        libwmf - static libraries
62 Summary(pl):    libwmf - biblioteki statyczne
63 Group:          Development/Libraries
64 Requires:       %{name}-devel = %{epoch}:%{version}
65
66 %description static
67 This package contains libwmf static libraries.
68
69 %description static -l pl
70 Pakiet zawiera statyczn± wersjê biblioteki libwmf.
71
72 %package gtk-loader
73 Summary:        WMF loader for gdk_pixbuf 2.x library
74 Summary(pl):    Modu³ wczytuj±cy WMF dla biblioteki gdk_pixbuf 2.x
75 Group:          X11/Libraries
76 Requires:       %{name} = %{epoch}:%{version}
77
78 %description gtk-loader
79 WMF loader for gdk_pixbuf 2.x library.
80
81 %description gtk-loader -l pl
82 Modu³ wczytuj±cy WMF dla biblioteki gdk_pixbuf 2.x
83
84 %prep
85 %setup -q
86 %patch0 -p1
87 %patch1 -p1
88 %patch2 -p1
89
90 %build
91 rm -f missing
92 %{__libtoolize}
93 %{__aclocal}
94 %{__autoheader}
95 %{__autoconf}
96 %{__automake}
97 %configure \
98         %{!?with_static_libs:--disable-static} \
99         --with-gsfontdir=%{_fontsdir}/Type1
100
101 %{__make}
102
103 %install
104 rm -rf $RPM_BUILD_ROOT
105
106 %{__make} install \
107         DESTDIR=$RPM_BUILD_ROOT
108
109 mv -f $RPM_BUILD_ROOT%{_datadir}/doc ./html-doc
110
111 %clean
112 rm -rf $RPM_BUILD_ROOT
113
114 %post
115 /sbin/ldconfig
116 %{_bindir}/libwmf-fontmap >/dev/null
117
118 %postun -p /sbin/ldconfig
119
120 %files
121 %defattr(644,root,root,755)
122 %doc CREDITS ChangeLog README TODO
123 %attr(755,root,root) %{_bindir}/libwmf-fontmap
124 %attr(755,root,root) %{_bindir}/wmf2eps
125 %attr(755,root,root) %{_bindir}/wmf2fig
126 %attr(755,root,root) %{_bindir}/wmf2gd
127 %attr(755,root,root) %{_bindir}/wmf2svg
128 %attr(755,root,root) %{_bindir}/wmf2x
129 %attr(755,root,root) %{_libdir}/*.so.*.*
130 %dir %{_datadir}/libwmf
131 %dir %{_datadir}/libwmf/fonts
132 %ghost %{_datadir}/libwmf/fonts/fontmap
133
134 %files devel
135 %defattr(644,root,root,755)
136 %doc html-doc examples
137 %attr(755,root,root) %{_bindir}/libwmf-config
138 %attr(755,root,root) %{_libdir}/*.so
139 %{_libdir}/*.la
140 %{_includedir}/*
141
142 %if %{with static_libs}
143 %files static
144 %defattr(644,root,root,755)
145 %{_libdir}/*.a
146 %endif
147
148 %if %{with gtk}
149 %files gtk-loader
150 %defattr(644,root,root,755)
151 %attr(755,root,root) %{_libdir}/gtk-2*/*/loaders/*.so
152 %endif
This page took 0.075616 seconds and 4 git commands to generate.