]> git.pld-linux.org Git - packages/libwmf.git/blob - libwmf.spec
- no macro in Conflicts for old package
[packages/libwmf.git] / libwmf.spec
1 #
2 # Conditional build:
3 %bcond_without  gtk             # without gtk-loader package (which requires gtk+2-devel)
4 %bcond_without  static_libs     # don't build static version of library
5 #
6 Summary:        libwmf - library to convert wmf files
7 Summary(pl):    libwmf - biblioteka z funkcjami do konwersji plików wmf
8 Name:           libwmf
9 Version:        0.2.8.4
10 Release:        4
11 Epoch:          2
12 License:        GPL
13 Group:          Applications/Text
14 Source0:        http://dl.sourceforge.net/wvware/%{name}-%{version}.tar.gz
15 # Source0-md5:  d1177739bf1ceb07f57421f0cee191e0
16 Patch0:         %{name}-fontmap-pld.patch
17 Patch1:         %{name}-includes.patch
18 Patch2:         %{name}-segv.patch
19 URL:            http://wvware.sourceforge.net/
20 BuildRequires:  autoconf >= 2.59-9
21 BuildRequires:  automake
22 BuildRequires:  expat-devel
23 BuildRequires:  freetype-devel >= 2.0
24 %{?with_gtk:BuildRequires:      gtk+2-devel >= 1:2.1.2}
25 BuildRequires:  libjpeg-devel
26 BuildRequires:  libpng-devel
27 BuildRequires:  libtool >= 1:1.4.2-9
28 BuildRequires:  xorg-lib-libX11-devel
29 Requires(post): ghostscript-fonts-std
30 Requires(post): sed
31 Requires:       ghostscript-fonts-std
32 Requires:       sed
33 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %define         specflags_ia32  -fomit-frame-pointer
37
38 %description
39 libwmf is a library for unix like machines that can convert wmf files
40 into other formats, currently it supports fig, eps, a gd binding to
41 convert to png, and an X one to draw direct to an X window or pixmap.
42
43 %description -l pl
44 libwmf jest bibliotek± dla systemów uniksowych, która konwertuje pliki
45 wmf na inne formaty. Aktualnie obs³uguje formaty fig i eps, format png
46 poprzez bibliotekê gd oraz - poprzez biblioteki X Window - rysowanie w
47 okienku oraz format xpm.
48
49 %package libs
50 Summary:        libwmf - libraries
51 Summary(pl):    libwmf - biblioteki
52 Group:          Libraries
53 Conflicts:      libwmf < 2:0.2.8.4
54
55 %description libs
56 This package contains libwmf libraries.
57
58 %description libs -l pl
59 Ten pakiet zawiera biblioteki libwmf.
60
61 %package devel
62 Summary:        libwmf - header files
63 Summary(pl):    libwmf - pliki nag³ówkowe
64 Group:          Development/Libraries
65 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
66 # libwmflite(.la) has no additional deps
67 # libwmf(.la) needs freetype-devel, expat-devel, libjpeg-devel, libpng-devel, xorg-lib-libX11-devel
68
69 %description devel
70 This package contains libwmf header files.
71
72 %description devel -l pl
73 Pakiet zawiera pliki nag³ówkowe do biblioteki libwmf.
74
75 %package static
76 Summary:        libwmf - static libraries
77 Summary(pl):    libwmf - biblioteki statyczne
78 Group:          Development/Libraries
79 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
80
81 %description static
82 This package contains libwmf static libraries.
83
84 %description static -l pl
85 Pakiet zawiera statyczn± wersjê biblioteki libwmf.
86
87 %package gtk-loader
88 Summary:        WMF loader for gdk_pixbuf 2.x library
89 Summary(pl):    Modu³ wczytuj±cy WMF dla biblioteki gdk_pixbuf 2.x
90 Group:          X11/Libraries
91 Requires:       %{name} = %{epoch}:%{version}-%{release}
92
93 %description gtk-loader
94 WMF loader for gdk_pixbuf 2.x library.
95
96 %description gtk-loader -l pl
97 Modu³ wczytuj±cy WMF dla biblioteki gdk_pixbuf 2.x
98
99 %prep
100 %setup -q
101 %patch0 -p1
102 %patch1 -p1
103 %patch2 -p1
104
105 %build
106 %{__libtoolize}
107 %{__aclocal}
108 %{__autoheader}
109 %{__autoconf}
110 %{__automake}
111 %configure \
112         %{!?with_static_libs:--disable-static} \
113         --with-sysfontmap=%{_fontsdir}/ghostscript-fonts-std.font \
114         --with-gsfontmap=%{_fontsdir}/Type1/Fontmap \
115         --with-gsfontdir=%{_fontsdir}/Type1
116
117 %{__make}
118
119 %install
120 rm -rf $RPM_BUILD_ROOT
121
122 %{__make} install \
123         DESTDIR=$RPM_BUILD_ROOT
124
125 rm -rf html-doc
126 mv -f $RPM_BUILD_ROOT%{_datadir}/doc ./html-doc
127
128 # no static modules and *.la for GTK+ loaders - shut up check-files
129 rm -f $RPM_BUILD_ROOT%{_libdir}/gtk-2*/*/loaders/*.{a,la}
130
131 %clean
132 rm -rf $RPM_BUILD_ROOT
133
134 %post
135 %{_bindir}/libwmf-fontmap > /dev/null
136
137 %post   libs -p /sbin/ldconfig
138 %postun libs -p /sbin/ldconfig
139
140 %files
141 %defattr(644,root,root,755)
142 %doc CREDITS ChangeLog README TODO
143 %attr(755,root,root) %{_bindir}/libwmf-fontmap
144 %attr(755,root,root) %{_bindir}/wmf2eps
145 %attr(755,root,root) %{_bindir}/wmf2fig
146 %attr(755,root,root) %{_bindir}/wmf2gd
147 %attr(755,root,root) %{_bindir}/wmf2svg
148 %attr(755,root,root) %{_bindir}/wmf2x
149 %dir %{_datadir}/libwmf
150 %dir %{_datadir}/libwmf/fonts
151 %ghost %{_datadir}/libwmf/fonts/fontmap
152
153 %files libs
154 %defattr(644,root,root,755)
155 %attr(755,root,root) %{_libdir}/*.so.*.*
156
157 %files devel
158 %defattr(644,root,root,755)
159 %doc html-doc examples
160 %attr(755,root,root) %{_bindir}/libwmf-config
161 %attr(755,root,root) %{_libdir}/*.so
162 %{_libdir}/*.la
163 %{_includedir}/*
164
165 %if %{with static_libs}
166 %files static
167 %defattr(644,root,root,755)
168 %{_libdir}/*.a
169 %endif
170
171 %if %{with gtk}
172 %files gtk-loader
173 %defattr(644,root,root,755)
174 %attr(755,root,root) %{_libdir}/gtk-2*/*/loaders/*.so
175 %endif
This page took 0.116151 seconds and 4 git commands to generate.