]> git.pld-linux.org Git - packages/libwmf.git/blob - libwmf.spec
- ghost soname symlinks, more verbose files
[packages/libwmf.git] / libwmf.spec
1 #
2 # Conditional build:
3 %bcond_without  gtk             # without gtk-loader package (which requires gtk+2-devel)
4 %bcond_without  static_libs     # don't build static version of library
5 #
6 Summary:        libwmf - library to convert WMF files
7 Summary(pl.UTF-8):      libwmf - biblioteka z funkcjami do konwersji plików WMF
8 Name:           libwmf
9 Version:        0.2.8.4
10 Release:        12
11 Epoch:          2
12 License:        LGPL v2+
13 Group:          Applications/Text
14 Source0:        http://downloads.sourceforge.net/wvware/%{name}-%{version}.tar.gz
15 # Source0-md5:  d1177739bf1ceb07f57421f0cee191e0
16 Patch0:         %{name}-fontmap-pld.patch
17 Patch1:         %{name}-includes.patch
18 Patch2:         %{name}-segv.patch
19 Patch3:         %{name}-png12.patch
20 Patch4:         %{name}-0.2.8.4-useafterfree.patch
21 URL:            http://wvware.sourceforge.net/
22 BuildRequires:  autoconf >= 2.59-9
23 BuildRequires:  automake
24 BuildRequires:  expat-devel
25 BuildRequires:  freetype-devel >= 2.0
26 %{?with_gtk:BuildRequires:      gtk+2-devel >= 1:2.10.0}
27 BuildRequires:  libjpeg-devel
28 BuildRequires:  libpng-devel >= 2:1.4.0
29 BuildRequires:  libtool >= 1:1.4.2-9
30 BuildRequires:  pkgconfig
31 BuildRequires:  xorg-lib-libX11-devel
32 Requires(post): ghostscript-fonts-std
33 Requires(post): sed
34 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
35 Requires:       fonts-Type1-urw
36 Requires:       sed
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %define         specflags_ia32  -fomit-frame-pointer
40
41 %description
42 libwmf is a library for Unix like machines that can convert WMF files
43 into other formats, currently it supports fig, eps, a gd binding to
44 convert to png, and an X one to draw direct to an X Window or pixmap.
45
46 %description -l pl.UTF-8
47 libwmf jest biblioteką dla systemów uniksowych, która konwertuje pliki
48 WMF na inne formaty. Aktualnie obsługuje formaty fig i eps, format png
49 poprzez bibliotekę gd oraz - poprzez biblioteki X Window - rysowanie w
50 okienku oraz format xpm.
51
52 %package libs
53 Summary:        libwmf - libraries
54 Summary(pl.UTF-8):      libwmf - biblioteki
55 Group:          Libraries
56 Conflicts:      libwmf < 2:0.2.8.4
57
58 %description libs
59 This package contains libwmf libraries.
60
61 %description libs -l pl.UTF-8
62 Ten pakiet zawiera biblioteki libwmf.
63
64 %package devel
65 Summary:        libwmf - header files
66 Summary(pl.UTF-8):      libwmf - pliki nagłówkowe
67 Group:          Development/Libraries
68 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
69 # libwmflite(.la) has no additional deps
70 # libwmf(.la) needs freetype-devel, expat-devel, libjpeg-devel, libpng-devel, xorg-lib-libX11-devel
71
72 %description devel
73 This package contains libwmf header files.
74
75 %description devel -l pl.UTF-8
76 Pakiet zawiera pliki nagłówkowe do biblioteki libwmf.
77
78 %package static
79 Summary:        libwmf - static libraries
80 Summary(pl.UTF-8):      libwmf - biblioteki statyczne
81 Group:          Development/Libraries
82 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
83
84 %description static
85 This package contains libwmf static libraries.
86
87 %description static -l pl.UTF-8
88 Pakiet zawiera statyczną wersję biblioteki libwmf.
89
90 %package gtk-loader
91 Summary:        WMF loader for gdk_pixbuf 2.x library
92 Summary(pl.UTF-8):      Moduł wczytujący WMF dla biblioteki gdk_pixbuf 2.x
93 Group:          X11/Libraries
94 Requires:       %{name} = %{epoch}:%{version}-%{release}
95
96 %description gtk-loader
97 WMF loader for gdk_pixbuf 2.x library.
98
99 %description gtk-loader -l pl.UTF-8
100 Moduł wczytujący WMF dla biblioteki gdk_pixbuf 2.x
101
102 %prep
103 %setup -q
104 %patch0 -p1
105 %patch1 -p1
106 %patch2 -p1
107 %patch3 -p1
108 %patch4 -p1
109
110 %build
111 rm configure.in
112 %{__libtoolize}
113 %{__aclocal}
114 %{__autoheader}
115 %{__autoconf}
116 %{__automake}
117 LDFLAGS="%{rpmldflags} -Wl,--as-needed"
118 %configure \
119         %{!?with_static_libs:--disable-static} \
120         --with-sysfontmap=%{_fontsdir}/ghostscript-fonts-std.font \
121         --with-gsfontmap=%{_fontsdir}/Type1/Fontmap \
122         --with-gsfontdir=%{_fontsdir}/Type1
123
124 %{__make}
125
126 %install
127 rm -rf $RPM_BUILD_ROOT
128
129 %{__make} -j1 install \
130         DESTDIR=$RPM_BUILD_ROOT
131
132 rm -rf html-doc
133 mv -f $RPM_BUILD_ROOT%{_datadir}/doc ./html-doc
134
135 # no static modules and *.la for GTK+ loaders - shut up check-files
136 rm -f $RPM_BUILD_ROOT%{_libdir}/gtk-2*/*/loaders/*.{a,la}
137
138 %clean
139 rm -rf $RPM_BUILD_ROOT
140
141 %post
142 %{_bindir}/libwmf-fontmap > /dev/null
143
144 %post   libs -p /sbin/ldconfig
145 %postun libs -p /sbin/ldconfig
146
147 %files
148 %defattr(644,root,root,755)
149 %doc CREDITS ChangeLog README TODO
150 %attr(755,root,root) %{_bindir}/libwmf-fontmap
151 %attr(755,root,root) %{_bindir}/wmf2eps
152 %attr(755,root,root) %{_bindir}/wmf2fig
153 %attr(755,root,root) %{_bindir}/wmf2gd
154 %attr(755,root,root) %{_bindir}/wmf2svg
155 %attr(755,root,root) %{_bindir}/wmf2x
156 %dir %{_datadir}/libwmf
157 %dir %{_datadir}/libwmf/fonts
158 %ghost %{_datadir}/libwmf/fonts/fontmap
159
160 %files libs
161 %defattr(644,root,root,755)
162 %attr(755,root,root) %{_libdir}/libwmf-0.2.so.*.*.*
163 %attr(755,root,root) %ghost %{_libdir}/libwmf-0.2.so.7
164 %attr(755,root,root) %{_libdir}/libwmflite-0.2.so.*.*.*
165 %attr(755,root,root) %ghost %{_libdir}/libwmflite-0.2.so.7
166
167 %files devel
168 %defattr(644,root,root,755)
169 %doc html-doc examples
170 %attr(755,root,root) %{_bindir}/libwmf-config
171 %attr(755,root,root) %{_libdir}/libwmf.so
172 %attr(755,root,root) %{_libdir}/libwmflite.so
173 %{_libdir}/libwmf.la
174 %{_libdir}/libwmflite.la
175 %{_includedir}/libwmf
176
177 %if %{with static_libs}
178 %files static
179 %defattr(644,root,root,755)
180 %{_libdir}/libwmf.a
181 %{_libdir}/libwmflite.a
182 %endif
183
184 %if %{with gtk}
185 %files gtk-loader
186 %defattr(644,root,root,755)
187 %attr(755,root,root) %{_libdir}/gtk-2.0/*/loaders/io-wmf.so
188 %endif
This page took 0.050981 seconds and 4 git commands to generate.