]> git.pld-linux.org Git - packages/libwmf.git/blob - libwmf.spec
- patch internal version of gd (taken from Fedora)
[packages/libwmf.git] / libwmf.spec
1 #
2 # Conditional build:
3 %bcond_without  gtk             # without gtk-loader package (which requires gtk+2-devel)
4 %bcond_without  static_libs     # don't build static version of library
5 #
6 Summary:        libwmf - library to convert WMF files
7 Summary(pl.UTF-8):      libwmf - biblioteka z funkcjami do konwersji plików WMF
8 Name:           libwmf
9 Version:        0.2.8.4
10 Release:        14
11 Epoch:          2
12 License:        LGPL v2+
13 Group:          Applications/Text
14 Source0:        http://downloads.sourceforge.net/wvware/%{name}-%{version}.tar.gz
15 # Source0-md5:  d1177739bf1ceb07f57421f0cee191e0
16 Patch0:         %{name}-fontmap-pld.patch
17 Patch1:         %{name}-includes.patch
18 Patch2:         %{name}-segv.patch
19 Patch3:         %{name}-png12.patch
20 Patch4:         %{name}-0.2.8.4-useafterfree.patch
21 Patch5:         %{name}-0.2.8.4-CVE-2007-0455.patch
22 Patch6:         %{name}-0.2.8.4-CVE-2007-3472.patch
23 Patch7:         %{name}-0.2.8.4-CVE-2007-3473.patch
24 Patch8:         %{name}-0.2.8.4-CVE-2007-3477.patch
25 Patch9:         %{name}-0.2.8.4-CVE-2007-2756.patch
26 Patch10:        %{name}-0.2.8.4-CAN-2004-0941.patch
27 Patch11:        %{name}-0.2.8.4-CVE-2009-3546.patch
28 URL:            http://wvware.sourceforge.net/
29 BuildRequires:  autoconf >= 2.59-9
30 BuildRequires:  automake
31 BuildRequires:  expat-devel
32 BuildRequires:  freetype-devel >= 2.0
33 %{?with_gtk:BuildRequires:      gtk+2-devel >= 1:2.10.0}
34 BuildRequires:  libjpeg-devel
35 BuildRequires:  libpng-devel >= 2:1.4.0
36 BuildRequires:  libtool >= 1:1.4.2-9
37 BuildRequires:  pkgconfig
38 BuildRequires:  xorg-lib-libX11-devel
39 Requires(post): ghostscript-fonts-std
40 Requires(post): sed
41 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
42 Requires:       fonts-Type1-urw
43 Requires:       sed
44 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46 %define         specflags_ia32  -fomit-frame-pointer
47
48 %description
49 libwmf is a library for Unix like machines that can convert WMF files
50 into other formats, currently it supports fig, eps, a gd binding to
51 convert to png, and an X one to draw direct to an X Window or pixmap.
52
53 %description -l pl.UTF-8
54 libwmf jest biblioteką dla systemów uniksowych, która konwertuje pliki
55 WMF na inne formaty. Aktualnie obsługuje formaty fig i eps, format png
56 poprzez bibliotekę gd oraz - poprzez biblioteki X Window - rysowanie w
57 okienku oraz format xpm.
58
59 %package libs
60 Summary:        libwmf - libraries
61 Summary(pl.UTF-8):      libwmf - biblioteki
62 Group:          Libraries
63 Conflicts:      libwmf < 2:0.2.8.4
64
65 %description libs
66 This package contains libwmf libraries.
67
68 %description libs -l pl.UTF-8
69 Ten pakiet zawiera biblioteki libwmf.
70
71 %package devel
72 Summary:        libwmf - header files
73 Summary(pl.UTF-8):      libwmf - pliki nagłówkowe
74 Group:          Development/Libraries
75 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
76 # libwmflite(.la) has no additional deps
77 # libwmf(.la) needs freetype-devel, expat-devel, libjpeg-devel, libpng-devel, xorg-lib-libX11-devel
78
79 %description devel
80 This package contains libwmf header files.
81
82 %description devel -l pl.UTF-8
83 Pakiet zawiera pliki nagłówkowe do biblioteki libwmf.
84
85 %package static
86 Summary:        libwmf - static libraries
87 Summary(pl.UTF-8):      libwmf - biblioteki statyczne
88 Group:          Development/Libraries
89 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
90
91 %description static
92 This package contains libwmf static libraries.
93
94 %description static -l pl.UTF-8
95 Pakiet zawiera statyczną wersję biblioteki libwmf.
96
97 %package gtk-loader
98 Summary:        WMF loader for gdk_pixbuf 2.x library
99 Summary(pl.UTF-8):      Moduł wczytujący WMF dla biblioteki gdk_pixbuf 2.x
100 Group:          X11/Libraries
101 Requires:       %{name} = %{epoch}:%{version}-%{release}
102
103 %description gtk-loader
104 WMF loader for gdk_pixbuf 2.x library.
105
106 %description gtk-loader -l pl.UTF-8
107 Moduł wczytujący WMF dla biblioteki gdk_pixbuf 2.x
108
109 %prep
110 %setup -q
111 %patch0 -p1
112 %patch1 -p1
113 %patch2 -p1
114 %patch3 -p1
115 %patch4 -p1
116 %patch5 -p1
117 %patch6 -p1
118 %patch7 -p1
119 %patch8 -p1
120 %patch9 -p1
121 %patch10 -p1
122 %patch11 -p1
123
124 %build
125 rm configure.in
126 %{__libtoolize}
127 %{__aclocal}
128 %{__autoheader}
129 %{__autoconf}
130 %{__automake}
131 LDFLAGS="%{rpmldflags} -Wl,--as-needed"
132 %configure \
133         %{!?with_static_libs:--disable-static} \
134         --with-sysfontmap=%{_fontsdir}/ghostscript-fonts-std.font \
135         --with-gsfontmap=%{_fontsdir}/Type1/Fontmap \
136         --with-gsfontdir=%{_fontsdir}/Type1
137
138 %{__make}
139
140 %install
141 rm -rf $RPM_BUILD_ROOT
142
143 %{__make} -j1 install \
144         DESTDIR=$RPM_BUILD_ROOT
145
146 rm -rf html-doc
147 mv -f $RPM_BUILD_ROOT%{_datadir}/doc ./html-doc
148
149 # no static modules and *.la for GTK+ loaders - shut up check-files
150 rm -f $RPM_BUILD_ROOT%{_libdir}/gtk-2*/*/loaders/*.{a,la}
151
152 %clean
153 rm -rf $RPM_BUILD_ROOT
154
155 %post
156 %{_bindir}/libwmf-fontmap > /dev/null
157
158 %post   libs -p /sbin/ldconfig
159 %postun libs -p /sbin/ldconfig
160
161 %files
162 %defattr(644,root,root,755)
163 %doc CREDITS ChangeLog README TODO
164 %attr(755,root,root) %{_bindir}/libwmf-fontmap
165 %attr(755,root,root) %{_bindir}/wmf2eps
166 %attr(755,root,root) %{_bindir}/wmf2fig
167 %attr(755,root,root) %{_bindir}/wmf2gd
168 %attr(755,root,root) %{_bindir}/wmf2svg
169 %attr(755,root,root) %{_bindir}/wmf2x
170 %dir %{_datadir}/libwmf
171 %dir %{_datadir}/libwmf/fonts
172 %ghost %{_datadir}/libwmf/fonts/fontmap
173
174 %files libs
175 %defattr(644,root,root,755)
176 %attr(755,root,root) %{_libdir}/libwmf-0.2.so.*.*.*
177 %attr(755,root,root) %ghost %{_libdir}/libwmf-0.2.so.7
178 %attr(755,root,root) %{_libdir}/libwmflite-0.2.so.*.*.*
179 %attr(755,root,root) %ghost %{_libdir}/libwmflite-0.2.so.7
180
181 %files devel
182 %defattr(644,root,root,755)
183 %doc html-doc examples
184 %attr(755,root,root) %{_bindir}/libwmf-config
185 %attr(755,root,root) %{_libdir}/libwmf.so
186 %attr(755,root,root) %{_libdir}/libwmflite.so
187 %{_libdir}/libwmf.la
188 %{_libdir}/libwmflite.la
189 %{_includedir}/libwmf
190
191 %if %{with static_libs}
192 %files static
193 %defattr(644,root,root,755)
194 %{_libdir}/libwmf.a
195 %{_libdir}/libwmflite.a
196 %endif
197
198 %if %{with gtk}
199 %files gtk-loader
200 %defattr(644,root,root,755)
201 %attr(755,root,root) %{_libdir}/gtk-2.0/*/loaders/io-wmf.so
202 %endif
This page took 0.04452 seconds and 4 git commands to generate.