]> git.pld-linux.org Git - packages/libwmf.git/blob - libwmf.spec
- security note
[packages/libwmf.git] / libwmf.spec
1 #
2 # http://www.securityfocus.com/bid/18751/info
3 #
4 # Conditional build:
5 %bcond_without  gtk             # without gtk-loader package (which requires gtk+2-devel)
6 %bcond_without  static_libs     # don't build static version of library
7 #
8 Summary:        libwmf - library to convert WMF files
9 Summary(pl.UTF-8):      libwmf - biblioteka z funkcjami do konwersji plików WMF
10 Name:           libwmf
11 Version:        0.2.8.4
12 Release:        8
13 Epoch:          2
14 License:        GPL
15 Group:          Applications/Text
16 Source0:        http://dl.sourceforge.net/wvware/%{name}-%{version}.tar.gz
17 # Source0-md5:  d1177739bf1ceb07f57421f0cee191e0
18 Patch0:         %{name}-fontmap-pld.patch
19 Patch1:         %{name}-includes.patch
20 Patch2:         %{name}-segv.patch
21 Patch3:         %{name}-png12.patch
22 URL:            http://wvware.sourceforge.net/
23 # Fix in RH:
24 # http://securitytracker.com/alerts/2009/Apr/1022156.html
25 BuildRequires:  security(CVE-2009-1364)
26 BuildRequires:  autoconf >= 2.59-9
27 BuildRequires:  automake
28 BuildRequires:  expat-devel
29 BuildRequires:  freetype-devel >= 2.0
30 %{?with_gtk:BuildRequires:      gtk+2-devel >= 1:2.10.0}
31 BuildRequires:  libjpeg-devel
32 BuildRequires:  libpng-devel >= 1.2.12
33 BuildRequires:  libtool >= 1:1.4.2-9
34 BuildRequires:  xorg-lib-libX11-devel
35 Requires(post): ghostscript-fonts-std
36 Requires(post): sed
37 Requires:       fonts-Type1-urw
38 Requires:       sed
39 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %define         specflags_ia32  -fomit-frame-pointer
43
44 %description
45 libwmf is a library for Unix like machines that can convert WMF files
46 into other formats, currently it supports fig, eps, a gd binding to
47 convert to png, and an X one to draw direct to an X Window or pixmap.
48
49 %description -l pl.UTF-8
50 libwmf jest biblioteką dla systemów uniksowych, która konwertuje pliki
51 WMF na inne formaty. Aktualnie obsługuje formaty fig i eps, format png
52 poprzez bibliotekę gd oraz - poprzez biblioteki X Window - rysowanie w
53 okienku oraz format xpm.
54
55 %package libs
56 Summary:        libwmf - libraries
57 Summary(pl.UTF-8):      libwmf - biblioteki
58 Group:          Libraries
59 Conflicts:      libwmf < 2:0.2.8.4
60
61 %description libs
62 This package contains libwmf libraries.
63
64 %description libs -l pl.UTF-8
65 Ten pakiet zawiera biblioteki libwmf.
66
67 %package devel
68 Summary:        libwmf - header files
69 Summary(pl.UTF-8):      libwmf - pliki nagłówkowe
70 Group:          Development/Libraries
71 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
72 # libwmflite(.la) has no additional deps
73 # libwmf(.la) needs freetype-devel, expat-devel, libjpeg-devel, libpng-devel, xorg-lib-libX11-devel
74
75 %description devel
76 This package contains libwmf header files.
77
78 %description devel -l pl.UTF-8
79 Pakiet zawiera pliki nagłówkowe do biblioteki libwmf.
80
81 %package static
82 Summary:        libwmf - static libraries
83 Summary(pl.UTF-8):      libwmf - biblioteki statyczne
84 Group:          Development/Libraries
85 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
86
87 %description static
88 This package contains libwmf static libraries.
89
90 %description static -l pl.UTF-8
91 Pakiet zawiera statyczną wersję biblioteki libwmf.
92
93 %package gtk-loader
94 Summary:        WMF loader for gdk_pixbuf 2.x library
95 Summary(pl.UTF-8):      Moduł wczytujący WMF dla biblioteki gdk_pixbuf 2.x
96 Group:          X11/Libraries
97 Requires:       %{name} = %{epoch}:%{version}-%{release}
98
99 %description gtk-loader
100 WMF loader for gdk_pixbuf 2.x library.
101
102 %description gtk-loader -l pl.UTF-8
103 Moduł wczytujący WMF dla biblioteki gdk_pixbuf 2.x
104
105 %prep
106 %setup -q
107 %patch0 -p1
108 %patch1 -p1
109 %patch2 -p1
110 %patch3 -p1
111
112 %build
113 rm configure.in
114 %{__libtoolize}
115 %{__aclocal}
116 %{__autoheader}
117 %{__autoconf}
118 %{__automake}
119 LDFLAGS="%{rpmldflags} -Wl,--as-needed"
120 %configure \
121         %{!?with_static_libs:--disable-static} \
122         --with-sysfontmap=%{_fontsdir}/ghostscript-fonts-std.font \
123         --with-gsfontmap=%{_fontsdir}/Type1/Fontmap \
124         --with-gsfontdir=%{_fontsdir}/Type1
125
126 %{__make}
127
128 %install
129 rm -rf $RPM_BUILD_ROOT
130
131 %{__make} -j1 install \
132         DESTDIR=$RPM_BUILD_ROOT
133
134 rm -rf html-doc
135 mv -f $RPM_BUILD_ROOT%{_datadir}/doc ./html-doc
136
137 # no static modules and *.la for GTK+ loaders - shut up check-files
138 rm -f $RPM_BUILD_ROOT%{_libdir}/gtk-2*/*/loaders/*.{a,la}
139
140 %clean
141 rm -rf $RPM_BUILD_ROOT
142
143 %post
144 %{_bindir}/libwmf-fontmap > /dev/null
145
146 %post   libs -p /sbin/ldconfig
147 %postun libs -p /sbin/ldconfig
148
149 %files
150 %defattr(644,root,root,755)
151 %doc CREDITS ChangeLog README TODO
152 %attr(755,root,root) %{_bindir}/libwmf-fontmap
153 %attr(755,root,root) %{_bindir}/wmf2eps
154 %attr(755,root,root) %{_bindir}/wmf2fig
155 %attr(755,root,root) %{_bindir}/wmf2gd
156 %attr(755,root,root) %{_bindir}/wmf2svg
157 %attr(755,root,root) %{_bindir}/wmf2x
158 %dir %{_datadir}/libwmf
159 %dir %{_datadir}/libwmf/fonts
160 %ghost %{_datadir}/libwmf/fonts/fontmap
161
162 %files libs
163 %defattr(644,root,root,755)
164 %attr(755,root,root) %{_libdir}/*.so.*.*
165
166 %files devel
167 %defattr(644,root,root,755)
168 %doc html-doc examples
169 %attr(755,root,root) %{_bindir}/libwmf-config
170 %attr(755,root,root) %{_libdir}/*.so
171 %{_libdir}/*.la
172 %{_includedir}/*
173
174 %if %{with static_libs}
175 %files static
176 %defattr(644,root,root,755)
177 %{_libdir}/*.a
178 %endif
179
180 %if %{with gtk}
181 %files gtk-loader
182 %defattr(644,root,root,755)
183 %attr(755,root,root) %{_libdir}/gtk-2*/*/loaders/*.so
184 %endif
This page took 0.048407 seconds and 4 git commands to generate.