]> git.pld-linux.org Git - packages/libwmf.git/blob - libwmf.spec
- added note about libwmf devel deps (maybe separate libwmflite?)
[packages/libwmf.git] / libwmf.spec
1 #
2 # Conditional build:
3 %bcond_without  gtk             # without gtk-loader package (which requires gtk+2-devel)
4 %bcond_without  static_libs     # don't build static version of library
5 #
6 Summary:        libwmf - library to convert wmf files
7 Summary(pl):    libwmf - biblioteka z funkcjami do konwersji plików wmf
8 Name:           libwmf
9 Version:        0.2.8.3
10 Release:        1
11 Epoch:          2
12 License:        GPL
13 Group:          Applications/Text
14 Source0:        http://dl.sourceforge.net/wvware/%{name}-%{version}.tar.gz
15 # Source0-md5:  3b058327bb14d2373260a74beb7f3e2f
16 Patch0:         %{name}-fontmap-pld.patch
17 Patch1:         %{name}-includes.patch
18 Patch2:         %{name}-segv.patch
19 URL:            http://wvware.sourceforge.net/
20 BuildRequires:  XFree86-devel
21 BuildRequires:  autoconf
22 BuildRequires:  automake
23 BuildRequires:  expat-devel
24 BuildRequires:  freetype-devel >= 2.0
25 %{?with_gtk:BuildRequires:      gtk+2-devel >= 2.1.2}
26 BuildRequires:  libjpeg-devel
27 BuildRequires:  libpng-devel
28 BuildRequires:  libtool >= 1:1.4.2-9
29 PreReq:         ghostscript-fonts-std
30 Requires(post): /sbin/ldconfig
31 Requires(post): sed
32 Requires:       sed
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %define         specflags_ia32  -fomit-frame-pointer
36
37 %description
38 libwmf is a library for unix like machines that can convert wmf files
39 into other formats, currently it supports fig, eps, a gd binding to
40 convert to png, and an X one to draw direct to an X window or pixmap.
41
42 %description -l pl
43 libwmf jest bibliotek± dla systemów uniksowych, która konwertuje pliki
44 wmf na inne formaty. Aktualnie obs³uguje formaty fig i eps, format png
45 poprzez bibliotekê gd oraz - poprzez biblioteki X Window - rysowanie w
46 okienku oraz format xpm.
47
48 %package devel
49 Summary:        libwmf - header files
50 Summary(pl):    libwmf - pliki nag³ówkowe
51 Group:          Development/Libraries
52 Requires:       %{name} = %{epoch}:%{version}-%{release}
53 # libwmflite(.la) has no additional deps
54 # libwmf(.la) needs freetype-devel, XFree86-devel, expat-devel, libjpeg-devel, libpng-devel
55
56 %description devel
57 This package contains libwmf header files.
58
59 %description devel -l pl
60 Pakiet zawiera pliki nag³ówkowe do biblioteki libwmf.
61
62 %package static
63 Summary:        libwmf - static libraries
64 Summary(pl):    libwmf - biblioteki statyczne
65 Group:          Development/Libraries
66 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
67
68 %description static
69 This package contains libwmf static libraries.
70
71 %description static -l pl
72 Pakiet zawiera statyczn± wersjê biblioteki libwmf.
73
74 %package gtk-loader
75 Summary:        WMF loader for gdk_pixbuf 2.x library
76 Summary(pl):    Modu³ wczytuj±cy WMF dla biblioteki gdk_pixbuf 2.x
77 Group:          X11/Libraries
78 Requires:       %{name} = %{epoch}:%{version}-%{release}
79
80 %description gtk-loader
81 WMF loader for gdk_pixbuf 2.x library.
82
83 %description gtk-loader -l pl
84 Modu³ wczytuj±cy WMF dla biblioteki gdk_pixbuf 2.x
85
86 %prep
87 %setup -q
88 %patch0 -p1
89 %patch1 -p1
90 %patch2 -p1
91
92 %build
93 %{__libtoolize}
94 %{__aclocal}
95 %{__autoheader}
96 %{__autoconf}
97 %{__automake}
98 %configure \
99         %{!?with_static_libs:--disable-static} \
100         --with-sysfontmap=%{_fontsdir}/ghostscript-fonts-std.font \
101         --with-gsfontmap=%{_fontsdir}/Type1/Fontmap \
102         --with-gsfontdir=%{_fontsdir}/Type1
103
104 %{__make}
105
106 %install
107 rm -rf $RPM_BUILD_ROOT
108
109 %{__make} install \
110         DESTDIR=$RPM_BUILD_ROOT
111
112 mv -f $RPM_BUILD_ROOT%{_datadir}/doc ./html-doc
113
114 # no static modules and *.la for gtk+ loaders - shut up check-files
115 rm -f $RPM_BUILD_ROOT%{_libdir}/gtk-2*/*/loaders/*.{a,la}
116
117 %clean
118 rm -rf $RPM_BUILD_ROOT
119
120 %post
121 /sbin/ldconfig
122 %{_bindir}/libwmf-fontmap >/dev/null
123
124 %postun -p /sbin/ldconfig
125
126 %files
127 %defattr(644,root,root,755)
128 %doc CREDITS ChangeLog README TODO
129 %attr(755,root,root) %{_bindir}/libwmf-fontmap
130 %attr(755,root,root) %{_bindir}/wmf2eps
131 %attr(755,root,root) %{_bindir}/wmf2fig
132 %attr(755,root,root) %{_bindir}/wmf2gd
133 %attr(755,root,root) %{_bindir}/wmf2svg
134 %attr(755,root,root) %{_bindir}/wmf2x
135 %attr(755,root,root) %{_libdir}/*.so.*.*
136 %dir %{_datadir}/libwmf
137 %dir %{_datadir}/libwmf/fonts
138 %ghost %{_datadir}/libwmf/fonts/fontmap
139
140 %files devel
141 %defattr(644,root,root,755)
142 %doc html-doc examples
143 %attr(755,root,root) %{_bindir}/libwmf-config
144 %attr(755,root,root) %{_libdir}/*.so
145 %{_libdir}/*.la
146 %{_includedir}/*
147
148 %if %{with static_libs}
149 %files static
150 %defattr(644,root,root,755)
151 %{_libdir}/*.a
152 %endif
153
154 %if %{with gtk}
155 %files gtk-loader
156 %defattr(644,root,root,755)
157 %attr(755,root,root) %{_libdir}/gtk-2*/*/loaders/*.so
158 %endif
This page took 0.041926 seconds and 4 git commands to generate.