]> git.pld-linux.org Git - packages/libvsqlitepp.git/blob - libvsqlitepp.spec
- unconditional noarch subpackages
[packages/libvsqlitepp.git] / libvsqlitepp.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library build
4 #
5 Summary:        Well designed C++ sqlite 3.x wrapper library
6 Summary(pl.UTF-8):      Dobrze zaprojektowana biblioteka obudowująca C++ dla sqlite 3.x
7 Name:           libvsqlitepp
8 Version:        0.3.13
9 Release:        3
10 License:        BSD
11 Group:          Libraries
12 Source0:        http://evilissimo.fedorapeople.org/releases/vsqlite--/%{version}/vsqlite++-%{version}.tar.xz
13 # Source0-md5:  f0616fd2680e0c78e50f78f6b869c0ba
14 URL:            https://github.com/vinzenz/vsqlite--
15 BuildRequires:  boost-devel >= 1.33
16 BuildRequires:  doxygen
17 BuildRequires:  graphviz
18 BuildRequires:  libstdc++-devel
19 BuildRequires:  sqlite3-devel >= 3
20 BuildRequires:  tar >= 1:1.22
21 BuildRequires:  xz
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 VSQLite++ is a C++ wrapper for sqlite3 using the C++ standard library
26 and Boost. VSQLite++ is designed to be easy to use and focuses on
27 simplicity.
28
29 %description -l pl.UTF-8
30 VSQLite++ to obudowanie C++ dla sqlite3 przy użyciu biblioteki
31 standardowej C++ oraz Boosta. Jest zaprojektowane z myślą o łatwym
32 użyciu, skupia się na prostocie.
33
34 %package devel
35 Summary:        Development files for VSQLite++ library
36 Summary(pl.UTF-8):      Pliki programistyczne biblioteki VSQLite++
37 Group:          Development/Libraries
38 Requires:       %{name} = %{version}-%{release}
39 Requires:       boost-devel >= 1.33
40 Requires:       libstdc++-devel
41
42 %description devel
43 This package contains development files for VSQLite++ library.
44
45 %description devel -l pl.UTF-8
46 Ten pakiet zawiera pliki programistyczne biblioteki VSQLite++.
47
48 %package static
49 Summary:        Static VSQLite++ library
50 Summary(pl.UTF-8):      Statyczna biblioteka VSQLite++
51 Group:          Development/Libraries
52 Requires:       %{name}-devel = %{version}-%{release}
53
54 %description static
55 Static VSQLite++ library.
56
57 %description static -l pl.UTF-8
58 Statyczna biblioteka VSQLite++.
59
60 %package doc
61 Summary:        Development documentation for VSQLite++ library
62 Summary(pl.UTF-8):      Dokumentacja programisty do biblioteki VSQLite++
63 Group:          Documentation
64 # noarch subpackages only when building with rpm5
65 BuildArch:      noarch
66
67 %description doc
68 This package contains development documentation files for VSQLite++.
69
70 %description doc -l pl.UTF-8
71 Ten pakiet zawiera dokumentację programisty do biblioteki VSQLite++.
72
73 %prep
74 %setup -q -n vsqlite++-%{version}
75
76 %build
77 %configure \
78         %{!?with_static_libs:--disable-static}
79 %{__make}
80 doxygen Doxyfile
81
82 %install
83 rm -rf $RPM_BUILD_ROOT
84 %{__make} install \
85         DESTDIR=$RPM_BUILD_ROOT
86
87 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libvsqlitepp.la
88
89 %clean
90 rm -rf $RPM_BUILD_ROOT
91
92 %post   -p /sbin/ldconfig
93 %postun -p /sbin/ldconfig
94
95 %files
96 %defattr(644,root,root,755)
97 %doc AUTHORS COPYING ChangeLog README TODO
98 %attr(755,root,root) %{_libdir}/libvsqlitepp.so.*.*.*
99 %attr(755,root,root) %ghost %{_libdir}/libvsqlitepp.so.3
100
101 %files devel
102 %defattr(644,root,root,755)
103 %doc examples/sqlite_wrapper.cpp
104 %attr(755,root,root) %{_libdir}/libvsqlitepp.so
105 %{_includedir}/sqlite
106
107 %if %{with static_libs}
108 %files static
109 %defattr(644,root,root,755)
110 %{_libdir}/libvsqlitepp.a
111 %endif
112
113 %files doc
114 %defattr(644,root,root,755)
115 %doc html/*
This page took 0.081589 seconds and 4 git commands to generate.