]> git.pld-linux.org Git - packages/libvpx.git/blob - libvpx.spec
- use dropin
[packages/libvpx.git] / libvpx.spec
1 #
2 # Conditional build:
3 %bcond_without  asm     # x86 assembler
4
5 Summary:        VP8, a high-quality video codec
6 Summary(pl.UTF-8):      VP8 - kodek obrazu wysokiej jakości
7 Name:           libvpx
8 Version:        1.3.0
9 Release:        1
10 License:        BSD
11 Group:          Libraries
12 #Source0Download: http://code.google.com/p/webm/downloads/list
13 #Source0:       https://webm.googlecode.com/files/%{name}-v%{version}.tar.bz2
14 # source, but regenerated on each fetch
15 #Source0:       https://chromium.googlesource.com/webm/libvpx/+archive/v%{version}.tar.gz?/%{name}-%{version}.tar.gz
16 Source0:        %{name}-%{version}.tar.gz
17 # Source0-md5:  dcf436a5dc8b56bdfb4aec63b2fe6729
18 URL:            http://www.webmproject.org/
19 BuildRequires:  /usr/bin/php
20 BuildRequires:  doxygen
21 BuildRequires:  php-common >= 4:5.0.0
22 BuildRequires:  php-pcre
23 BuildRequires:  sed >= 4.0
24 %ifarch %{ix86} %{x8664}
25 %{?with_asm:BuildRequires:      yasm >= 0.8}
26 %endif
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %define generic_target  generic-gnu
30 %define vpxtarget       %{generic_target}
31 %ifarch %{x8664}
32 %define vpxtarget       x86_64-linux-gcc
33 %endif
34 %ifarch %{ix86}
35 %define vpxtarget       x86-linux-gcc
36 %endif
37 %ifarch ppc
38 %define vpxtarget       ppc32-linux-gcc
39 %endif
40 %ifarch ppc64
41 %define vpxtarget       ppc64-linux-gcc
42 %endif
43
44 %description
45 VP8, a high-quality video codec.
46
47 %description -l pl.UTF-8
48 VP8 - kodek obrazu wysokiej jakości.
49
50 %package devel
51 Summary:        Header files for libvpx
52 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libvpx
53 Group:          Development/Libraries
54 Requires:       %{name} = %{version}-%{release}
55
56 %description devel
57 Header files for libvpx library.
58
59 %description devel -l pl.UTF-8
60 Pliki nagłówkowe biblioteki libvpx.
61
62 %package static
63 Summary:        Static libvpx library
64 Summary(pl.UTF-8):      Statyczna biblioteka libvpx
65 Group:          Development/Libraries
66 Requires:       %{name}-devel = %{version}-%{release}
67
68 %description static
69 Static libvpx library.
70
71 %description static -l pl.UTF-8
72 Statyczna biblioteka libvpx.
73
74 %prep
75 #%setup -q -n %{name}-v%{version}
76 %setup -q -c
77
78 %build
79 install -d obj
80 cd obj
81 # not autoconf configure
82 CFLAGS="%{rpmcflags} %{rpmcppflags}" \
83 ../configure \
84 %if %{with asm}
85         --as=yasm \
86 %endif
87         --target=%{vpxtarget} \
88 %if "%{vpxtarget}" != "%{generic_target}"
89         --enable-shared \
90 %endif
91         --disable-optimizations \
92         --enable-vp8 \
93         --enable-postproc \
94         --enable-runtime-cpu-detect
95
96 %{__make} verbose=true target=libs \
97         HAVE_GNU_STRIP=no \
98         CC="%{__cc}" \
99         LD="%{__cc}" \
100         LDFLAGS="%{rpmldflags}"
101
102 %{__make} verbose=true target=examples \
103         CC="%{__cc}" \
104         LD="%{__cc}" \
105         LDFLAGS="%{rpmldflags} -L."
106 %{__make} verbose=true target=docs
107
108 %install
109 rm -rf $RPM_BUILD_ROOT
110 install -d $RPM_BUILD_ROOT{%{_bindir},%{_includedir}/vpx,%{_libdir}}
111
112 %{__make} -C obj verbose=true install \
113         LIBSUBDIR=%{_lib} \
114         DIST_DIR=$RPM_BUILD_ROOT%{_prefix}
115
116 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libvpx.so.1.3
117
118 # adjust prefix and libdir
119 %{__sed} -i -e 's,^prefix=.*,prefix=%{_prefix},;s,^libdir=.*,libdir=%{_libdir},' $RPM_BUILD_ROOT%{_pkgconfigdir}/vpx.pc
120
121 %clean
122 rm -rf $RPM_BUILD_ROOT
123
124 %post   -p /sbin/ldconfig
125 %postun -p /sbin/ldconfig
126
127 %files
128 %defattr(644,root,root,755)
129 %doc AUTHORS CHANGELOG LICENSE PATENTS README
130 %attr(755,root,root) %{_bindir}/vp8_scalable_patterns
131 %attr(755,root,root) %{_bindir}/vp9_spatial_scalable_encoder
132 %attr(755,root,root) %{_bindir}/vpxdec
133 %attr(755,root,root) %{_bindir}/vpxenc
134 %attr(755,root,root) %{_libdir}/libvpx.so.*.*.*
135 %attr(755,root,root) %ghost %{_libdir}/libvpx.so.1
136
137 %files devel
138 %defattr(644,root,root,755)
139 %attr(755,root,root) %{_libdir}/libvpx.so
140 %{_includedir}/vpx
141 %{_pkgconfigdir}/vpx.pc
142
143 %files static
144 %defattr(644,root,root,755)
145 %{_libdir}/libvpx.a
This page took 0.17133 seconds and 4 git commands to generate.