]> git.pld-linux.org Git - packages/libvpx.git/blob - libvpx.spec
5f3065272272b42a33a2a6aedb5699d9b0eb48bf
[packages/libvpx.git] / libvpx.spec
1 #
2 # Conditional build:
3 %bcond_without  asm     # x86 assembler
4 #
5 Summary:        VP8, a high-quality video codec
6 Summary(pl.UTF-8):      VP8 - kodek obrazu wysokiej jakości
7 Name:           libvpx
8 Version:        0.9.5
9 Release:        1
10 License:        BSD
11 Group:          Libraries
12 #Source0-Download: http://code.google.com/p/webm/downloads/list
13 Source0:        http://webm.googlecode.com/files/%{name}-v%{version}.tar.bz2
14 # Source0-md5:  4bf2f2c76700202c1fe9201fcb0680e3
15 Source1:        %{name}.ver
16 Patch0:         %{name}-0.9.0-no-explicit-dep-on-static-lib.patch
17 URL:            http://www.webmproject.org/
18 BuildRequires:  /usr/bin/php
19 BuildRequires:  doxygen
20 BuildRequires:  php-common >= 4:5.0.0
21 BuildRequires:  php-pcre
22 %ifarch %{ix86} %{x8664}
23 %{?with_asm:BuildRequires:      yasm}
24 %endif
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 VP8, a high-quality video codec.
29
30 %description -l pl.UTF-8
31 VP8 - kodek obrazu wysokiej jakości.
32
33 %package devel
34 Summary:        Header files for libvpx
35 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libvpx
36 Group:          Development/Libraries
37 Requires:       %{name} = %{version}-%{release}
38
39 %description devel
40 Header files for libvpx library.
41
42 %description devel -l pl.UTF-8
43 Pliki nagłówkowe biblioteki libvpx.
44
45 %package static
46 Summary:        Static libvpx library
47 Summary(pl.UTF-8):      Statyczna biblioteka libvpx
48 Group:          Development/Libraries
49 Requires:       %{name}-devel = %{version}-%{release}
50
51 %description static
52 Static libvpx library.
53
54 %description static -l pl.UTF-8
55 Statyczna biblioteka libvpx.
56
57 %prep
58 %setup -q -n %{name}-v%{version}
59 %patch0 -p1
60
61 %build
62 install -d obj
63 cd obj
64 # not autoconf configure
65 CFLAGS="%{rpmcflags} %{rpmcppflags}" \
66 ../configure \
67 %if %{with asm}
68 %ifarch %{x8664}
69         --target=x86_64-linux-gcc \
70 %endif
71 %ifarch %{ix86}
72         --target=x86-linux-gcc \
73 %endif
74 %else
75         --target=generic-gnu \
76 %endif
77         --enable-pic \
78         --disable-optimizations \
79         --enable-vp8 \
80         --enable-postproc \
81         --enable-runtime-cpu-detect
82
83 # disable stripping
84 sed -i "s|STRIP=.*|STRIP=|g" {libs,examples,docs}-*.mk
85
86 %{__make} verbose=true target=libs \
87         CC="%{__cc}"
88
89 mkdir tmp
90 cd tmp
91 ar x ../libvpx_g.a
92 cd ..
93 %{__cc} %{rpmldflags} -fPIC -shared \
94         -Wl,--no-undefined -Wl,-soname,libvpx.so.0 -Wl,--version-script,%{SOURCE1} -Wl,-z,noexecstack \
95         -o libvpx.so.0.0.0 tmp/*.o \
96         -pthread -lm
97 rm -rf tmp
98
99 # Temporarily dance the static libs out of the way
100 mv libvpx.a libNOTvpx.a
101 mv libvpx_g.a libNOTvpx_g.a
102
103 # We need to do this so the examples can link against it.
104 ln -sf libvpx.so.0.0.0 libvpx.so
105
106 %{__make} verbose=true target=examples \
107         CC="%{__cc}"
108 %{__make} verbose=true target=docs
109
110 # Put them back so the install doesn't fail
111 mv libNOTvpx.a libvpx.a
112 mv libNOTvpx_g.a libvpx_g.a
113
114 %install
115 rm -rf $RPM_BUILD_ROOT
116 install -d $RPM_BUILD_ROOT{%{_bindir},%{_includedir}/vpx,%{_libdir}}
117
118 install -d outdir
119 %{__make} -C obj install \
120         DIST_DIR=$(pwd)/outdir
121
122 install -p outdir/bin/* $RPM_BUILD_ROOT%{_bindir}
123 install -p obj/libvpx.so.* $RPM_BUILD_ROOT%{_libdir}
124 ln -s libvpx.so.0.0.0 $RPM_BUILD_ROOT%{_libdir}/libvpx.so.0
125 ln -s libvpx.so.0.0.0 $RPM_BUILD_ROOT%{_libdir}/libvpx.so
126
127 cp -a outdir/include/vpx/*.h $RPM_BUILD_ROOT%{_includedir}/vpx
128 cp -a outdir/lib/*.a $RPM_BUILD_ROOT%{_libdir}
129
130 %clean
131 rm -rf $RPM_BUILD_ROOT
132
133 %post   -p /sbin/ldconfig
134 %postun -p /sbin/ldconfig
135
136 %files
137 %defattr(644,root,root,755)
138 %doc AUTHORS CHANGELOG LICENSE PATENTS README
139 %attr(755,root,root) %{_bindir}/vpxdec
140 %attr(755,root,root) %{_bindir}/vpxenc
141 %attr(755,root,root) %{_libdir}/libvpx.so.*.*.*
142 %attr(755,root,root) %ghost %{_libdir}/libvpx.so.0
143
144 %files devel
145 %defattr(644,root,root,755)
146 %attr(755,root,root) %{_libdir}/libvpx.so
147 %{_includedir}/vpx
148
149 %files static
150 %defattr(644,root,root,755)
151 %{_libdir}/libvpx.a
This page took 0.054835 seconds and 2 git commands to generate.