]> git.pld-linux.org Git - packages/libsmi.git/commitdiff
Fix build with automake 1.13 and -Werror=format-security
authorMarcin Banasiak <marcin.banasiak@gmail.com>
Tue, 5 Feb 2013 12:05:55 +0000 (13:05 +0100)
committerMarcin Banasiak <marcin.banasiak@gmail.com>
Tue, 5 Feb 2013 12:05:55 +0000 (13:05 +0100)
libsmi-am.patch [new file with mode: 0644]
libsmi-format-security.patch [new file with mode: 0644]
libsmi.spec

diff --git a/libsmi-am.patch b/libsmi-am.patch
new file mode 100644 (file)
index 0000000..8f522b6
--- /dev/null
@@ -0,0 +1,11 @@
+--- libsmi-0.4.8/configure.in.newautomake      2013-02-05 12:56:47.028569291 +0100
++++ libsmi-0.4.8/configure.in  2013-02-05 12:56:58.745172483 +0100
+@@ -24,7 +24,7 @@ VERSION_STRING="$LIBSMI_MAJOR.$LIBSMI_MI
+ VERSION_LIBTOOL="$LIBTOOL_VERSION:$LIBTOOL_REVISION:$LIBTOOL_AGE"
+ AM_INIT_AUTOMAKE(libsmi,$VERSION_STRING)
+-AM_CONFIG_HEADER(config.h)
++AC_CONFIG_HEADERS(config.h)
+ AC_DEFINE([MAX_LEX_DEPTH], 30,
+ [The maximum module import recursion depth.])
diff --git a/libsmi-format-security.patch b/libsmi-format-security.patch
new file mode 100644 (file)
index 0000000..4ce1738
--- /dev/null
@@ -0,0 +1,20 @@
+--- libsmi-0.4.8/tools/dump-tree.c.formatsec   2013-02-05 13:00:54.907226417 +0100
++++ libsmi-0.4.8/tools/dump-tree.c     2013-02-05 13:01:49.217530638 +0100
+@@ -117,7 +117,7 @@ static void fprintIndex(FILE *f, SmiNode
+        smiElement; smiElement = smiGetNextElement(smiElement), i++) {
+       if (i > 0) fprintf(f, ",");
+       if (indexname) {
+-          fprintf(f, indexname);
++          fputs(indexname, f);
+       }
+       indexname = smiGetElementNode(smiElement)->name;
+     }
+@@ -143,7 +143,7 @@ static void fprintObjects(FILE *f, SmiNo
+        smiElement = smiGetNextElement(smiElement), i++) {
+       if (i > 0) fprintf(f, ",");
+       if (objectname) {
+-          fprintf(f, objectname);
++          fputs(objectname, f);
+       }
+       objectname = smiGetElementNode(smiElement)->name;
+     }
index 219971d1dc9a5ae71b96624f6c4990b06a5fa3d3..dd6482795c2eb4f90bc8d6d33519b6ee03045584 100644 (file)
@@ -11,6 +11,8 @@ Source0:      ftp://ftp.ibr.cs.tu-bs.de/pub/local/libsmi/%{name}-%{version}.tar.gz
 # Source0-md5: 760b6b1070738158708649ed2c63425e
 Source1:       %{name}-smi.conf
 Patch0:                flat-mibdir.patch
+Patch1:                %{name}-am.patch
+Patch2:                %{name}-format-security.patch
 URL:           http://www.ibr.cs.tu-bs.de/projects/libsmi/
 BuildRequires: autoconf
 BuildRequires: automake
@@ -149,6 +151,8 @@ Dane PIB (Policy Information Base) dostarczane przez LibSMI.
 %prep
 %setup -q
 %patch0 -p1
+%patch1 -p1
+%patch2 -p1
 
 find '(' -name '*~' -o -name '*.orig' -o -name '*-orig' ')' -print0 | xargs -0 -r -l512 rm -f
 
This page took 0.181253 seconds and 4 git commands to generate.