]> git.pld-linux.org Git - packages/libsidplay2.git/commitdiff
debian patch to fix build with gcc >= 6 master
authorJan Palus <atler@pld-linux.org>
Thu, 21 Jan 2021 17:47:32 +0000 (18:47 +0100)
committerJan Palus <atler@pld-linux.org>
Thu, 21 Jan 2021 17:47:32 +0000 (18:47 +0100)
gcc6-fixes.patch [new file with mode: 0644]
libsidplay2.spec

diff --git a/gcc6-fixes.patch b/gcc6-fixes.patch
new file mode 100644 (file)
index 0000000..7cfac32
--- /dev/null
@@ -0,0 +1,22 @@
+Description: explicit cast to int8_t
+ Fix FTBFS with GCC 6 due to narrowing conversions from 'char' to 'int8_t'.
+Author: Laszlo Boszormenyi (GCS) <gcs@debian.org>
+Forwarded: no
+Bug-Debian: https://bugs.debian.org/837378
+Last-Update: 2016-09-19
+
+---
+
+--- sidplay-libs-2.1.1.orig/libsidplay/src/xsid/xsid.cpp
++++ sidplay-libs-2.1.1/libsidplay/src/xsid/xsid.cpp
+@@ -96,8 +96,8 @@ const int8_t XSID::sampleConvertTable[16
+ */
+ const int8_t XSID::sampleConvertTable[16] =
+ {
+-    '\x80', '\x94', '\xa9', '\xbc', '\xce', '\xe1', '\xf2', '\x03',
+-    '\x1b', '\x2a', '\x3b', '\x49', '\x58', '\x66', '\x73', '\x7f'
++    (int8_t)'\x80', (int8_t)'\x94', (int8_t)'\xa9', (int8_t)'\xbc', (int8_t)'\xce', (int8_t)'\xe1', (int8_t)'\xf2', (int8_t)'\x03',
++    (int8_t)'\x1b', (int8_t)'\x2a', (int8_t)'\x3b', (int8_t)'\x49', (int8_t)'\x58', (int8_t)'\x66', (int8_t)'\x73', (int8_t)'\x7f'
+ };
+ const char *XSID::credit =
index a36fbb200a8ecded231f7974b9175c63e5fff42e..0a0cd9129ac33ed8dafa8695de06bc55950fccd8 100644 (file)
@@ -10,6 +10,7 @@ Source0:      http://downloads.sourceforge.net/sidplay2/sidplay-libs-%{version}.tar.g
 Patch0:                gcc4-fixes.patch
 Patch1:                configure-fixes.patch
 Patch2:                pkg-config.patch
+Patch3:                gcc6-fixes.patch
 URL:           http://sidplay2.sourceforge.net/
 BuildRequires: autoconf >= 2.50
 BuildRequires: automake
@@ -62,6 +63,7 @@ Ten pakiet zawiera statycznÄ… wersjÄ™ libsidplay.
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
+%patch3 -p1
 
 %build
 cd libsidplay
This page took 0.233546 seconds and 4 git commands to generate.