]> git.pld-linux.org Git - packages/libsidplay2.git/commitdiff
- fix building on gcc 3.4
authorwolf <wolf@pld-linux.org>
Mon, 21 Feb 2005 22:45:06 +0000 (22:45 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    libsidplay2-gcc34.patch -> 1.1
    libsidplay2.spec -> 1.7

libsidplay2-gcc34.patch [new file with mode: 0644]
libsidplay2.spec

diff --git a/libsidplay2-gcc34.patch b/libsidplay2-gcc34.patch
new file mode 100644 (file)
index 0000000..6201cdf
--- /dev/null
@@ -0,0 +1,50 @@
+--- sidplay-libs-2.1.1.orig/libsidplay/include/sidplay/SmartPtr.h
++++ sidplay-libs-2.1.1/libsidplay/include/sidplay/SmartPtr.h
+@@ -17,16 +17,16 @@
+               doFree = bufOwner;
+               if ( bufferLen >= 1 )
+               {
+-                      pBufCurrent = ( bufBegin = buffer );
+-                      bufEnd = bufBegin + bufferLen;
+-                      bufLen = bufferLen;
+-                      status = true;
++                      this->pBufCurrent = ( this->bufBegin = buffer );
++                      this->bufEnd = this->bufBegin + bufferLen;
++                      this->bufLen = bufferLen;
++                      this->status = true;
+               }
+               else
+               {
+-                      pBufCurrent = ( bufBegin = ( bufEnd = 0 ));
+-                      bufLen = 0;
+-                      status = false;
++                      this->pBufCurrent = ( this->bufBegin = ( this->bufEnd = 0 ));
++                      this->bufLen = 0;
++                      this->status = false;
+               }
+       }
+       
+@@ -211,16 +211,16 @@
+       {
+               if ( bufferLen >= 1 )
+               {
+-                      pBufCurrent = ( bufBegin = buffer );
+-                      bufEnd = bufBegin + bufferLen;
+-                      bufLen = bufferLen;
+-                      status = true;
++                      this->pBufCurrent = ( this->bufBegin = buffer );
++                      this->bufEnd = this->bufBegin + bufferLen;
++                      this->bufLen = bufferLen;
++                      this->status = true;
+               }
+               else
+               {
+-                      pBufCurrent = bufBegin = bufEnd = 0;
+-                      bufLen = 0;
+-                      status = false;
++                      this->pBufCurrent = this->bufBegin = this->bufEnd = 0;
++                      this->bufLen = 0;
++                      this->status = false;
+               }
+       }
+ };
index 084892943770375784ad7bf140118bddee8083f5..e0526e9c9ccb6f7e49717f228d36ede3ba0c7869 100644 (file)
@@ -7,6 +7,7 @@ License:        GPL
 Group:         Libraries
 Source0:       http://dl.sourceforge.net/sidplay2/sidplay-libs-%{version}.tar.gz
 # Source0-md5: 7ea0ba5dc1da4604d15eaae001f7d2a7
+Patch0:                %{name}-gcc34.patch
 URL:           http://sidplay2.sourceforge.net/
 BuildRequires: automake
 BuildRequires: libstdc++-devel
@@ -54,6 +55,7 @@ Ten pakiet zawiera statyczn
 
 %prep
 %setup -q -n sidplay-libs-%{version}
+%patch0 -p1
 
 %build
 cp -f /usr/share/automake/config.* unix
This page took 0.040203 seconds and 4 git commands to generate.