]> git.pld-linux.org Git - packages/libsecret.git/blob - libsecret.spec
- release 2 (by relup.sh)
[packages/libsecret.git] / libsecret.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # disable gtk-doc
4 %bcond_without  static_libs     # don't build static library
5 %bcond_without  vala            # do not build Vala API
6
7 Summary:        Library for storing and retrieving passwords and other secrets
8 Summary(pl.UTF-8):      Biblioteka do przechowywania i odczytu haseł oraz innych tajnych informacji
9 Name:           libsecret
10 Version:        0.18.8
11 Release:        2
12 License:        LGPL v2.1+
13 Group:          Libraries
14 Source0:        http://ftp.gnome.org/pub/GNOME/sources/libsecret/0.18/%{name}-%{version}.tar.xz
15 # Source0-md5:  fee403988442f497f3c1dfe7b128869c
16 URL:            https://live.gnome.org/Libsecret
17 BuildRequires:  autoconf >= 2.63
18 BuildRequires:  automake >= 1:1.11
19 BuildRequires:  gettext-tools >= 0.19.8
20 BuildRequires:  glib2-devel >= 1:2.44.0
21 BuildRequires:  gobject-introspection-devel >= 1.29
22 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.9}
23 BuildRequires:  libgcrypt-devel >= 1.2.2
24 BuildRequires:  libxslt-progs
25 BuildRequires:  pkgconfig
26 %{?with_vala:BuildRequires:     vala >= 2:0.17.2.12}
27 Requires:       glib2 >= 1:2.44.0
28 Requires:       libgcrypt >= 1.2.2
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 libsecret is a library for storing and retrieving passwords and other
33 secrets. It communicates with the "Secret Service" using DBus.
34 gnome-keyring and KSecretService are both implementations of a Secret
35 Service.
36
37 %description -l pl.UTF-8
38 libsecret to biblioteka do przechowywania i odczytu haseł oraz innych
39 tajnych informacji. Komunikuje się z usługą informacji tajnych
40 ("Secret Service") poprzez DBus. Zarówno gnome-keyring, jak i
41 KSecretService są implementacjami tej usługi.
42
43 %package devel
44 Summary:        Header files for libsecret library
45 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libsecret
46 Group:          Development/Libraries
47 Requires:       %{name} = %{version}-%{release}
48 Requires:       glib2-devel >= 1:2.38.0
49 Requires:       libgcrypt-devel >= 1.2.2
50
51 %description devel
52 Header files for libsecret library.
53
54 %description devel -l pl.UTF-8
55 Pliki nagłówkowe biblioteki libsecret.
56
57 %package static
58 Summary:        Static libsecret library
59 Summary(pl.UTF-8):      Statyczna biblioteka libsecret
60 Group:          Development/Libraries
61 Requires:       %{name}-devel = %{version}-%{release}
62
63 %description static
64 Static libsecret library.
65
66 %description static -l pl.UTF-8
67 Statyczna biblioteka libsecret.
68
69 %package apidocs
70 Summary:        libsecret API documentation
71 Summary(pl.UTF-8):      Dokumentacja API biblioteki libsecret
72 Group:          Documentation
73 %if "%{_rpmversion}" >= "5"
74 BuildArch:      noarch
75 %endif
76
77 %description apidocs
78 libsecret API documentation.
79
80 %description apidocs -l pl.UTF-8
81 Dokumentacja API biblioteki libsecret.
82
83 %package -n vala-libsecret
84 Summary:        libsecret API for Vala language
85 Summary(pl.UTF-8):      API libsecret dla języka Vala
86 Group:          Development/Libraries
87 Requires:       %{name}-devel = %{version}-%{release}
88 Requires:       vala >= 2:0.17.2.12
89 %if "%{_rpmversion}" >= "5"
90 BuildArch:      noarch
91 %endif
92
93 %description -n vala-libsecret
94 libsecret API for Vala language.
95
96 %description -n vala-libsecret -l pl.UTF-8
97 API libsecret dla języka Vala.
98
99 %prep
100 %setup -q
101
102 %build
103 %{__gettextize}
104 %{__libtoolize}
105 %{__aclocal} -I build/m4
106 %{__autoconf}
107 %{__autoheader}
108 %{__automake}
109 %configure \
110         --disable-silent-rules \
111         %{__enable_disable static_libs static} \
112         %{__enable_disable apidocs gtk-doc} \
113         %{__enable_disable vala vala} \
114         --with-html-dir=%{_gtkdocdir}/%{name}
115 %{__make}
116
117 %install
118 rm -rf $RPM_BUILD_ROOT
119
120 %{__make} install \
121         DESTDIR=$RPM_BUILD_ROOT
122
123 %find_lang libsecret
124
125 %clean
126 rm -rf $RPM_BUILD_ROOT
127
128 %post   -p /sbin/ldconfig
129 %postun -p /sbin/ldconfig
130
131 %files -f libsecret.lang
132 %defattr(644,root,root,755)
133 %doc AUTHORS ChangeLog NEWS README
134 %attr(755,root,root) %{_bindir}/secret-tool
135 %attr(755,root,root) %{_libdir}/libsecret-1.so.*.*.*
136 %attr(755,root,root) %ghost %{_libdir}/libsecret-1.so.0
137 %{_libdir}/girepository-1.0/Secret-1.typelib
138 %{_mandir}/man1/secret-tool.1*
139
140 %files devel
141 %defattr(644,root,root,755)
142 %attr(755,root,root) %{_libdir}/libsecret-1.so
143 %{_libdir}/libsecret-1.la
144 %{_includedir}/libsecret-1
145 %{_pkgconfigdir}/libsecret-1.pc
146 %{_pkgconfigdir}/libsecret-unstable.pc
147 %{_datadir}/gir-1.0/Secret-1.gir
148
149 %if %{with static_libs}
150 %files static
151 %defattr(644,root,root,755)
152 %{_libdir}/libsecret-1.a
153 %endif
154
155 %if %{with apidocs}
156 %files apidocs
157 %defattr(644,root,root,755)
158 %{_gtkdocdir}/%{name}
159 %endif
160
161 %if %{with vala}
162 %files -n vala-libsecret
163 %defattr(644,root,root,755)
164 %{_datadir}/vala/vapi/libsecret-1.deps
165 %{_datadir}/vala/vapi/libsecret-1.vapi
166 %endif
This page took 0.058263 seconds and 3 git commands to generate.