]> git.pld-linux.org Git - packages/libsecret.git/blob - libsecret.spec
4c35659d0d4d5130f0b4d6b93f5c2a1c7c04c4ca
[packages/libsecret.git] / libsecret.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # disable gtk-doc
4 %bcond_without  static_libs     # don't build static library
5 %bcond_without  vala            # do not build Vala API
6
7 Summary:        Library for storing and retrieving passwords and other secrets
8 Summary(pl.UTF-8):      Biblioteka do przechowywania i odczytu haseł oraz innych tajnych informacji
9 Name:           libsecret
10 Version:        0.20.0
11 Release:        1
12 License:        LGPL v2.1+
13 Group:          Libraries
14 Source0:        http://ftp.gnome.org/pub/GNOME/sources/libsecret/0.20/%{name}-%{version}.tar.xz
15 # Source0-md5:  335750caeed47f50496b3b0e6a1875ff
16 URL:            https://wiki.gnome.org/Projects/Libsecret
17 BuildRequires:  autoconf >= 2.63
18 BuildRequires:  automake >= 1:1.11
19 BuildRequires:  gettext-tools >= 0.19.8
20 BuildRequires:  glib2-devel >= 1:2.44.0
21 BuildRequires:  gobject-introspection-devel >= 1.29
22 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.9}
23 BuildRequires:  libgcrypt-devel >= 1.2.2
24 BuildRequires:  libtool
25 BuildRequires:  libxslt-progs
26 BuildRequires:  pkgconfig
27 %{?with_vala:BuildRequires:     vala >= 2:0.17.2.12}
28 Requires:       glib2 >= 1:2.44.0
29 Requires:       libgcrypt >= 1.2.2
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 libsecret is a library for storing and retrieving passwords and other
34 secrets. It communicates with the "Secret Service" using DBus.
35 gnome-keyring and KSecretService are both implementations of a Secret
36 Service.
37
38 %description -l pl.UTF-8
39 libsecret to biblioteka do przechowywania i odczytu haseł oraz innych
40 tajnych informacji. Komunikuje się z usługą informacji tajnych
41 ("Secret Service") poprzez DBus. Zarówno gnome-keyring, jak i
42 KSecretService są implementacjami tej usługi.
43
44 %package devel
45 Summary:        Header files for libsecret library
46 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libsecret
47 Group:          Development/Libraries
48 Requires:       %{name} = %{version}-%{release}
49 Requires:       glib2-devel >= 1:2.38.0
50 Requires:       libgcrypt-devel >= 1.2.2
51
52 %description devel
53 Header files for libsecret library.
54
55 %description devel -l pl.UTF-8
56 Pliki nagłówkowe biblioteki libsecret.
57
58 %package static
59 Summary:        Static libsecret library
60 Summary(pl.UTF-8):      Statyczna biblioteka libsecret
61 Group:          Development/Libraries
62 Requires:       %{name}-devel = %{version}-%{release}
63
64 %description static
65 Static libsecret library.
66
67 %description static -l pl.UTF-8
68 Statyczna biblioteka libsecret.
69
70 %package apidocs
71 Summary:        libsecret API documentation
72 Summary(pl.UTF-8):      Dokumentacja API biblioteki libsecret
73 Group:          Documentation
74 %if "%{_rpmversion}" >= "5"
75 BuildArch:      noarch
76 %endif
77
78 %description apidocs
79 libsecret API documentation.
80
81 %description apidocs -l pl.UTF-8
82 Dokumentacja API biblioteki libsecret.
83
84 %package -n vala-libsecret
85 Summary:        libsecret API for Vala language
86 Summary(pl.UTF-8):      API libsecret dla języka Vala
87 Group:          Development/Libraries
88 Requires:       %{name}-devel = %{version}-%{release}
89 Requires:       vala >= 2:0.17.2.12
90 %if "%{_rpmversion}" >= "5"
91 BuildArch:      noarch
92 %endif
93
94 %description -n vala-libsecret
95 libsecret API for Vala language.
96
97 %description -n vala-libsecret -l pl.UTF-8
98 API libsecret dla języka Vala.
99
100 %prep
101 %setup -q
102
103 %build
104 %{__gettextize}
105 %{__libtoolize}
106 %{__aclocal} -I build/m4
107 %{__autoconf}
108 %{__autoheader}
109 %{__automake}
110 %configure \
111         %{__enable_disable apidocs gtk-doc} \
112         --disable-silent-rules \
113         %{__enable_disable static_libs static} \
114         %{__enable_disable vala vala} \
115         --with-html-dir=%{_gtkdocdir}/%{name}
116 %{__make}
117
118 %install
119 rm -rf $RPM_BUILD_ROOT
120
121 %{__make} install \
122         DESTDIR=$RPM_BUILD_ROOT
123
124 # obsoleted by pkg-config
125 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libsecret-1.la
126
127 %find_lang libsecret
128
129 %clean
130 rm -rf $RPM_BUILD_ROOT
131
132 %post   -p /sbin/ldconfig
133 %postun -p /sbin/ldconfig
134
135 %files -f libsecret.lang
136 %defattr(644,root,root,755)
137 %doc AUTHORS ChangeLog NEWS README
138 %attr(755,root,root) %{_bindir}/secret-tool
139 %attr(755,root,root) %{_libdir}/libsecret-1.so.*.*.*
140 %attr(755,root,root) %ghost %{_libdir}/libsecret-1.so.0
141 %{_libdir}/girepository-1.0/Secret-1.typelib
142 %{_mandir}/man1/secret-tool.1*
143
144 %files devel
145 %defattr(644,root,root,755)
146 %attr(755,root,root) %{_libdir}/libsecret-1.so
147 %{_includedir}/libsecret-1
148 %{_pkgconfigdir}/libsecret-1.pc
149 %{_pkgconfigdir}/libsecret-unstable.pc
150 %{_datadir}/gir-1.0/Secret-1.gir
151
152 %if %{with static_libs}
153 %files static
154 %defattr(644,root,root,755)
155 %{_libdir}/libsecret-1.a
156 %endif
157
158 %if %{with apidocs}
159 %files apidocs
160 %defattr(644,root,root,755)
161 %{_gtkdocdir}/%{name}
162 %endif
163
164 %if %{with vala}
165 %files -n vala-libsecret
166 %defattr(644,root,root,755)
167 %{_datadir}/vala/vapi/libsecret-1.deps
168 %{_datadir}/vala/vapi/libsecret-1.vapi
169 %endif
This page took 0.381461 seconds and 2 git commands to generate.