]> git.pld-linux.org Git - packages/libprelude.git/commitdiff
- fix for python 3.8
authorMarcin Krol <hawk@tld-linux.org>
Sat, 14 Dec 2019 23:43:21 +0000 (00:43 +0100)
committerMarcin Krol <hawk@tld-linux.org>
Sat, 14 Dec 2019 23:43:21 +0000 (00:43 +0100)
libprelude.spec
python-3.8-fix.patch [new file with mode: 0644]

index d2cdc1df5cbcd5e56d4c133517b80c9a6cb16c79..c1dfc954071a99ddfdbcf9ff686b183c6144b90d 100644 (file)
@@ -15,7 +15,7 @@ Summary:      The Prelude library
 Summary(pl.UTF-8):     Biblioteka Prelude
 Name:          libprelude
 Version:       5.1.1
-Release:       2
+Release:       3
 License:       GPL v2 or commercial
 Group:         Libraries
 #Source0Download: https://www.prelude-siem.org/projects/prelude/files
@@ -24,6 +24,7 @@ Source0:      https://www.prelude-siem.org/attachments/download/1181/%{name}-%{versio
 Patch0:                python-install.patch
 Patch1:                %{name}-lua.patch
 Patch2:                gtk-doc-1.32.patch
+Patch3:                python-3.8-fix.patch
 URL:           https://www.prelude-siem.org/
 BuildRequires: autoconf >= 2.59
 BuildRequires: automake >= 1:1.9
@@ -231,6 +232,7 @@ Wiązania języka Ruby do libprelude.
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
+%patch3 -p1
 
 %if %{with python3}
 # regenerate with fresh swig for python 3.5+
diff --git a/python-3.8-fix.patch b/python-3.8-fix.patch
new file mode 100644 (file)
index 0000000..187c091
--- /dev/null
@@ -0,0 +1,11 @@
+--- libprelude-5.1.0/bindings/python/_prelude.cxx      2019-07-12 07:19:49.365476420 +0200
++++ libprelude-5.1.0/bindings/python/_prelude.cxx      2019-07-12 07:20:02.458213034 +0200
+@@ -3132,7 +3132,7 @@
+ SWIGINTERN void
+ SwigPyStaticVar_dealloc(PyDescrObject *descr) {
+-  _PyObject_GC_UNTRACK(descr);
++  PyObject_GC_UnTrack(descr);
+   Py_XDECREF(PyDescr_TYPE(descr));
+   Py_XDECREF(PyDescr_NAME(descr));
+   PyObject_GC_Del(descr);
This page took 0.131108 seconds and 4 git commands to generate.