]> git.pld-linux.org Git - packages/liborcus.git/commitdiff
upstream fixes for gcc 13
authorJan Palus <atler@pld-linux.org>
Thu, 29 Jun 2023 20:21:02 +0000 (22:21 +0200)
committerJan Palus <atler@pld-linux.org>
Thu, 29 Jun 2023 20:21:02 +0000 (22:21 +0200)
gcc-13.patch [new file with mode: 0644]
liborcus.spec

diff --git a/gcc-13.patch b/gcc-13.patch
new file mode 100644 (file)
index 0000000..ada4416
--- /dev/null
@@ -0,0 +1,52 @@
+From fa68d6a76778df26e41108e3400f4a907e351203 Mon Sep 17 00:00:00 2001
+From: Kohei Yoshida <kohei.yoshida@gmail.com>
+Date: Tue, 19 Jul 2022 21:11:16 -0400
+Subject: [PATCH] Explicitly include <cstdint> header with GCC 13 (#162)
+
+c.f. https://gcc.gnu.org/gcc-13/porting_to.html#header-dep-changes
+---
+ include/orcus/types.hpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/include/orcus/types.hpp b/include/orcus/types.hpp
+index f5ec320de..46edd1ca0 100644
+--- a/include/orcus/types.hpp
++++ b/include/orcus/types.hpp
+@@ -8,6 +8,7 @@
+ #ifndef INCLUDED_ORCUS_TYPES_HPP
+ #define INCLUDED_ORCUS_TYPES_HPP
++#include <cstdint>
+ #include <cstdlib>
+ #include <vector>
+ #include <string>
+-- 
+GitLab
+
+From ce66c0fb64c667e78476f8611eb5f097ec572f0a Mon Sep 17 00:00:00 2001
+From: WANG Xuerui <xen0n@gentoo.org>
+Date: Tue, 23 Aug 2022 15:35:38 +0800
+Subject: [PATCH] Include <cstdint> in base64.hpp too
+
+This is also necessary for building with gcc-13.
+
+Signed-off-by: WANG Xuerui <xen0n@gentoo.org>
+---
+ include/orcus/base64.hpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/include/orcus/base64.hpp b/include/orcus/base64.hpp
+index f880b7fe7..44c70175d 100644
+--- a/include/orcus/base64.hpp
++++ b/include/orcus/base64.hpp
+@@ -9,6 +9,7 @@
+ #define __ORCUS_BASE64_HPP__
+ #include "env.hpp"
++#include <cstdint>
+ #include <vector>
+ #include <string>
+-- 
+GitLab
+
index 3b047ce58d74e1fd365a4f91851888ffcbace33b..1bd5596051d2427401aa753b6a90dbd025382d9a 100644 (file)
@@ -17,6 +17,7 @@ Group:                Libraries
 Source0:       https://kohei.us/files/orcus/src/%{name}-%{version}.tar.xz
 # Source0-md5: 4df3646ca736fa0d04965e25fee4898e
 Patch0:                %{name}-flags.patch
+Patch1:                gcc-13.patch
 URL:           https://gitlab.com/orcus/orcus
 BuildRequires: autoconf >= 2.65
 BuildRequires: automake >= 1:1.11
@@ -149,6 +150,7 @@ Wiązanie Pythona 3 do biblioteki liborcus.
 %prep
 %setup -q
 %patch0 -p1
+%patch1 -p1
 
 %build
 %{__libtoolize}
This page took 0.182086 seconds and 4 git commands to generate.